Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 17.03.2014, 14:44  postituse pealkiri:  (teema puudub)  

natsa kirjutas:

Kustuta vana /.pki ära, pane ID-kaart lugejasse, ava Chrome ja tekita uus.

On juba traditsiooniks saanud, et minul niipalju vedamist ei ole.
Tekitasin uue pki, aga chrome ei suhtle üldse enam kaardi lugejaga. Id kaardi utiliit töötab ja loeb kaardilt andmeid.
Proovisin ka teminali sisestada: modutil -dbdir sql:$HOME/.pki/nssdb -add opensc-pkcs11 -libfile opensc-pkcs11.so -mechanisms FRIENDLY" küll töötava chomrga ja ilma. Terminalis tekkib järgmise rea algusse ">" märk ja kõik.
Uus pkcs11.txt näeb ka teistmoodi välja:
Kood:
library=
name=NSS Internal PKCS #11 Module
parameters=configdir='sql:/home/henno/.pki/nssdb' certPrefix='' keyPrefix='' secmod='secmod.db' flags=optimizeSpace updatedir='' updateCertPrefix='' updateKeyPrefix='' updateid='' updateTokenDescription=''
NSS=Flags=internal,critical trustOrder=75 cipherOrder=100 slotParams=(1={slotFlags=[RSA,DSA,DH,RC2,RC4,DES,RANDOM,SHA1,MD5,MD2,SSL,TLS,AES,Camellia,SEED,SHA256,SHA512] askpw=any timeout=30})


Edit Siiski, siiski Smile
Tundub hetkel, et sain tööle. Kaks korda panka sisenetud ja mõlemad korrad küsis pin1 Very Happy
Kombineerides vana pkcs11.txt faili ja natsa postitust, siis lisasin uue pkcs11.txt faili lõppu järgmised read:
Kood:
library=opensc-pkcs11.so
name=opensc-pkcs11
NSS=slotParams={0xffffffff=[slotFlags=PublicCerts rootFlags=hasRootTrust] 0x00000001=[slotFlags=PublicCerts rootFlags=hasRootTrust] 0x00000002=[slotFlags=PublicCerts ] }


Tundub, et töötab nüüd.
Hetkel happy Very Happy


tarm0
Uus kasutaja
Uus kasutaja



Liitunud: 01.04.2014
Postitused: 3


blank.gif
postituspostitatud: 01.04.2014, 19:26  postituse pealkiri:  (teema puudub)  

Tere,

Üritan hetkel debian 7.4 installida eesti id-d. Pin1 -ga hetkel kõik korras, aga pin2 jaoks vaja fail i http://ideelabor.ee/downloads/pkcs11wrapper-linux64.tar.gz , aga tõmbamisel ütleb, et ei ole olemas.. Teen midagi valesti või ongi see ajutiselt maas? Või on kellelgi seda mulle saata..

Tarmo


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 01.04.2014, 19:38  postituse pealkiri:  (teema puudub)  

Wut. Ideelabori tarkvara on juba ajast ja arust. See ei tohiks vist isegi töötada.
Kasuta ikka RIA enda softi, näiteks selle juhendi järgi:
https://github.com/martinpaljak/ria-debian-build


tarm0
Uus kasutaja
Uus kasutaja



Liitunud: 01.04.2014
Postitused: 3


blank.gif
postituspostitatud: 01.04.2014, 23:22  postituse pealkiri:  (teema puudub)  

Proovisin, a ju ma tegin midagi valesti..või jätsin tegemata..
Ei õnnestu saada siit edasi:''

# build ... things.
mkdir -p idkaart/current && ln -s ../packaging idkaart/current/packaging
./builder.sh

ütleb selle peale:
ln: ei õnnestu luua nimeviidet

T.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 706
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 02.04.2014, 09:03  postituse pealkiri:  (teema puudub)  

tarm0 kirjutas:
ütleb selle peale:
ln: ei õnnestu luua nimeviidet


See teade on käsu
ln -s ../packaging idkaart/current/packaging
kohta.

Kas on mingi õiguste probleem või jääb packaging leidmata.
Mine sinna kausta, kus toimetasid ja vaata, kas ../packaging on olemas,
näiteks käsuga (ilma ülakomadeta)
'ls -l ..'


Sander
Vana Pingviin
Vana Pingviin



Liitunud: 14.10.2007
Postitused: 615


estonia.gif
postituspostitatud: 02.04.2014, 22:56  postituse pealkiri:  (teema puudub)  

Täna jälle veider anomaalia. Üritan Chromega kuhugi sisse logida, ütleb, et SSL viga. Sulen Chrome ja login sisse FireFoxiga. Pärast seda saab ka Chromega sisse. Ja nii terve päev. Algul e-kooli, siis lõuna paiku SEB panka ja nüüd õhtul eestiloto.ee-sse. Kui olen ID-kaardi eemaldanud ja mõlemad brauserid sulgenud, algab sama asi otsast peale, kui üritan ID-kaarti algul Chromega kasutada.


tarm0
Uus kasutaja
Uus kasutaja



Liitunud: 01.04.2014
Postitused: 3


blank.gif
postituspostitatud: 06.04.2014, 13:09  postituse pealkiri:  (teema puudub)  

tarm0 kirjutas: < Vali >
ütleb selle peale:
ln: ei õnnestu luua nimeviidet


See teade on käsu
ln -s ../packaging idkaart/current/packaging
kohta.

Kas on mingi õiguste probleem või jääb packaging leidmata.
Mine sinna kausta, kus toimetasid ja vaata, kas ../packaging on olemas,
näiteks käsuga (ilma ülakomadeta)
'ls -l .


Õiogustega ei tohiks probleemi olla, sest tegin seda kõike root-ina.
../pakcing kataloog on ka olemas
( root@debianM:/ria-debian-build/idkaart/packaging# ) ja seal on veel igast faile ja asju, st ei ole ka tühi..



Sain siiski tehtud, pidin minema kataloogi ../ria-debian-build ja siis ei kobisenud enam midagi. Aga sellegi poolest läks midagi nihu, sest kui teen apt-get update ja siis ´install qdigidoc qesteidutil esteidcerts esteidfirefoxplugin opensc' leiab ta ainult opensc...

Uurisn natuke ria-debian-build lehte. Seal on alguses, et pean tegema nö oma install repository apt source listi. See rida on source failis olemas, aga füüsiliselt seda ei ole..?
Kas oleks peale selle rea lisamist tegema $HOME/repository kataloogi ning sellesse nö kloonima ria-debian-build kataloogi? Sest antud hetkel on see ria-debian-build kataloog ../ all..!


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 07.04.2014, 10:02  postituse pealkiri:  (teema puudub)  

Huvitav tõesti. See peaks suht lihtne juhend olema... lihtsalt kopeeri käsud terminali ja valmis. Ma ei saa aru, kuidas sul ei õnnestu Razz
Midagi rohkem ei pea tegema, kui seal kirjas on. Ei ühtegi lisaliigutust. Kui esimesel korral ei õnnestu, siis kustuta repo /etc/apt/sources.list failist ning ria-debian-build kataloog ja alusta uuesti.

Ma tegelikult ka ei oska paremat abi anda, olen selle juhendi järgi nii Debianis, kui ka peale tõsist muutmist Fedoras ID-kaardi tööle saanud.

LISA:
Ära kõike juurkasutajana tee. Toimeta nii nagu seal kirjas. Ehk enne sea valmis sudo.


KristjanS
Vana Pingviin
Vana Pingviin


Vanus: 31
Liitunud: 29.12.2006
Postitused: 419

Distributsioon: Debian
blank.gif
postituspostitatud: 09.04.2014, 21:12  postituse pealkiri:  (teema puudub)  

Seni, kuni asi ei toimi nii, et Synapticuga paigaldan ID kaardi tarkvara + Firefoxi ja Chrome'i pluginud, ning kõik töötab s.h. kõik Eesti pangad, pole mõtet tarkvara "valmimisest" rääkida ja see versiooninumber peaks olema 0. midagi beeta.

_________________
Ubuntu Brainstorm: Have a device manager
Seadmehalduriga peaks saama jälgida riistvara, juhtprogrammi vahetada, ning vastavalt juhtprogrammile seadistusi muuta.

rastik
Pingviini külastaja
Pingviini külastaja



Liitunud: 27.03.2014
Postitused: 19

Distributsioon: Trisquel Gnu/Linux
blank.gif
postituspostitatud: 10.04.2014, 02:41  postituse pealkiri:  (teema puudub)  

KristjanS kirjutas:
Seni, kuni asi ei toimi nii, et Synapticuga paigaldan ID kaardi tarkvara + Firefoxi ja Chrome'i pluginud, ning kõik töötab s.h. kõik Eesti pangad, pole mõtet tarkvara "valmimisest" rääkida ja see versiooninumber peaks olema 0. midagi beeta.


Mõtled Eesti keskpanka või hoiu- laenuühistuid?

Synapticust saab paigaldada ID kaarti. Käsitsi paned repositooriumi aadressi.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 22.05.2014, 00:19  postituse pealkiri:  (teema puudub)  

Mint 16 xfce 64bit
Uuenes Chrome, nüüd versioon 35.0.1916.114 ja jälle jama majas.
Pangas makset allkirjastada ei saanud. Ütles, et vastav lisa on vaja installida ja link juhatas installer.ee lehele.
OK vaatasin siis asjad üle:
Ongi nii, et pluginate nimekirjas ainult 5 asja ja pole seal ID kaardi kohta midagi.
Kontrollisin ka teisi asju:
- libnss3-tools on synapticu andmetel olemas
- .pki failis viimane rida nagu ID kaardiga tehtult olema peab
- Sertifikaatidest ESTEID-SK 2011 jälle kadunud.
ID kaardi haldusvahend töötab

Järelikult uuem versioon koristas pluginatest ära tema arust "üleliigse". Või mis ??
Kuna chrome ise nii lahkelt installer.ee lehele suunas, siis mõtlesin prooviks installida kogu tarkvara kupatuse uuesti. Muud moodust pluginate lisamiseks chrome-sse ma ei leidnud. Seepeale teavitas terminal mind, et on juba kasutusel viimane versioon.
Viga ikkagi chromes, sest firefox-iga allkirjastamine töötab.

Mis siis nüüd edasi ???


sander85
Vana Pingviin
Vana Pingviin


Vanus: 33
Liitunud: 08.08.2005
Postitused: 4358
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 22.05.2014, 15:52  postituse pealkiri:  (teema puudub)  

Viga on selles, et Chrome kuni versioonini 34 kasutas Firefoxi allkirjastamise pluginat. Versioonist 35 alates tahab saada aga Chrome jaoks loodud pluginat.

_________________
Image Image Image

natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 23.05.2014, 10:01  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
...Mis siis nüüd edasi ???


Eemalda see mitterahuldav versioon masinast, tõsta ~/.config/google-chrome mujale, sealt saad järjehoidjad.

http://95.31.35.30/chrome/pool/main/g/google-chrome-stable/

Laadi endale vanem versioon alla, lase GDebi Package Installeriga peale.

Uuenduste vastu terminalis käsk
Tsitaat:
sudo apt-mark hold google-chrome-stable


Edasi peaks asi olema klaar. Very Happy

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 26.05.2014, 01:34  postituse pealkiri:  (teema puudub)  

Proovisin vanemat, (34 versiooni) ja pluginaid tuli tagsi tervelt 11 (esteid olemas) ja uuema installiga jäi neid ainult 5 alles (esteid pole).

Otsisin, aga ei leidnud, et kuskohas need chrome pluginad pesitsevad ?
Extensions kaust on olemas aga just pluginate kohta ei leia. Googeldamine annab tulemuseks flashi installimise ja siis on see plugin kaust vaja ise teha.

Tekkis idee, et võtaks vanema versiooni pluginate kausta või faili, kopeeriks ära ja paneks julmalt uuemale versioonile asemele.
Või siis vähemalt saaks selle ID asjandusele teha kuidagi copy-paste...
On selline variant üldse reaalne, mõtekas, tehtav ??


sander85
Vana Pingviin
Vana Pingviin


Vanus: 33
Liitunud: 08.08.2005
Postitused: 4358
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 26.05.2014, 10:36  postituse pealkiri:  (teema puudub)  

hirax kirjutas:

On selline variant üldse reaalne, mõtekas, tehtav ??


Ei ole, nagu oma eelmises postituses juba kirjutasin, siis Chrome kuni versioonini 34 kasutab allkirjastamiseks Firefoxile loodud pluginat, mis asub Firefoxi pluginate kaustas ega kao sealt uue Chrome'i paigaldamisel mitte kuhugi. Uus Chrome lihtsalt keeldub seda pluginat kasutamast ja tuleb oodata kuni SK laseb välja ID-tarkvara versiooni 3.9, millega koos peaks eelduste kohaselt tulema ka plugin Chrome uuemate versioonide jaoks.

_________________
Image Image Image

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 26.05.2014, 16:36  postituse pealkiri:  (teema puudub)  

SK klienditugi vastas mu "hädaldamisele" minule mitte millegi uuega, vaid tavapärase õpetusega, kuidas pluginaid lubada jne. Aga üks rida sealt on huvitav:
Tsitaat:
ID-kaardi tarkvara kasutab allkirjastamiseks tõesti Mozilla Firefoxi pluginat ja seda ka Google Chrome 35 versioonis.

Nii, et kas seal versioonis 3.9 midagi uut tulebki Rolling Eyes
Kui saatsin neile screenshoti, et mul pole chromes sellist pluginat enam ja kaardi tarkvara diagnostika tulemuse, siis peale seda - vaikus

EDIT paar minutit peale postitust tuli SK klienditoelt kogunisti kaks kirja. Väljavõte teisest:
Tsitaat:
Linux Mint 16 puhul on soovitav kasutada järgmist juhist tarkvara paigaldusel, kuna see süsteem pole toetatud ID-tarkvaras:

- laadige alla Ubuntu skript installer.id.ee keskkonnast;
- käivitage terminal ja sisenege superuser-ina (sudo -i + passw);
- käivitage skript ühe korra ja oodake kuni kuvatakse teade, et ei leitud ID-kaardi tarkvara;
- seejärel navigeerige Software Sources ja otsige üles RIA repositoorium (asub Additional repositories);
- muutke repositooriumi kirjes ära "kasutatava distro koodnimi" ümber saucy'ks, salvestage info ja sulgege aknad;
- terminali sisestage käsklus apt-get update ja oodake ära kuni uuendus on läbiviidud;
- lõpetuseks sisestage apt-get install estonianidcard

ID-kaardi tarkvara paigaldus algab.

Kas ta nüüd Google Chrome hakkab toimima, ei saa samas 100% garanteerida. Mozilla Firefoxiga peaks töötama kenasti

Peale paigaldust tuleks avada Mozilla Firefox ja seal muuta Advanced sätete all ära turvamoodul (Tools > Options > Advanced > Security Devices).
Selleks navigeerige turvamoodulite alajaotusesse, (ID-kaart lugejas) ja valige ID-kaardi kirje aktiivseks nii, et paremalt poolt saate valida unload valiku.

Sulgege aknad ja tehke Firefoxile taaskäivitus, nüüd peaks ka autentimise ja allkirjastamisega veebis korras olema.
(Ühe lause bold on minu tehtud)

Eks ma õhtapoole proovin ja annan ka siia teada

EDIT2 Eemaldasin vana tarkvara ja tegin siis täpselt nagu kirjas öeldud (ehk natuke "teistmoodi" kui tavaliselt), Lootsin, et ehk on nad seal midagi muutnud.
Tühjagi - esteid pluginat ei tekkinud chromesse. sander85-l õigus, chrome ei tunnista enam seda. Saatsin neile vastuse, põhimõtteliselt teist korda copy-paste sander85 postitustest (loodan, et ei pahanda). Eks näis, mida nüüd välja pakuvad ja kas nad on ise ikka veel veendunud, et ver.35 kasutab FF pluginaid.

EDIT3 27.05 Täna sain vastuse, mis veelkord kinnitab sander85 juttu.
Kiri ise selline:

Lugesin läbi alloleva kirjavahetuse ning tuleb tõdeda, et Teile on antud asjatult lootust saada Linux'i distributsioonis Mint tööle digitaalne allkirjastamine veebilehitseja Google Chrome M35 versioonist. ID-kaardi abil digitaalne allkirjastamine ei ole alates Google Chrome M35 versioonist võimalik.

Lisasin sellekohase info äsja ka ID.ee veebi aadressilt http://id.ee/?id=35974 leitavasse artiklisse. Toon siinkohal välja lisatud info:

NB! Linux distributsioonides ei tööta ID-kaardiga allkirjastamine alates veebilehitseja Google Chrome versioonist M35. ID-tarkvara poolne allkirjastamise tugi lisatakse versioonis 3.9, ent täiendavalt peavad muudatusi tegema ka allkirjastamist pakkuvad e-teenused. Tehniline lisainfo http://id.ee/?id=30010&read=36679 ID-tarkvara ver. 3.9 avalikustatakse juuni 2014.

Lisaks andsin sellekohase info edasi ka ID-kaardi abiliini meeskonnale ning loodan, et tulevikus saab sealt nimetatud küsimuse suhtes juba kohe korrektseid vastuseid.

Lugupidamisega

klienditoe spetsialist
AS Sertifitseerimiskeskus


-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 25.06.2005
Postitused: 1389
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - MX Linux
finland.gif
postituspostitatud: 28.02.2016, 18:57  postituse pealkiri:  (teema puudub)  

Häda ID tarkvara paigalduse ja käima saamisega. Kuna ma ise ei kasuta id kaarti ja seda tarkvara siis seega olen täis algaja hetkel selle paigaldamisega. Antud hetkel paigaldan seda tuttava arvutisse läbi teamvieweri. Antud kasutaja on esimesed sammud linuxis kuna tal sai windowsis kõrini ja mõni päev tagasi käisin paigaldasin talle Lubuntu 14.04. Kasutaja on täiesti rahul linuxiga aga ütles kui ID kaarti toimima ei saa siis tagasi windows Smile lohutuseks ütlesin, et saame asja käima ja windows unusta Smile

Nii siis masinaks on Samsung 350V ning paigaldasin sinna Lubuntu LTS 14.04 (viimaseim versioon mis hetkel saadaval.

Laadisin alla id.ee lehelt automaat paigaldus scripti. Chmodisin a+x ja käivitasin sudo käsuga terminalis. Paigalduse lõpus oli info, et ei õnnestunud mõningaid pagette paigaldada
Kood:
Mõnda paketti ei saanud paigaldada. See võib tähendada, et oled
palunud võimatut olukorda või kasutad ebastabiilset
distributsiooni, millel on mõned vajalikud paketid veel loomata
või on sissetulevate hulgast välja arvatud.
Järgmine teave võib aidata olukorda lahendada:

Järgmistel pakettidel on lahendamata sõltuvusi:
 open-eid : Depends: chrome-token-signing aga seda ei paigaldata
            Depends: qdigidoc aga seda ei paigaldata
            Depends: qesteidutil aga seda ei paigaldata
E: Unable to correct problems, you have held broken packages.


minnes lehele http://www.sk.ee/tervitus/ saime kurva näoga vastuse, et ei õnnestunud leida lugejat või siis id kaarti. Selge pilt, ei õnnestunud ju osasid pakke paigaldada.

Paluks siis abi kuidas see mure lahendada lihtsalt ja mugavalt, et kasutaja ei pistaks linuxi maailmast kohe hirmuga jooksma Smile

Kasutasime Google Chrome brauserit. Antud brauser on kasutajale meelepärane ja jääb seega siis kasutusse.


acrux
Pingviini külastaja
Pingviini külastaja


Vanus: 57
Liitunud: 15.03.2010
Postitused: 31
Asukoht: Tallinn
Distributsioon: Mageia
estonia.gif
postituspostitatud: 28.02.2016, 19:42  postituse pealkiri:  (teema puudub)  

Kui tegemist algajaga, siis ehk oleks olnud mõistlik võtta mõni distro, milles id kaardi soft juba "out-of-the-box" olemas ning kasutada firefox'i, mis parimini toetatud...
Aga edusoovid sellegipoolest Smile


hannes
Pingviini aktivist
Pingviini aktivist


Vanus: 33
Liitunud: 18.06.2009
Postitused: 213
Asukoht: Pärnu
Distributsioon: Debian | Ubuntu
estonia.gif
postituspostitatud: 28.02.2016, 20:54  postituse pealkiri:  (teema puudub)  

-IFFI- kirjutas:
Laadisin alla id.ee lehelt automaat paigaldus scripti. Chmodisin a+x ja käivitasin sudo käsuga terminalis. Paigalduse lõpus oli info, et ei õnnestunud mõningaid pagette paigaldada

Mina ei pidanud midagi chmodima, skript on kohe käivitatav. Ja ära käivita seda sudo'ga, sest siis ei lähe skript käima. Lase lihtsalt terminalis:
Kood:
$ sh install-open-eid.sh

Ja peaks kärama küll.


-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 25.06.2005
Postitused: 1389
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - MX Linux
finland.gif
postituspostitatud: 28.02.2016, 21:23  postituse pealkiri:  (teema puudub)  

mhhh, mulle väitis et puuduvad ligipääsu õigused.! ma lasin scripti käima nii
Kood:
$ ./install-open-eid.sh


Võimalik, et "mäkerdasin" asja ära kuidagi. Eemaldada saan selle pudru vist nii
Kood:
sudo apt-get --purge install-open-eid.sh


Eemaldaks ennem vana pahna kui uuesti proovida.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group