Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 17.12.2013, 17:43  postituse pealkiri:  (teema puudub)  

Mint 13 xfce 64bit. ID tarkvara paigaldatud automaatskriptiga (muudetud opsys=presice)
ID kaardi haldusvahend loeb kaardilt andmeid (pilti ei suuda miskipärast laadida)
Firefox tahab esimesena igal pool pin2 saada. Firefoxi turvaseadmetest Estonian ID Card eemaldamine ei aidanud. Isegi www.sk.ee/tervitus lehel tahab esimesena pin2 saada. Kui sisestada esimesena pin2 siis saab panka ja sinna tervituse lehele sisse. Muudmoodi panka sisse ei saagi - ütleb, et kasutaja tuvastamine ebaõnnestus. Firefoxi pluginates ja extensionites on esteid asjad lubatud.
Google chrome ei saa kaardilugejaga üldse hakkama. Kui firefox käivitada, siis hakkab kaardilugejal tuluke põlema, aga chromega ei hakka ja mitte kuhugi sisse logida ei saa. www.sk.ee/tervitus leht ütleb, et ssl ühenduse viga. Chrome pluginate nimekirjas on ka esteid lubatud ja on näha, et path viib firefoxi pluginate kausta.
Estobuntu 12.08 töötas ID kaardi asi nii firefoxi kui ka chrome all täiesti probleemivabalt (ainult digitaalset allkirjastamist ei proovinud)
Mis siis nüüd veel ette võtta???

PS kaardilugeja on omnikey 1021


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 17.12.2013, 19:56  postituse pealkiri:  (teema puudub)  

Xfce töölaual paistab ID tarkvara jaoks sisevidinaid puudu jäävat.

Solydx samuti xfce peal.

Proovin Solydk ka järgi, see on KDE-ga.

hirax kirjutas:
Mint 13 xfce 64bit. ID tarkvara paigaldatud automaatskriptiga (muudetud opsys=presice)


Kas ca tund aega kestvad uuendused on ikka peale pandud?

Lõbus tegevus: vahid ekraani ja vajutad 3 X [Enter] Very Happy

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 17.12.2013, 20:05  postituse pealkiri:  (teema puudub)  

natsa kirjutas:
Kas ca tund aega kestvad uuendused on ikka peale pandud?

Tehtud Very Happy
Oli vist mingi 620 (või midagi sellist) uuendust. Peale neid hakkas mint jubedalt lollitama, aga selle kirjeldamiseks tuleb mul vist eraldi teema teha.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 17.12.2013, 20:36  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Tehtud Very Happy
Oli vist mingi 620 (või midagi sellist) uuendust. Peale neid hakkas mint jubedalt lollitama, aga selle kirjeldamiseks tuleb mul vist eraldi teema teha.


Xfce kohta ei tea öelda Mate hakkas siis lollitama, kui kõiki uuendusi vaikimisi ei pannud.

Seni on parim kooslus: Ubuntu 12.04.3 LTS ja Mate-desktop.

Väga hästi annab Gnome-2 töölaua välimuse välja, funktsionaalsus jääb natuke alla, aga tühja kah.

_________________
Kõige parem asi on töötav asi.

Sander
Vana Pingviin
Vana Pingviin



Liitunud: 14.10.2007
Postitused: 615


estonia.gif
postituspostitatud: 17.12.2013, 21:45  postituse pealkiri:  (teema puudub)  

Sander kirjutas:
Mint 16-l ilmus ka ootamatult eelpoolkirjeldet viga, algul seda polnud. Klõpsasin enne sander85 abistava postituse lugemist pin2 küsimise peale 2X 'loobu' kuna esimese korra järel ilmus pin2 uuesti. Nüüd on samuti korras


Täna õhtul hakkas jälle 2X pin2 küsima enne kui pin1 ette tuleb

täiendan: tegin sander85 soovitatu uuesti läbi ja jälle korras. Ei saa aru, mis ta untsu ajab, kas uuendamine või?




Viimati muutis Sander 17.12.2013, 22:46; muudetud 1 kord
hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 17.12.2013, 22:00  postituse pealkiri:  (teema puudub)  

Kas keegi ka sinna abi@id.ee on sellest jamast kirjutanud ?? Viitega ka sellesse teemasse, et näete hädalisi on rohkem. Kas sellest üldse kasu oleks??
natsa kirjutas:
Seni on parim kooslus: Ubuntu 12.04.3 LTS ja Mate-desktop.
Väga hästi annab Gnome-2 töölaua välimuse välja, funktsionaalsus jääb natuke alla, aga tühja kah.
Paganas kas tähendab, et hakka nüüd JÄLLE os-i vahetama ? Mad


Sander
Vana Pingviin
Vana Pingviin



Liitunud: 14.10.2007
Postitused: 615


estonia.gif
postituspostitatud: 17.12.2013, 22:24  postituse pealkiri:  (teema puudub)  

Elementary OS Lunaga toimib 3.8 korralikult, isegi Chromium saab id-kaardiga hakkama


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 18.12.2013, 01:06  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Kas keegi ka sinna abi@id.ee on sellest jamast kirjutanud ?? Viitega ka sellesse teemasse, et näete hädalisi on rohkem. Kas sellest üldse kasu oleks??
natsa kirjutas:
Seni on parim kooslus: Ubuntu 12.04.3 LTS ja Mate-desktop.
Väga hästi annab Gnome-2 töölaua välimuse välja, funktsionaalsus jääb natuke alla, aga tühja kah.
Paganas kas tähendab, et hakka nüüd JÄLLE os-i vahetama ? Mad


Lohutuseks niipalju, et see vahetus pole nii hull midagi. Smile

N'iteks sain juba SolydX asemel SolydK peale ja idikas t;;tab Kde peal korralikult.

Vabandust, Kde on veriv'rske ja v66ras, klaver on veel paigast 'ra. Sad

E: Lohutuseks: ei pruugi uut installida. lase alglaadimiselt recovery mode's käima, lase parandada katkised paketid ja vaata, mis juhtub. Smile

E: 11:35 Lasin oma retsimiskastile LimuxMint 13 XFCE peale, tõmbasin kõik uuendused,

lasin ID-kaardi tarkvara automaatskriptiga peale ja töötab! Smile

Pean oma sõnad Xfce kohta tagasi võtma.

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 18.12.2013, 14:14  postituse pealkiri:  (teema puudub)  

natsa kirjutas:
lase parandada katkised paketid ja vaata, mis juhtub. Smile
lasin ID-kaardi tarkvara automaatskriptiga peale ja töötab! Smile
Kuidas see parandamine täpsemalt käib ??
Kas automaatskriptis muutsid selle kolmanda rea ära või installis muutmata kujul ka ??


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 18.12.2013, 16:26  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
natsa kirjutas:
lase parandada katkised paketid ja vaata, mis juhtub. Smile
lasin ID-kaardi tarkvara automaatskriptiga peale ja töötab! Smile
Kuidas see parandamine täpsemalt käib ??
Kas automaatskriptis muutsid selle kolmanda rea ära või installis muutmata kujul ka ??

Kolmas rida muudetud.

Grub alglaadimismenüüst valid rea, kus lõpus "(recovery mode)".

Kui alglaadimismenüü ei ole nähtav, mine juurikana /etc/default/grub ja muuda
Kood:
#GRUB_HIDDEN_TIMEOUT=0

st tuleb algusesse lisada trellid.

Siis anna terminalis käsk

Kood:
sudo update-grub

Rebuudi ja vali parandamine.

Kaks head asja tuleb kohe peale installi peale lasta:
Kood:
sudo apt-get install mc synaptic


MC häälestamise kohta: http://pingviin.org/ftopic9420-0-asc-40.html

Segasevõitu kiiruga tehtud jutt, aga katsu aru saada. Smile

E.: 16:35 Tundub, et asi on ära parandatud.

SolydX peal ja ID-kaart töötab. Very Happy

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 18.12.2013, 19:21  postituse pealkiri:  (teema puudub)  

Firefoxiga sain ka asja tööle. Kirjutasin eile sinna abi@id.ee ja sain täna vastuse, milles soovitati sedasama turvaseadmete alt ID kaart unload tegemist. Huvitav on see, et kui ma eile seda sama asja tegin siis ei mõjunud. Tea kas see mint tahab alati enne iga asja muutumist öö labi puhkamist Smile (nagu need muud imelikud õhtused veidrused tal hommikul iseenesest ära kaovad Very Happy )
Google Chrome-ga aga ID kaardi värk ei tööta. Tegin haldusvahendi diagnostika ja märkasin, et seal raportis on veebibrauseritena ainult firefox ja chromium. Chrome-t pole - võib olla viga selles?

Seda pakkide parandamise asja küsisin sellepärast, et ma polnud enne recovery mode käima lasknud. Ma arvasin selle teistmoodi olevat, aga seal ju kohe ühe valikuna parandamine välja pakutud. Kas peaksin selle parandamise igaks juhuks ära tegema või on oht et siis just midagi viltu võib minna ja mint järjekordse rabanduse saab ?? Smile


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 18.12.2013, 20:00  postituse pealkiri:  (teema puudub)  

recovery mode on unumbes sama, mis Win käivitamisel safe mode.

Vahel, kui midagi ei meeldi, lasen käima, hullemaks pole teinud.

_________________
Kõige parem asi on töötav asi.

Sander
Vana Pingviin
Vana Pingviin



Liitunud: 14.10.2007
Postitused: 615


estonia.gif
postituspostitatud: 18.12.2013, 21:24  postituse pealkiri:  (teema puudub)  

hirax kirjutas:

Google Chrome-ga aga ID kaardi värk ei tööta. Tegin haldusvahendi diagnostika ja märkasin, et seal raportis on veebibrauseritena ainult firefox ja chromium. Chrome-t pole - võib olla viga selles?

Kas sa id-kaardi Chromiumiga Mintis käima said? Mul ei õnnestu nende käskudega, millega ma seni muudes buntulistes hakkama olen saanud. Viimati sain asja toimima elementary OS-ga.
sudo apt-get install libnss3-tools
modutil -dbdir sql:$HOME/.pki/nssdb -add opensc-pkcs11 -libfile /usr/lib/onepin-opensc-pkcs11.so -mechanisms FRIENDLY

Sul on küll Mint 13, mul Mint 16 Cinnamon




Viimati muutis Sander 19.12.2013, 10:09; muudetud 1 kord
merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 155
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 18.12.2013, 22:29  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Firefoxiga sain ka asja tööle. Kirjutasin eile sinna abi@id.ee ja sain täna vastuse, milles soovitati sedasama turvaseadmete alt ID kaart unload tegemist. Huvitav on see, et kui ma eile seda sama asja tegin siis ei mõjunud. Tea kas see mint tahab alati enne iga asja muutumist öö labi puhkamist Smile (nagu need muud imelikud õhtused veidrused tal hommikul iseenesest ära kaovad Very Happy )


Huvitav, kas nad selle mooduli automaatset eemaldamist vms ei plaani? Kui see enam vajalik pole, siis võiks selle tarkvaraliselt sealt eemaldada, mitte sundida kasutajaid seadete rägastikus orienteeruma...


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 18.12.2013, 23:07  postituse pealkiri:  (teema puudub)  

Chromiumiga pole proovinud. Pole seda tegelikult kunagi kasutanudki (chromega ära harjunud)
Kirjutasin id.ee ka, et firefoxiga töötab, chromega mitte ja et diagnostikas chromet pole kirjas. Sain vastuse: tore, et probleem lahenes ja tänati tähelepaneku eest (vist see chrome puudumine)
Nüüd aga ei saagi aru kumba pidi jama on. Kas chrome ei saa kaardi lugejaga hakkama või ID kaardi tarkvara ei tunnista chrome-t ??

Edit 23:23 Mulle näib, et siiski ID kaardi tarkvara ei tunnista Chrome. Käisin vahepeal win7 peal, lasin sinna 3.8 tarkvara peale ja töötas firefoxi ja chromega. Kui seal tegin haldusprogrammi diagnostika, siis sealne veebibrauserite nimekiri oli oluliselt pikem (isegi mingi mozilla media asi oli kirjas). Kuid sealt nimekirjast puudus jällegi Chromium ...
Kas chrome on siis rohkem win teema ja chromium ainult linuxi jaoks?


topil
Uus kasutaja
Uus kasutaja



Liitunud: 04.02.2013
Postitused: 6


blank.gif
postituspostitatud: 19.12.2013, 07:30  postituse pealkiri:  (teema puudub)  

Chrome pole kunagi linuxi all ID kaardiga töödanud, Chromium ilmselt ka ei tööta. Ei ole ammu jälgind seda arendust, aga kunagi oli vähemalt nii, et Chrome Win peal kasutas sama moodulit mis IE ning FF oli omaette. Võibolla on ajad muutnud.


Sander
Vana Pingviin
Vana Pingviin



Liitunud: 14.10.2007
Postitused: 615


estonia.gif
postituspostitatud: 19.12.2013, 10:06  postituse pealkiri:  (teema puudub)  

topil kirjutas:
Chrome pole kunagi linuxi all ID kaardiga töödanud, Chromium ilmselt ka ei tööta. Ei ole ammu jälgind seda arendust, aga kunagi oli vähemalt nii, et Chrome Win peal kasutas sama moodulit mis IE ning FF oli omaette. Võibolla on ajad muutnud.


On ikka töötanud ja mul töötab osade buntulistega praegugi, ainult Mint 16 ei saa hakkama, nagu eelpool kirjutasin.

Selleks on isegi aadressil http://www.id.ee/?id=35974 juhend

"ID-tarkvara ver. 3.8 (avalikustatud 10.12.2013) https://installer.id.ee

Selleks, et Ubuntus autentimine ID-kaardiga Google Chrome ja Chromium veebilehitsejas toimima hakkaks, peab olema paigaldatud pakett lbnss3-tools. Selle paigaldamiseks tuleb käsurealt anda käsk:

sudo apt-get install libnss3-tools

Seejärel käivitada veebilehitseja ja sulge see uuesti. Sisesta nüüd käsk:

modutil -dbdir sql:$HOME/.pki/nssdb -add opensc-pkcs11 -libfile opensc-pkcs11.so -mechanisms FRIENDLY

Viimane tegevus tuleb igal kasutaja puhul eraldi teha."

Mint 16 Cinnamoni puhul annab sellise veateate

ERROR: Failed to add module "opensc-pkcs11". Probable cause : "Failure to load dynamic library".




Viimati muutis Sander 19.12.2013, 17:22; muudetud 2 korda
natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 19.12.2013, 10:53  postituse pealkiri:  (teema puudub)  

merike kirjutas:
hirax kirjutas:
Firefoxiga sain ka asja tööle. Kirjutasin eile sinna abi@id.ee ja sain täna vastuse, milles soovitati sedasama turvaseadmete alt ID kaart unload tegemist. Huvitav on see, et kui ma eile seda sama asja tegin siis ei mõjunud. Tea kas see mint tahab alati enne iga asja muutumist öö labi puhkamist Smile (nagu need muud imelikud õhtused veidrused tal hommikul iseenesest ära kaovad Very Happy )


Huvitav, kas nad selle mooduli automaatset eemaldamist vms ei plaani? Kui see enam vajalik pole, siis võiks selle tarkvaraliselt sealt eemaldada, mitte sundida kasutajaid seadete rägastikus orienteeruma...


See moodul on pärast FF taaskäivitamist paigal jälle...

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 249
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Linux Lite
estonia.gif
postituspostitatud: 19.12.2013, 18:02  postituse pealkiri:  (teema puudub)  

topil kirjutas:
Chrome pole kunagi linuxi all ID kaardiga töödanud,
Estobuntu 12.08 64bit töötab ID kaart ilusti nii firefoxi kui ka chromega

Sander kirjutas:
Selleks, et Ubuntus autentimine ID-kaardiga Google Chrome ja Chromium veebilehitsejas toimima hakkaks, peab olema paigaldatud pakett lbnss3-tools.
Linux Mint peaks ju ka baseeruma Ubuntul.
Kas ma peaksin proovima seda paketti oma Mint 13-le ka juurde installima ???


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2545
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 19.12.2013, 19:30  postituse pealkiri:  (teema puudub)  

topil kirjutas:
Chrome pole kunagi linuxi all ID kaardiga töödanud, Chromium ilmselt ka ei tööta.

Chrome all töötab kenasti, Chromiumi all samamoodi.

See PIN2 küsimine FF puhul jääb ära kui Opensc 0.12 kasutada.
Ei ole vaja FF seadistustes kolada ja mingeid asju eemaldada.

Minu enda masina näitel:
Kood:

dpkg --purge --force-depends opensc
dpkg -i opensc_0.12.2-2ubuntu2_amd64.deb

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group