Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
mannie
Uus kasutaja
Uus kasutaja



Liitunud: 03.03.2010
Postitused: 13


estonia.gif
postituspostitatud: 25.10.2020, 15:51  postituse pealkiri:  libpoppler probleem  

Ahoi!

Ubuntu 18.04.5 LTS (GNU/Linux 5.4.0-48-generic x86_64)

Ei saa uuendada paketti libpoppler85, põhjuseks tundub olevat, et masinas on ka libpoppler73. Kuna mõlemat on vaja, siis ei saa ka eemaldada ühte neist.

Kood:
kaspar@kaspar:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Järgnevaid pakette hoiti tagasi:
  libpoppler85
0 uuendatud, 0 värskelt paigaldatud, 0 eemaldada ja 1 uuendamata.

kaspar@kaspar:~$ sudo apt install libpoppler85
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  evince-common kaccounts-providers kactivities-bin kactivitymanagerd kde-cli-tools kde-cli-tools-data kdeconnect libaccounts-glib0
  libaccounts-qt5-1 libbabl-0.1-0 libc-ares2 libcfitsio5 libepub0 libgegl-0.3-0 libgsf-1-114 libgsf-1-common libgtkspell0
  libimage-magick-perl libimage-magick-q16-perl libkaccounts1 libkf5activities5 libkf5js5 libkf5jsapi5 libkf5kcmutils-data libkf5kcmutils5
  libkf5kexiv2-15.0.0 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5pty-data libkf5pty5 libkf5purpose-bin libkf5purpose5
  libkf5su-bin libkf5su-data libkf5su5 libkf5threadweaver5 libmarkdown2 libmatio4 libokular5core8 libopenslide0 libqca-qt5-2
  libqca-qt5-2-plugins libqmobipocket2 libsignon-plugins-common1 libsignon-qt5-1 libuv1 nodejs nodejs-doc python-scour
  qml-module-org-kde-purpose qml-module-qtquick-dialogs qml-module-qtquick-privatewidgets qml-module-ubuntu-onlineaccounts
  qtdeclarative5-qtquick2-plugin qtspeech5-flite-plugin signon-plugin-oauth2 sshfs
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  foomatic-filters libpaps0 paps
Soovitatavad paketid:
  poppler-utils
EEMALDATAKSE järgnevad paketid:
  atril bluez-cups cups cups-core-drivers cups-filters cups-filters-core-drivers evince gimp hplip inkscape libatrildocument3
  libatrilview3 libevdocument3-4 libevview3-3 libkf5filemetadata-bin libpoppler-glib8 libpoppler-qt5-1 libvips42 nip2 okular poppler-utils
  printer-driver-gutenprint printer-driver-hpcups printer-driver-postscript-hp printer-driver-pxljr printer-driver-splix ubuntu-mate-core
  ubuntu-mate-desktop
Paigaldatakse järgnevad UUED paketid:
  foomatic-filters libpaps0 paps
Uuendatakse järgnevaid pakette:
  libpoppler85
1 uuendatud, 3 värskelt paigaldatud, 28 eemaldada ja 0 uuendamata.
On vaja tõmmata 1 025 kB arhiive.
Pärast seda tegevust vabaneb 189 MB kettaruumi.
Do you want to continue? [Y/n]


Tahaks kogu süsteemi uuendada, aga ei saa teha do-release-upgrade sest:
Kood:

kaspar@kaspar:~$ sudo do-release-upgrade
Uue Ubuntu väljalaske saadavaloleku kontroll
Please install all available updates for your release before upgrading.


Oskab keegi lahendust pakkuda?


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2618
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 25.10.2020, 18:57  postituse pealkiri:  (teema puudub)  

Sa ei saa libpoppler85 ja libpoppler73 mõlemat korraga.
Miks libpoppler73 just vajalik on?

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

mannie
Uus kasutaja
Uus kasutaja



Liitunud: 03.03.2010
Postitused: 13


estonia.gif
postituspostitatud: 25.10.2020, 19:05  postituse pealkiri:  (teema puudub)  

imre kirjutas:
Sa ei saa libpoppler85 ja libpoppler73 mõlemat korraga.
Miks libpoppler73 just vajalik on?


Faktiliselt nad on masinas korraga, mis juhtub kui hakata libpoppler73 eemaldama on näha allpool... ka libpoppler85 ei saa eemaldada, sest sellega visatakse välja hulganisti tööks vajalikku tarkvara.
Kood:

kaspar@kaspar:~$ sudo apt remove libpoppler73
[sudo] password for kaspar:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  blender-data calculix-ccx fonts-lato fonts-lmodern fonts-texgyre freecad-common freecad-runtime gdal-data ibverbs-providers
  libarmadillo8 libdap25 libdapclient6v5 libepsilon1 libfabric1 libfreexl1 libfyba0 libgavl1 libgdcm2.8 libgeos-3.6.2 libgeos-c1v5
  libgeotiff2 libgtkspell0 libhdf4-0-alt libhdf5-openmpi-100 libhwloc-plugins libhwloc5 libibverbs1 libimage-magick-perl
  libimage-magick-q16-perl libjemalloc1 libkmlbase1 libkmldom1 libkmlengine1 liblog4cplus-1.1-9 libmedc1v5 libnetcdf-c++4 libnetcdf13
  libnl-route-3-200 libocct-data-exchange-7.3 libocct-ocaf-7.3 libogdi3.2 libopencolorio1v5 libopencv-core3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-video3.2 libopenmpi2 libopenvdb5.0 libpotrace0 libpq5 libproj12 libpsm-infinipath1 libptexenc1
  libpyside2-py3-5.11 libqt5concurrent5 librdmacm1 libreoffice-l10n-en-gb libruby2.5 libshiboken2-py3-5.11 libsocket++1 libspatialite7
  libspooles2.2 libsuperlu5 libsynctex1 libtexlua52 libtexluajit2 libtinyxml2.6.2v5 liburiparser1 libyaml-cpp0.5v5 libzipios++0v5
  libzzip-0-13 lmodern odbcinst odbcinst1debian2 openmpi-bin openmpi-common preview-latex-style proj-bin proj-data ps2eps python-sagetex
  python-scour python3-cycler python3-matplotlib python3-pivy python3-pyparsing python3-pyside2.qtcore python3-pyside2.qtgui
  python3-pyside2.qtopengl python3-pyside2.qtsvg python3-pyside2.qtuitools python3-pyside2.qtwidgets python3-pyside2.qtxml
  python3-pyside2uic python3-tz rake ruby ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.5
  rubygems-integration tex-gyre
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  foomatic-filters libpaps0 paps
EEMALDATAKSE järgnevad paketid:
  blender bluez-cups cups cups-core-drivers cups-filters cups-filters-core-drivers freecad freecad-python3 frei0r-plugins hplip inkscape
  libfreecad-python3-0.18 libgdal20 libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-objdetect3.2 libopencv-videoio3.2
  libopenimageio1.7 libpoppler73 libreoffice-avmedia-backend-gstreamer libreoffice-base-core libreoffice-calc libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-et
  libreoffice-impress libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-writer libvtk7.1 printer-driver-gutenprint
  printer-driver-hpcups printer-driver-postscript-hp printer-driver-pxljr printer-driver-splix python3-uno sagetex texlive-base
  texlive-binaries texlive-font-utils texlive-fonts-recommended texlive-latex-base texlive-latex-extra texlive-latex-recommended
  texlive-pictures texlive-plain-generic tipa ubuntu-mate-core ubuntu-mate-desktop
Paigaldatakse järgnevad UUED paketid:
  foomatic-filters libpaps0 paps
0 uuendatud, 3 värskelt paigaldatud, 54 eemaldada ja 1 uuendamata.
On vaja tõmmata 111 kB arhiive.
Pärast seda tegevust vabaneb 1 099 MB kettaruumi.
Do you want to continue? [Y/n]


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2618
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 25.10.2020, 19:51  postituse pealkiri:  (teema puudub)  

Tundub nagu oleks erinevatest repodest midagi peale lastud ja see teeb elu keeruliseks.
On mingi kindel soft mis tahab just libpoppler73 ja mingi tahab libpoppler85? Gimp sõltub tõenäoliselt libpoppler73 versioonist, aga mis sul 85 versioonist sõltub?

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

v6lur
Vana Pingviin
Vana Pingviin


Vanus: 33
Liitunud: 08.07.2005
Postitused: 659
Asukoht: Tartu
Distributsioon: Arch
blank.gif
postituspostitatud: 26.10.2020, 16:16  postituse pealkiri:  (teema puudub)  

Kust see libpoppler85 pärineb? Ametlikes repodes on 18.04 jaoks 73.
Mis paketid 85-st sõltuvad? Ehk õnnestub need ajutiselt eemaldada (koos libpoppler85-ga), seejärel süsteem uuendada ning siis eemaldatud kraam uuesti paigaldada, siis juba loodetavasti koos korrektsete sõltuvustega.

_________________
"Sleep, she is for the weak."

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group