Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 19.03.2014, 01:37  postituse pealkiri:  Peale protsessori ja emaplaadi vahetust  

Sai siis lauakale kõva värskenduskuur tehtud Smile
Vana kola asemele läksid need jubinad:
Intel® Core i5-4570 (Haswell)
Asrock B85M Pro4

Kõvaketas, toide ja korpus jäid esialgu vanad ja cd-rom kasutada ei saa (ata ühendused)

Kurja vaeva (paar tundi googeldamist) nägin, et internet tööle saada.
Graafika toimib ka veidralt (aknad ekraanilt väljas ja hiirekursor teeb igasuguseid trikke)

Põhiline küsimus on see, et kuidas OP süsteemile raua vahetus võimalikult leebelt selgeks teha ???
Netiühendusega majandades jäi mingitest logifailidest silma, et süsteem üritab kõigepealt leida "vana rauda" ja selle draivereid. Näiteks proovib kõigepealt leida fglrx draivereid kuigi pole ju enam ati videokaart. Jne jne.
Kuidas süsteemi värskendada, et unustagu vana ja leidku kohe uued asjad ?? Smile
Ei tahaks uut installi teha. Uuesti installides ja home kataloogi säilitades jäävad sinna ju kõikvõimalikud settingud alles ja jälle sama jama, et üritab mingeid vanu asju üles leida ja nende järgi ennast tööle ajada.


ertserts
Vana Pingviin
Vana Pingviin



Liitunud: 31.10.2013
Postitused: 429
Asukoht: Tallinn
Distributsioon: Ubuntu, Debian
estonia.gif
postituspostitatud: 19.03.2014, 02:41  postituse pealkiri:  (teema puudub)  

Nii et loobusid pc vanakesest ja tegid riistvarale plastilise opi.
Selle arvutiga peaks nüüd küll saama valutult mängukesi jooksutada.

Mina isiklikult arvan et lihtsaim ja tõhusaim variant on sul vajalikud failid tõsta välisele andmekandjale ja teha nullist täiesti uus puhas install koos hdd format'iga. Pealegi oled sa kindlasti seda vana nö. eelnevat distrot palju mudinud ja sättinud kusjuures kõvakettal on vana emaplaadi ja ati videokaardi riistvara soft ning konf jms tohuva-pohu.

Uus puhas distro install ajaks sul arvatavasti automaatselt jonksu ka integreeritud inteli videokaardi draiverid. Neti ja soundiga ei tohiks ka probleeme tekkida sest seegi tugi leitakse üles automaatselt.

Sa ei suudakse ealeski seda arvutit uue riistvara jaoks nii puhtaks rookida kui seda oleks täiesti uus nullist distro install koos partitsioonide formatiga. Nüüd sa saad ka endale valida sobiliku Linux distro, ilma et peaksid pelgama et riistvara mitte kuidagi välja ei vea. Sa ei vaja enam Linux distrot mis töötaks "eriliselt lahjal" riistvaral. Smile

_________________
ertserts@linuxialune:~$ echo;echo Local and Remote IP connections:;netstat -at|sort -k5|grep ESTABLISHED|cut -c20-80;echo

mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 19.03.2014, 10:07  postituse pealkiri:  (teema puudub)  

Mina olen oma debiane/fedorasid ühest masinast teise tõstnud ainult kõvaketta või SSD vahetamisega... mingit puhast installi pole vaja. Linux elab need üleviimised edukalt üle.

Muidugi, kui sul on olemas xorg.conf fail, siis üritatakse kõigepealt seal olevat infot rakendada ja kui see feilib, siis tuvastatakse riistvara automaatselt. Sul praegu inteli graafika?
Lahenduseks oleks fglrx maha laskmine ning veenduda, et xorg.conf faili poleks ega ka xorg.conf.d kataloomas sellist faili, mis viitaks fglrx-le.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 19.03.2014, 11:08  postituse pealkiri:  (teema puudub)  

Kui kõvaketas on see: https://www.dropbox.com/s/22hlkhmqyzvxvt2/gparted.png

siis ertserts annab VÄGA HEAD NÕU!,

XP uut riistvara omaks ei võta ja on alates 8. aprillist "kuival". Smile

Selle riistvaraga käib 'buntulise install kähku.

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 20.03.2014, 06:14  postituse pealkiri:  (teema puudub)  

Mulle võib vist vabalt omastada tiitli; "Linuxi probleemide magnet" Very Happy

Tegin nii nagu siin soovitati. Kõigepealt tekitasin GParted live usb abil uue installi jaoks kõvakettale vaba ruumi. Alles jätsin andmete osa (dokumendid filmid jne ntfs formaadis partitsioonil) Win XP läks ka kadunud ajaloo igavikku Smile
Lasin peale vana hea tuttava Mint13...
Ja hakkas pihta.
Imelikult kaua buutis. Pluss see, et aknad ekraanilt väljas ja hiirekursor kadus aegajalt ära ja üldse käitus väga veidralt. Peale teise kasutaja tekitamist ei saanud enam välja logida ega arvutit seisma jätta ega restart teha. Lülitas monitori välja ja isegi restart või power nupp ei mõjunud. Grub menu ei olnud ka nähtav.
Hea küll: mis s....ti - see uuesti.
Kui on võimalik, et midagi nässu läheb, siis ta ka läheb
Seekord jooksis mint13 installer kokku ja kööga. Mingi "installer krahh" teade oli vist. Ei saanud grub installiga hakkama vms.
Kusjuures mint13 live usb ei suutnud ilma täiendavate draiveriteta netiühendust luua. Jällegi tuleb tunnustada "väikest kutsikat" linux puppyt,kes suutis neti kohe üles leida.
Egas midagi, proovime midagi uuemat. Installisin Mint 16 xfce...
Noh ja mis arvate ????
Peale restarti teade: grub rescue
No mida f...k ?
Läksin asjale "boot repair"-iga ja nüüd vähemalt on mingisugunegi Mint16 mul olemas.Terve öö läks ID kaardi tööle saamisega


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 20.03.2014, 15:47  postituse pealkiri:  (teema puudub)  

Mint-13 jaoks on see emaplaat liiga uus. Kogemus Ubuntu 10.04 ja Intel DH67BL emaplaadiga: ei pilti, ei heli. Sissepandud graafika- ja võrgukaart panid asja korda. Ubuntu 12.04 tunneb raua ära. See selleks.

Kõvakettale jäid ju vana masina probleemid alles.

Puhtalt lehelt alustamiseks varunda LADU1 teisele andmekandjale.

Kõvakettal tekita uus partitsioonitabel ja tee 4 partitsiooni.

2 tk á 15 ÷ 20 GB erinevate linuxite / jaoks, 1 tk /home jaoks ja 1 tk LADU1 jaoks. Suure mälumahuga masinatel /swap partitsiooni enam vaja ei lähe.

Installi valikul vali "Midagi muud".

Soovitan proovida 32-bitist LMDE Matet.

_________________
Kõige parem asi on töötav asi.

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 21.03.2014, 02:48  postituse pealkiri:  (teema puudub)  

Taaskord on sul vist õigus Smile
Praeguse Mint16-ga ei ole kõik päris korras ja õigem oleks jah alustada täiesti "puhtalt" lehelt.
Kui teha uus partitsioonitabel, siis millise failiformaadi võiks valida uuele "LADU" partitsioonile ? Ext4 või igaks juhuks ntfs ?

LMDE. Ma natuke pelgan seda debiani värki väiksema kasutajaskonna tõttu. Olen aru saanud, et selle LMDE kasutamine eeldab rohkemat "linuxi sisemuse" teadmist jne. Minusuguse "hädamagneti" puhul tähendaks see iga päev vist mingit probleemi. Igasugu pakette tuleks ise teha vms. Näiteks ma ei leidnudki googeldades juhendit kuidas sinna chrome ID kaardi tugi tekitada. Jne jne...
Ja mis põhjusel just LMDE 32bit, mitte 64bit ??


kernull
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 03.08.2008
Postitused: 58
Asukoht: Tallinn

estonia.gif
postituspostitatud: 21.03.2014, 14:45  postituse pealkiri:  (teema puudub)  

Mind huvitaks ka, miks just 32-bitine?

Mälu kohta mainiks igaks juhuks, et DIMM-e on kasulik paarikaupa panna, nii saadakse suurem kiirus.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 21.03.2014, 16:32  postituse pealkiri:  (teema puudub)  

32-bitine sellepärast, et Google Earth ja DraftSight ei lähe 64-bitisele peale.
Muidu 64-bitine ka täitsa OK.

Kui laos midagi win-põhist ei ole, siis vahet pole.

Pane Petra peale, sellega saad / ja /home pardid paika.

LMDE on tublisti arenenud, install väga selge viisardiga, ID-kaardi saab tööle mõne terminali-käsuga.

Chrome ID kaardi tugi läheb täpselt samamoodi käima, nagu teistes 'buntulistes.

Lisan siia käsud ID kaardi installimiseks.

############################################
## ID-kaardi repo
sudo add-apt-repository "deb https://installer.id.ee/media/ubuntu saucy main"

## Repo võti
wget -qO - https://installer.id.ee/media/install-scripts/ria-public.key | sudo apt-key add -

## Uuendamine
sudo apt-get update

## Vajalikud pakid
sudo apt-get install pcscd libccid libxerces-c3.1 opensc ttf-liberation libxml-security-c17

## Ja lõpuks saab installida
sudo apt-get install estonianidcard
##################################################

Seda saad proovida teise / partitsiooni pealt. Kasutajanimi vali erinev, siis ei hakka seaded üksteist segama.

Edit: Google Earth läks 64-bitises käima, aga DraftSight paraku...

_________________
Kõige parem asi on töötav asi.

mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 21.03.2014, 18:29  postituse pealkiri:  (teema puudub)  

natsa kirjutas:
32-bitine sellepärast, et Google Earth ja DraftSight ei lähe 64-bitisele peale.


Kas LMDE ei oskagi multilib-i. Baseerub ju teine Debianil, mis saab täiesti edukalt hakkama 32-bitiste programmide jooksutamisega 64-bitisel süsteemil.

LISA:
Guugeldasin sel teemal pisut ning jõudsin järeldusele, et Draftsighti paigaldamisega on tõesti probleeme, aga seda eelkõige seetõttu, et ta on kehvasti pakendatud. Workaround-e on, aga kui ei viitsi mässata ja selle programmi kasutamine on hädavajalik, siis võibolla tõesti on parem 32-bitist süsteemi kasutada.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 21.03.2014, 20:19  postituse pealkiri:  (teema puudub)  

mihkel kirjutas:
natsa kirjutas:
32-bitine sellepärast, et Google Earth ja DraftSight ei lähe 64-bitisele peale.


Kas LMDE ei oskagi multilib-i. Baseerub ju teine Debianil, mis saab täiesti edukalt hakkama 32-bitiste programmide jooksutamisega 64-bitisel süsteemil.

LISA:
Guugeldasin sel teemal pisut ning jõudsin järeldusele, et Draftsighti paigaldamisega on tõesti probleeme, aga seda eelkõige seetõttu, et ta on kehvasti pakendatud. Workaround-e on, aga kui ei viitsi mässata ja selle programmi kasutamine on hädavajalik, siis võibolla tõesti on parem 32-bitist süsteemi kasutada.


Minu mäletamist mööda tahtis mingit ia32-libs, aga seda polnud.

_________________
Kõige parem asi on töötav asi.

mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 21.03.2014, 22:02  postituse pealkiri:  (teema puudub)  

Vat see ongi pakendamise viga. ia32-libs oli meetod või häkk (kuidas võtta) saamaks 32-bitiseid programme tööle 64-bitisel süsteemil. Nüüd on üle mindud multiarch-le: https://wiki.debian.org/Multiarch/HOWTO

Võibolla hoitakse ia32-libs sõltuvust seal pakis mõnede vanade distrode pärast, võibolla aga puhtalt laiskusest. Mina ei tea Smile

Põhimõtteliselt käib 64-bitises süsteemis 32-bitiste programmide paigaldamine nii:
Kood:

dpkg --add-architecture i386
apt-get update
apt-get install pakinimi:i386

See näide siis debianiliste kohta. Fedoras käib asi analoogselt
Kood:

yum install pakinimi.i386


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 250
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 22.03.2014, 03:23  postituse pealkiri:  (teema puudub)  

Tsitaat:
Kasutajanimi vali erinev, siis ei hakka seaded üksteist segama.

Vot see lõi nüüd "lambikese põlema" Smile Sellest võiski saada alguse mu viimane probleemide jada nende partitsioonidega. Kui ma proovimiseks mageiat installisin, siis ma panin ju sama kasutaja, mis mul mintiga oli..

DraftSight
sellist SolidWorksi analoogi rohkem mehhaanika joonestamise peal oleks mõnikord vaja küll. SW kasutasin windoozas vahelduvalt. Sellle analoogi leidmiseni linuxis polegi veel jõudnud. Ma ju oskan muidki hädasi omale kaela tõmmata.

Tsitaat:
Kui laos midagi win-põhist ei ole, siis vahet pole.

Seal mõned spetsiifilised win põhised proged olid, aga ehk saab need kunagi wine all tööle. Jällegi pole veel aega saanud nendega tegeleda oma "hädade" kõrvalt

LMDE installer jne.
Esimese hooga leitud kirjeldus just ülemäära optimistlik ei näi. Tundub mulle, et see kirjutaja hädaldab rohkem automaatse paigalduse koha pealt. Kui nii, siis pole probleemi. Ma olengi siiani paigaldanud linuxi käsitsi partitsioone määrates. Ainsaks erandiks see õnnetu mageia proov... Enam nii ei tee Smile
Lähemal uurimisel tundub LMDE proovimist väärt. Enne katsetamisi uurin veel võimalusi kuidas kasutada ühtset home partitsiooni erinevate distrote puhul.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 22.03.2014, 12:45  postituse pealkiri:  (teema puudub)  

mihkel kirjutas:
Vat see ongi pakendamise viga. ia32-libs oli meetod või häkk (kuidas võtta) saamaks 32-bitiseid programme tööle 64-bitisel süsteemil. Nüüd on üle mindud multiarch-le: https://wiki.debian.org/Multiarch/HOWTO

Võibolla hoitakse ia32-libs sõltuvust seal pakis mõnede vanade distrode pärast, võibolla aga puhtalt laiskusest. Mina ei tea Smile

Põhimõtteliselt käib 64-bitises süsteemis 32-bitiste programmide paigaldamine nii:
Kood:

dpkg --add-architecture i386
apt-get update
apt-get install pakinimi:i386

See näide siis debianiliste kohta. Fedoras käib asi analoogselt
Kood:

yum install pakinimi.i386


See on proovitud.
Kood:
(Andmebaasi lugemine ... 197198 files and directories currently installed.)
Paki draftsight lahtipakkimine (failist draftSight.deb) ...
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicense: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing draftSight.deb (--install):
 alamprotsess uus pre-installation skript tagastas lõpetamisel veakoodi 127
Järgnevate pakkide töötlemisel tekkisid vead:
 draftSight.deb


Gdebi ütleb, et sõltuvused on korras, aga ei midagi. Nagu spermaproovi andmine: ise proovid ühe ja teise käega, naine proovib ühe ja teise käega, naabrinaine ka proovib,aga... proovipurgi kaant lahti ei saa. Sad

_________________
Kõige parem asi on töötav asi.

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2547
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 22.03.2014, 13:24  postituse pealkiri:  (teema puudub)  

Kood:
# apt-file search libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0

Ehk paigalda libgtk2.0-0

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 22.03.2014, 16:29  postituse pealkiri:  (teema puudub)  

imre kirjutas:
Kood:
# apt-file search libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0

Ehk paigalda libgtk2.0-0


Kood:
[1]simmu@simmu-desktop ~/Allalaadimised $ apt-file search libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0.2400.22
libgtk2.0-0-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0.2400.22


Seis endine: ei lähe peale. Sad

_________________
Kõige parem asi on töötav asi.

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2547
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 22.03.2014, 16:49  postituse pealkiri:  (teema puudub)  

Kasutu info see "ei lähe peale" - mis veateade tuleb?

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 22.03.2014, 16:59  postituse pealkiri:  (teema puudub)  

Kood:
(Andmebaasi lugemine ... 197198 files and directories currently installed.)
Paki draftsight lahtipakkimine (failist draftSight.deb) ...
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicense: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing draftSight.deb (--install):
 alamprotsess uus pre-installation skript tagastas lõpetamisel veakoodi 127
Järgnevate pakkide töötlemisel tekkisid vead:
 draftSight.deb

_________________
Kõige parem asi on töötav asi.

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2547
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 22.03.2014, 17:15  postituse pealkiri:  (teema puudub)  

64-bit jaoks proovi paigaldada: libgtk2.0-0:i386
Kui seda veel ei ole muidugi.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 22.03.2014, 18:03  postituse pealkiri:  (teema puudub)  

imre kirjutas:
64-bit jaoks proovi paigaldada: libgtk2.0-0:i386
Kui seda veel ei ole muidugi.


Ei ole varamus.

_________________
Kõige parem asi on töötav asi.

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group