Mis jama selle id kaardiga siis tegelikult on?

0 häält
198 vaatamist
Lugesin siin seda foorumit ja mina konkreetset vastust enda omale ei leidnud? Nimelt asi selles, et id-kaardi haldusvahend toimib just kui valikuliselt (minu 10.06.2014 aasta väljaantud id kaart töötab tõrgetetta aga kui panen lugejasse naise id-kaardi mis on väljastatud 19.10 2016 siis see ei toimi?)

Jah, sertifikaadid ja jutud on uuendatud ja siin probleeme pole. Asi sai alguse siit kui vihastasin oma arvuti HP Elitebook 2560p ja Windows 10-mne peale kuna viimane ei suutnud peale upgradet win-seitsmelt win-kümnele enam leida toimivaid draivereid wifi, lan, bluetooth ja gsm ühenduse tarvis ja pärast viiendat rollpacki otsustasin, et nüüd aitab, vaatan tagasi Linuxi maailma ja katsetasin siis erinevaid (olen muidugi aastaid eelnevalt ka linuxit kasutanud ja see pole minu jaoks võõras teema). Võtsin siis Peppermint 7 algatuseks (meeldis, kõik toimis, ka vead süsteemis tundusid olevat parandatud). Ok, siis mõtlesin, et vaatan mis see kõige uuem Peppermint 8 mulle räägib= veel parem ja ilusam, kõik toimib-töötab, isegi mobiilne nett ja saan kasutada oma avuti sisest id-kaardilugejat toimetusteks aga naise kaarti ära ei tunne). Siis mõtlesin, et proovin Ubuntu uut versiooni (no see oli ikka võrreldes Peppermindiga täielik saabas.., aeglane ja vigu täis), lasin siis Linux Mint Cinnamoni uue versiooni peale kuna olin eelnevalt paar aastat Linux Minti kasutanud aga natuke näppides ja uurides tundus ikkagi, et Peppermint 8 on parim valik nende seast!

Siit ka küsimus, et mis kepp see selle id-kaardiga siis on, et minu ja ühe teise pereliikme kaart toimib ja kahe teise pereliikme kaardid mis on natuke uuemad väljalasked need ei toimi? Mida teha probleemi lahendamiseks?

NB. Viga ei ole kaardilugejas, sai proovitud ka välist lugejat ja sellega sama pull!

On kellegil äkki ideid, lahendusi, mõned sudo käsud asja lahendamiseks oma tagumisest vasakust teksapüksitaskust võtta?

Aitäh vastamast!
avatar küsitud 28. dets 2017 kategoorias Varia - Kodukola (0 punkti)
muudetud 28. dets 2017 - Kodukola

1 vastus

0 häält
Kui kaardi sertifikaadid on uuendatud pärast selle aasta novembri ID-kriisi siis on kaardil niisugune sertifikaat mille äratundmiseks Linuxis on vaja väga uut OpenSC versiooni. OpenSC uusim ametlik reliis 0.17 ei ole selleks piisavalt uus. RIA poolt väljastatavasse ametlikku ID-tarkvara komplekti kuulub piisavalt uus OpenSC, aga ühe või teise Linuxi distributsiooniga kaasasolev OpenSC on pigem tõenäoliselt liiga vana. Seega pakun välja sellise idee et kontrolli milline OpenSC versioon sul süsteemis on.
vastatud 28. dets 2017 - vatson (0 punkti)
OpenSC on: 0.15.0-1 ubuntu1

Kuda moodu ma seda uuendan? Kas võib olla, et pärast uuendamist ei tööta enam minu id-kaart?
Keegi hea inimene võiks juhendada ka kuidas seda automaatset paigaldusscripti kasutada saab  https://installer.id.ee/?lang=est

Lugesin siit foorumist selle scripti kasutamise kohta aga no ma ei tea, terminalist jookseb see script mul 1sekundiga läbi ja rohkem mitte midagi ei muutu? Ma ei tea, ma olen ikka nii lammas või mis asja, aru ma ei saa?

Kunagi on olnud kokkupuudet ja sain hakkama aga praegu ei mäleta ei "ööd ega mütsi" sellest!
Kuna Peppermint 8 on ülesehitatud Ubuntu 16.04 code base alusel siis ei tohiks väga raketiteadus see olla, et kõik id-kaardid saaksid toimida? Äkki keegi siin foorumis on tõesti nii tark ja oskab aidata rumalat vanainimest?

*Peppermint Eight is built on the Ubuntu 16.04 code base*
https://peppermintos.com/
ID.ee lehel hiire parema klahviga klõps automaatsel paigaldusskriptil. Avanevast menüüst valid "Salvesta link nimega..." Salvestad näiteks Töölauale. Avad selle install-open-eid.sh käepärast oleva tekstiredaktoriga. Leiad sealt koha
"# check if Debian or Ubuntu"
Kustutad Ubuntu, kirjutad asemele Peppermint.
Edasi natuke allapoole on Ubuntu), selle asemele Peppermint)
Nüüd edasi salvestad tehtud muudatused ja terminalis tuld.
See küll hetkel rohkem puusalt tulistamine, aga arvan, et peaks nii toimima. Kui mahti saan, siis proovin ise järgi. Oma Ubuntul põhineval opsüsteemil sain selliselt kaardimajanduse paika.
Lisan siia juurde veel, et omal on kogemus, et automaatse paigaldusskriptiga ei õnnestunud uuendamine, osa pakke jättis uuendamata. Muidugi peab olema RIA poolt toetatav opsüsteem. Ma kasutasin siis pakkide uuendamiseks
https://apps.ubuntu.com/cat/applications/precise/synaptic/
See näitab ära, millised pakid vajavad uuendamist ja sellega saab uuendada. Hetkel näitab, et arvutis olev OpenSC versioon on 0.17.0-1RIA5. Ja sellega uuendatud sertidega ID-kaart töötab.
Tänud härra tonksile, asi sai korda nii nagu sa juhendasid, "puusalt" pakutu toimis! Pidin muidugi synapticut ka kasutama (see õnneks Peppermindil samuti süsteemis kohe olemas).

Nice :)
...