Heli ei ole pärast Estobuntu 14.04 installi

0 häält
1,165 vaatamist
Tere!
 
Paigaldasin hiljuti vanale sülearvutile (2006. a Desknote) Estobuntu 14.04, ühtlasi on see minu esimene kokkupuude Linuxiga. Heli arvutist enam ei tule. Olen tundide viisi foorumeid kamminud ja seal pakutud lahendusi proovinud, kuid miski ei aita. Ka siinses foorumis sama teema alt ei saanud abi. Panen kirja mõned võimalikud vead/vihjed, mida olen leidnud:
 
1) alsamixer
AlsaMixer v1.0.27.2 erineb sellest, mida guugeldades näha võib. Vasakule-paremale nooltega liikudes on Item all "Beep", "Caller ID" ja "Off-hook", aga mitte "Master".
 
2) pavucontrol
Configuration lehel on tekst "No cards available for configuration". Muusikat mängides on Playback-i lehel näha justkui heli oleks.
 
3) ubuntu-bug pulseaudio
Väljavõte vearaportist:
AudioDevicesInUse
   Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/pmcC0D6c', '/dev/snd/pcmC0D6p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
 
4) aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 
5) lspci -v
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
    Subsystem: QUANTA Computer Inc Device 0748
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
 
Olen jooksutanud muuhulgas selliseid käske: sudo apt-get remove --purge alsa-base pulseaudio; sudo apt-get install alsa-base pulseaudio; sudo alsa force-reload; sudo apt-get update; sudo apt-get upgrade; sudo apt-get install dkms.
 
Kas oskate midagi soovitada?
Liisi
 
küsitud 15. nov 2015 kategoorias Algaja küsib - liisip (0 punkti)
Kui alsamixer-is F6-ga (Select sound card) midagi muud valida pole, siis see vihjab sellele, et helikaardi moodul kas puudub või pole kasutuses. Mida näitab 'lsmod | grep snd' ?
Kernel driver in use: snd_hda_intel
Viitab sellele, et siiski on moodul laetud.
Alsamixeris sai F6-ga valida küll, esimene valik on default ja teine HDA Intel. Aga midagi ei muutu sellest.

Sain sellise vastuse:

~$ lsmod | grep snd
snd_hda_codec_si3054    12864  1
snd_hda_codec_realtek    59451  1
snd_hda_intel          42794  3
snd_hda_codec         168250  3 snd_hda_codec_realtek,snd_hda_codec_si3054,snd_hda_intel
snd_hwdep              13272  1 snd_hda_codec
snd_pcm                85501  5 snd_hda_codec_si3054,snd_hda_codec,snd_hda_intel
snd_page_alloc         14230  2 snd_pcm,snd_hda_intel
snd_seq_midi           13132  0
snd_seq_midi_event     14475  1 snd_seq_midi
snd_rawmidi            25135  1 snd_seq_midi
snd_seq                55383  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28584  2 snd_pcm,snd_seq
snd                    60939  15 snd_hda_codec_realtek,snd_hda_codec_si3054,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
soundcore              12600  1 snd

2 vastust

0 häält
Vaata mida näidatakse selle peale:
 cat /proc/asound/card0/codec* | grep Codec

Vanemate masinate puhul tuleb võib-olla ette anda arvuti mudeli nimi. Tõsi, Ordi või Desknote ei sobi.
Kui Codec teada, siis saab edasi mõelda.
avatar vastatud 16. nov 2015 - imre (31 punkti)
Sain sellise vastuse:

~$ cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC880
Codec: Motorola Si3054
0 häält
Kas oskab keegi soovitada, mida edasi võiksin proovida? Pääsen nädalavahetusel üle pika aja jälle selle Linuxiga arvuti taha.
vastatud 3. dets 2015 - liisip (0 punkti)
Moodulite loetelust jääb mulje, et kõik on olemas ja võiks töötada.
Ma ei tea Ubuntu võimalusi heli vaikseks sundida.
Heli ei ole ka siis, kui see ei ole konkreetsele kasutajale lubatud.
Kas root-kasutajal ka pole heli?
Kas terminalis käsk 'id' audio gruppi kuulumist näitab?
/dev/snd/* on audio grupi seadmed ja neil on kirjutamisõigus üsna usutavasti ainult ruudule ja audio-grupile. Kui kasutaja ei kuulu audio-gruppi, siis tuleks see lisada.
Käsk 'id' audio gruppi kuulumist ei näidanud, lisasin selle, aga heli ikka ei ole.

'ubuntu-bug pulseaudio' annab ikka sama errorit, mis ülalpool kirjeldatud.

Proovisin veel:
1) ~$ wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
mille tulemus on siin: http://www.alsa-project.org/db/?f=c2d081cb95cb6692fc4ddba739c9c864284680ba

2) ~$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server

3) ~$ speaker-test

speaker-test 1.0.27.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 192 to 2097152
Period size range from 64 to 699051
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
 0 - Front Left
Time per period = 12,456992
 0 - Front Left
Time per period = 12,639732
....
Selle ajal mingit heli kuulda ei ole, aga kaks viimast rida muudkui korduvad. 'sudo speaker-test' annab errori.

Kas on veel mingeid soovitusi või oleks targem ubuntu uuesti peale panna?
> 'ubuntu-bug pulseaudio' annab ikka sama errorit, mis ülalpool kirjeldatud.

Ülal oli:
> AudioDevicesInUse
>    Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/pmcC0D6c', '/dev/snd/pcmC0D6p', '/dev/snd/seq', '/dev/snd/timer'] failed

Kirjutasid ka
> pavucontrol
> Configuration lehel on tekst "No cards available for configuration".
> Muusikat mängides on Playback-i lehel näha justkui heli oleks.

Neid fuser käske saab anda terminalis käsurealt sel ajal kui mingi lugu mängib.

Vaata
ls -l /dev/snd

Ja siis sealsetele seadmetele näiteks
fuser -v /dev/snd/pcmC0D0p
Nii võid kõik sealsed seadmed läbi proovida.

> .. kaks viimast rida muudkui korduvad.
Sel ajal saadetakse helikaardile 'merekohinat'. Kui test seisma panna, siis lõpeb ära.

Kui ei oleks teadet "No cards available for configuration", arvaks, et helikaardiga on kõik korras ja lihtsalt kõlar ei tee häält. Näiteks kõrvaklapi lüliti lülitas kõlari välja ja ei anna enam kontakti. Mõnikord aitab kõrvaklapi pistiku korduv sisse-välja liigutamine. Kas teade 'No cards ..' jäi ka pärast kasutaja audio-gruppi lisamist alles?

Võibolla annab ka BIOS-ist heli välja lülitada?

Ubuntu-rahvas, ehk oskate sõna sekka öelda?
Mul läheb selle katsetamisega nüüd jälle aega, kuna enne jõulu selle arvuti taha ei pääse.

See "No cards available..." oli pavucontrol Configuration lehel ka pärast audio gruppi lisamist alles.
Kahjuks ei õnnestunud heli korda saada. Ma kahtlustan, et asi võib olla helikaardiga sobimatutes draiverites. Varem on ka Windowsis ses asjas nokitsemist olnud. Igal juhul lahendasin selle Estobuntu 12.08 installimisega. Nüüd on paraku uus probleem: ID-kaarti ei saa kasutada, aga see ei käi enam selle teema alla. Aitäh kaasamõtlejatele!
...