Probleem heli väljundiga

0 häält
620 vaatamist

Pikemat aega olen mures heli väljundiga. Heli väljund kaob.

Olen otsinud erinevaid lahendusi ja üht-teist ka leidnud ning katsetanud. Olen saanud heli tagasi, aga see ei ole püsiv. Kestab mõnikord loetud minutid, mõnikord paar päeva, siis kaob.

Audio device: NVIDIA Corporation MCP67 High Definition Audio (rev a1)

Subsystem: Hewlett-Packard Company Device

Capabilities: <access denied>

Kernel driver in use: snd_hda_intel

Kernel modules: snd-hda-intel

 

Operatsioonisüsteem Estobuntu 12.08

 

Heli olen saanud tagasi järgnevate käskudega:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

 

Alternatiivse lahendusena olen proovinud gnome alsamixerit.

sudo apt-get autoremove pulseaudio 

sudo apt-get install gnome-alsamixer

http://www.hecticgeek.com/2012/01/how-to-remove-pulseaudio-use-alsa-ubuntu-linux/

Probleeme see siiski täiesti ei lahenda

Olen väga tänulik, kui keegi annaks juhise, kuidas probleemi tegelik põhjus avastada ja heli püsivaks muuta. Googles ringi seigeldes leiab, et analoogse probleemiga on mures paljud. Mingiks ajaks pakutud lahendused ka toimivad, aga probleem ilmneb taas.

Täpsustatud küsimuseks on kuidas avastada, mis lülitab helikaardi välja.

küsitud 10. dets 2014 kategoorias Algaja küsib - okaspendel (0 punkti)
muudetud 18. dets 2014 - okaspendel
Erinevate katsetustega jõudsin järeldusele, et mingi programm lülitab välja helikaardi (NVidia HDA). Mõnikord aitab restart, mõnikord reinstall.

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
Kas on tegemist lauaka või läpakaga?
Läpakas HP Pavilion
Läpakatega ei ole kogemusi.  :(
Mul sama mure juba pikemat aega. Võibolla keegi oskab aidata, saaksin ka korda:)
Mis läpaka konkreetne mudel on? Samuti võiks kopeerida siia:
        aplay -l
väljundi.

maqx14, sul ka Estobuntu 12.08? Ja sama läpakas?

okaspendel, kas sa saad aru, mida need käsud teevad :D
        sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
See näiteks lisab veel ühe repo, kust tuleb Pulseaudio arendusversioon, mis ei pruugi ka korralikult töötada. Ehk siis, kui aru ei saa, ära toksi tundmatuid käske sisse.

Aga probleemist. Mida mina teeksin, kui nii juhtub. Kui heli ära kaob, siis kontrolliksin, kas helikaardi moodul on laaditud.
        lsmod | grep snd_hda_intel

Kui pole, siis tuleb uuesti laadida. Kui aga on olemas, siis prooviksin pulseaudiot uuesti käivitada.
        pulseaudio -k
        pulseaudio --start

Kui see aitab, st. iga kord, kui heli ära kaob ning pulseaudio restart toob ta tagasi, siis tuleb edasi uurida, miks PA ära sureb.
Läpakas on HP Pavilion dv6500

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: CX20549 Analog [CX20549 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: CX20549 Digital [CX20549 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Käskudest eriti aru ei saa, ainult üldjoontes ja kohati. Olen kopeerinud foorumitest leitavaid käske. (nt siit: https://help.ubuntu.com/community/SoundTroubleshooting) Ise käske koostada ei oska.

Hetkel on mul installitud gnome alsamixer. Paar päeva on tõrgeteta töötanud. (Nagu eelnevalt olen kirjutanud, siis on ka sellega analoogne probleem olnud)
Ei, minul Thinkpad 410 ja Lubuntu 14.04. Jamad juba Fedora ajast(st. mingi aasta jagu juba).

Küsimusele vastamiseks logi sisse või registreeru.

...