eKool ei käivita ID-kaardiga sisselogimist Linux mint 17

0 häält
980 vaatamist

Sellest sügisest sai tehtud lapsevanema ekooli kasutaja.

Mõned korrad lasi sisse logida ID-kaardiga. Üldiselt tõrkus ja pidi uuesti proovima.

Nüüd ei lase üldse. Peale ID-kaart vajutamist läheb tuhmiks ja jääb ringi keerutama.
Ei viska ette Pin1 ja isiku sertifikaadi akent.

Firefox Web Console viimased read:
POST https://ee.ekool.eu/dwr/call/plaincall/__System.pageLoaded.dwr [HTTP/1.1 200 OK 190ms]
GET https://ssl.google-analytics.com/__utm.gif [HTTP/1.1 200 OK 43ms]
POST https://ee.ekool.eu/dwr/call/plaincall/userAccountManager.selectLanguage.dwr [HTTP/1.1 200 OK 76ms]
POST https://ee.ekool.eu/dwr/call/plaincall/userAccountManager.getSessData.dwr [HTTP/1.1 200 OK 78ms]
POST https://ee.ekool.eu/dwr/call/plaincall/userAccountManager.getServerTimeStamp.dwr [HTTP/1.1 200 OK 192ms]
GET https://id.ekool.eu/idCardChecker.php [0ms]

See probleem on kahes Mint 17 64-bit arvutis:
Firefox 32.0
ID-kaart Firefox lisa 3.8.0.1052

Pangas töötavad vana ja uus id-kaart. p, li { white-space: pre-wrap; }

ID-kaardi haldusvahend:

Keeleseaded (aja-, numbriformaat / kooditabel): Estonian / et_EE.UTF-8

Baastarkvara: 3.8.0-99koodur4
Rakenduse versioon: 3.8.0.0
Operatsioonisüsteem: Linux Mint 17 Qiana
Protsessor: Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz
Tuum: Linux 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64

Argumendid: qesteidutil
Teegi otsing: /usr/lib/x86_64-linux-gnu/qt5/plugins;/usr/bin
Teegid:
libdigidoc2 (3.8.0.1133-99koodur2)
libdigidocpp0 (3.8.0.1208-99koodur2)
qdigidoc (3.8.1.1250-99koodur1)
qesteidutil (3.8.0.1106-99koodur3)
openssl (1.0.1f-1ubuntu2.5)
libpcsclite1 (1.8.10-1ubuntu1)
opensc (0.13.0-3ubuntu4.1ria1koodur0)
QT (5.2.1)
Smart Card teenuse staatus: Töötab
Kaardilugejad:
OMNIKEY CardMan 1021 00 00 max APDU size 65536

Reader state: CHANGED|PRESENT|INUSE


 

Samas võrgus on veel arvuti Mageia 4 Firefox 24.7.0 ja ID-kaardi lisa 3.7.1.
Selles arvutis eKool ID-kaardiga logimine toimib.

Midagi on Linux mint 17 arvutites paigast?
eKool ei ole võimeline uuema tarkvaraga töötama?

 


 


 

avatar küsitud 23. sept 2014 kategoorias Algaja küsib - hunt_1 (-1 punkti)

1 vastus

0 häält
Mul Linux Mint 17 KDE ja Firefoxiga sama jama. Varem proovisin ka Cinnamoni ja Matega, ikka tulutult. Chromega toimib asi korralikult. Järeldan sellest, et viga on Mindi, Firefoxi ja ekooli koosluses, mitte Mindis üksi.
vastatud 23. sept 2014 - Sander (4 punkti)
muudetud 23. sept 2014 - Sander
Töölaua versioon ei mängi mingit vahet... olgu ta Mate, KDE vms. Igatahes RIA viimaste avaldatud pakkidega Fedoras töötab (3.8 ja osad komponendid 3.9...https://installer.id.ee/media/sources/). Viga võib olla selles kooduri pakkides. Ma isiklikult ei tea, mis patche Lauri seal kasutatud on (ja ei viitsi järgi ka uurida).
Hundi postitatud teegid on osad vanad... peaks olema 3.9 versiooni peal. Mitte küll kõik, aga 3 või 4 komponenti.
Egas muud midagi ei oska soovitada, kui pakkide koostajaga kontakteeruda ja paluda tal need mõned komponendid uuendada... ehk sellest juba piisab. Või siis kurta ekooli muret ja ta saab juba ise testida.

LISA.
Kuna Mint 17 baseerub ubuntu 14.04-l, siis võiks mõni ubuntu kasutaja sõna sekka öelda. Võimalik, et teen praegu lauri pakkidele oma ütlemisega liiga :P
Samuti on RIA-l endal olemas pakid 14.04-le... võid ka neid proovida. Eemaldades enne kooduri varamu ja pakid.
Tänan.
Paigaldasin RIA oma ja nüüd eKool toimib.
Loodetavasti teised kohad samuti.
Hetkel selline seis:
Argumendid: qesteidutil
Teegi otsing: /usr/lib/x86_64-linux-gnu/qt5/plugins;/usr/bin
Teegid:
libdigidoc2 (3.9.0.1167-ubuntu-14-04)
libdigidocpp0 (3.9.0.1237-ubuntu-14-04)
qdigidoc (3.9.0.1297-ubuntu-14-04)
qesteidutil (3.8.2.1134-ubuntu-14-04)
openssl (1.0.1f-1ubuntu2.5)
libpcsclite1 (1.8.10-1ubuntu1)
opensc (0.13.0-3ubuntu4.1ria1koodur0)
QT (5.2.1)

Smart Card teenuse staatus: Töötab
Kaardilugejad:
OMNIKEY CardMan 1021 00 00 max APDU size 65536
Reader state: CHANGED|PRESENT|INUSE

Niisama: ei meeldi see uus postitamise asjandus, kasutan vana.
Ubuntus seda probleemi pole, toimivad nii Firefox kui ka Chrome
Linux distro siin suurt ei määra. Näiteks meil on nii et mingi nädal tagasi töötas ekool.ee ametliku id-kaardi tarkvaraga 32-bit Linux Mint 17 kui ka 64-bit Ubuntu 14.04 Firefox'iga ver. 32. Hetkel töötab ekool.ee Chrome'ga ver. 37.0.2062.120.

Pakun et props on ekool.ee portaalis mis ei suuda suhelda Firefoxi ja id-kaardi tarkvaraga. Samas kõik muu id-kaardiga Firefoxis töötab (eesti.ee, pangad jne).  
Nii et kasuta ekool.ee portaalis id-kaardiga hetkel chrome brauserit. Chrome vähemalt seal töötab.
...