Kuidas saada ID-kaart tööle Ubuntu 14.04 beetaga?

0 häält
5,238 vaatamist
Alates beetaversioonist (26.03.14 päevatõmmisest), ei tööta enam RIA saucy paketid. Ei aita ka libccid 1.4.15-1 asendamine vanema 1.4.12-1 versiooniga. Ikka veateade, et qdigidoc ja qesteidutil pakette ei saa paigaldada.

Tundub, et probleemiks on uuendatud libqt5core5a pakett. Paketid qesteidutil ja qdigidoc sõltuvad paketist libqt5core5 (ilma "a" täheta). Tuleb vist oodata, kuni RIA neid muudab.
küsitud 28. märts 2014 kategoorias Ubuntu, Kubuntu jne - arvomagi (0 punkti)
kategooria muudetud 29. märts 2014 - arvomagi
Ehk lisad ka täpsema veateate?
The following packages have unmet dependencies:
 estonianidcard : Depends: qdigidoc but it is not going to be installed
                  Depends: qesteidutil but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Vaata, mis pakke kinni hoitakse: apt-mark showhold
ja vajadusel lase nad lahti: sudo apt-mark unhold <paki nimi>
Mis seepeale toimub?

2 vastust

+1 hääl

ID-kaardi tarkvarapaketid Ubuntu 14.04 jaoks on saadaval siin: http://lauri.xn--vsandi-pxa.com/blog/ubuntu-trusty-esteid.html

vastatud 18. apr 2014 - laurivosandi (1 punkt)
Paigaldasin viidatud varamust ID-kaardi tarkvara. Töötab Firefoxi ja Swedbankaga. Tuhat tänu!
Toimetasin etteantud juhiste järgi aga miskipärast digidoc ei avane ja firefoxis lhv ja sebi lehel ütleb, et kaarti ei leita.
Haldusvahendis oleks nagu kõik korras:
Keeleseaded (aja-, numbriformaat / kooditabel): Estonian / et_EE.UTF-8

Baastarkvara: 3.8.0-99koodur4
Rakenduse versioon: 3.8.0.0
Operatsioonisüsteem: Ubuntu 14.04 LTS
Protsessor: Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz
Tuum: Linux 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686

Argumendid: qesteidutil
Teegi otsing: /usr/lib/i386-linux-gnu/qt5/plugins;/usr/bin
Teegid:
libdigidoc2 (3.8.0.1133-99koodur2)
libdigidocpp0 (3.8.0.1208-99koodur2)
qdigidoc (0.4.1-0ubuntu1)
qesteidutil (3.8.0.1106-99koodur3)
openssl (1.0.1f-1ubuntu2)
libpcsclite1 (1.8.10-1ubuntu1)
opensc (0.13.0-3ubuntu4)
QT (5.2.1)

Smart Card teenuse staatus: Töötab
Kaardilugejad:
OMNIKEY CardMan 1021 00 00 max APDU size 65536
Reader state: CHANGED|PRESENT|INUSE
ID - 38004140236
ATR cold - 3BFE1800008031FE454573744549442076657220312E30A8
ATR warm - 3BFE1800008031FE45803180664090A4162A00830F9000EF

Veebibrauserid:
firefox (28.0+build2-0ubuntu2)

USB info:
Bus 002 Device 003: ID 05ca:18a0 Ricoh Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 076b:1021 OmniKey AG CardMan 1021
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 005: ID 413c:8156 Dell Computer Corp. Wireless 370 Bluetooth Mini-card
Bus 003 Device 004: ID 413c:8158 Dell Computer Corp. Integrated Touchpad / Trackstick
Bus 003 Device 003: ID 413c:8157 Dell Computer Corp. Integrated Keyboard
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Firefoxis peavad Add-ons alt vastu vaatama lubatud EstEID plug-in ja ID Card PKCS11 module loader.
'Preferencies' all on kuskil 'Advanced' all 'Security Devices' seadmine.
Seal peab olema ID-kaardi moodul näha, mingi onepin-opensc-pkcs11.so või midagi taolist.
0 häält

Lühidalt jah RIA poisid peavad 14.04 jaoks uued pakid tegema.

Põhjuseks on QT 5.0-lt üleminek 5.2-le ja seoses sellega ei ole ABI (application binary interface) enam ühilduv. API on väidetavalt endiselt ühilduv ning nagu ma aru saan, siis tuleks pakid lihtsalt rebuildida.

It is important to note that Qt 5.2 has ABI breakage [2] so all Qt
depending packages need a rebuilt. It is partially forced by the
library rename "libqt5core5" to "libqt5core5a", which conflict.

Viited:
https://lists.launchpad.net/ubuntu-phone/msg05681.html
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=731261#35
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=740511#15
http://packages.ubuntu.com/search?keywords=libqt5core5&searchon=names

avatar vastatud 17. apr 2014 - Cancer (0 punkti)
Tervist,

liitun antud teemaga, kuna esineb endal ka probleeme Ubuntu 14.04-ga internetipanka sisenemisel.

Kasutan USB ID-kaardi lugejat- Klickist eelmsiel nädalal soetatud - tõenaäoliselt igati ID-tarkvara kõlbulik.
ID-haldusvahendid, Digidoc ja Digicrypto sai installeeirtud Ubuntu tarkvarakeskusest otse läbi otsingu.
haldusvahendid tunnevad ID-kaarid ära, mis tähendab et riistavra toimib.
Samuti töötavad Digidoc ja Digicrypto.
Ei õnnestu aga interneti panka siseneda. Firefoxi ad-in-des ei näe ühtegi estID või midagigi id-kaardi tarkvara meenutavat ad-i.

kas on ideid?
Mis reposid sa ID tarkvara paigaldamiseks kasutad? Kas estobuntu omasid?
Tere

Probleem:  paigaldasin ubuntu14.04 ja ID kaardi lugeja tarkvara, kuid see ei leia HP lapakal kaardilugejat üles.

Palun abi, soovitusi

diagnostics.txt
==============
Keeleseaded (aja-, numbriformaat / kooditabel): Estonian / et_EE.UTF-8

Baastarkvara: 3.8.0-99koodur4
Rakenduse versioon: 3.8.0.0
Operatsioonisüsteem: Ubuntu 14.04 LTS
Protsessor: Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz
Tuum: Linux 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686

Argumendid: qesteidutil
Teegi otsing: /usr/lib/i386-linux-gnu/qt5/plugins;/usr/bin
Teegid:
libdigidoc2 (3.8.0.1133-99koodur2)
libdigidocpp0 (3.8.0.1208-99koodur2)
qdigidoc (3.8.1.1250-99koodur1)
qesteidutil (3.8.0.1106-99koodur3)
openssl (1.0.1f-1ubuntu2.1)
libpcsclite1 (1.8.10-1ubuntu1)
opensc (0.13.0-3ubuntu4.1~koodur0)
QT (5.2.1)

Smart Card teenuse staatus: Töötab
Kaardilugejad:
Hewlett-Packard Company HP USB Smart Card Keyboard [CCID Interface] (08178085) 00 00 max APDU size 65536


Veebibrauserid:
firefox (29.0+build1-0ubuntu0.14.04.2)

USB info:
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 04f2:b053 Chicony Electronics Co., Ltd
Bus 001 Device 007: ID 03f0:1024 Hewlett-Packard Smart Card Keyboard
Bus 001 Device 006: ID 0461:4d20 Primax Electronics, Ltd HP Optical Mouse
Bus 001 Device 005: ID 145f:0199 Trust
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc. AES2810
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
vaata käsuga pcsc_scan kas lugeja leitakse või mitte, siis saaks edasi minna sealt.
opensc-tool --list-readers
See näitaks ka ära.
kasutan ubuntu 14.04 64bit inglisekeelset versiooni (nädal tagais alla tõmmatud ubuntu kodukalt)- leidis mu uuel läbakal kõik jupid kenasti üles, interneti pulk töötab, häält ja ekraani heledust annab otse nuppudest timmida- ühesõnaga täiesti toimiv süsteem selle konkreetse läpaka jaoks. ID- soft ei ole tõenäoliselt estobuntu oma, kuigi keegi peale eestlaste seda tõenäolsielt ubuntu softi-keksusesse üles lükanud ei ole. püüdsin alguses estobuntu lehelt tõmmatud ID-kaardilugeja tarvarapaketi peale saada.  toimetas terminalis ilusti mitu minutit, aga sisuliselt tööle ei hakanud- programme endid unitist üles ei leidnud.
Siis otsisin lihstalt Ubuntu enda softikogumikust ID ja Digi sisaldavaid programme ja leidis just need samad Eesti asjad (digidoc, diicrypto ja id-haldusvahendid üles). installeerisin ja leidis kaardilugeja jne. aga jahh, interneti pank ei toimi.võibolla proovin õhtul siin lingitud versioonid ära
...