Open SUSE 11.4 ja ID kaart

0 häält
1,129 vaatamist
Püüdsin panna uuemat Open SUSEt peale, aga pidin ikkagi minema tagasi vana Open SUSE 11.4 peale. Nüüd ei saa enam ID kaarti tööle. Firefoxil on uuem versioon 16.0.2 peal. Oskab ehk keegi aidata?
avatar küsitud 29. jaan 2014 kategoorias SUSE - ht (0 punkti)
kategooria muudetud 29. jaan 2014 - sander85
Kus täpsemalt toppama jääd?
Tuleb muidugi öelda, et minule teadaolevalt OpenSUSE jaoks hetkel ID-tarkvara tuge keegi ei paku..
Tegin selle juhendi järgi http://id.ee/?id=34228

Tundub, et tuleb Open SUSE 12.2 püüda peale ajada. Sellele peaks olema ID kaardi tugi. https://installer.id.ee/media/

Käsk;   sudo sh install-esteid-opensuse.sh
RIA Repository key already loaded
Repository 'Updates for openSUSE 11.4 11.4-0' is up to date.
Repository 'openSUSE-11.4-11.4-0' is up to date.
Repository 'openSUSE-11.4-Non-Oss' is up to date.
Retrieving repository 'RIA' metadata [\]
File '/repodata/repomd.xml' not found on medium 'https://installer.id.ee/media/opensuse/11.4'
Mul käib OpenSUSE-13.1-s (x64) RIA 12.2-le pakutav komplekt.
Kas uuendasid Open SUSE 12.2 pealt või tegid uue installi? Kui uue, siis kuidas said ID- kaardi tööle?
Proovisin panna Open SUSE 12.3 kohe peale, aga taas ID- kaart ei hakanud tööle.
Panin seejärel peale Open SUSE 12.2 ja nüüd ID- kaart töötab, ning seejärel uuendasin 12.3 peale ja ID- kaart töötab kenasti edasi.

1 vastus

0 häält
Ei teinud muud kui valisin repoks RIA openSUSE-12 repo

https://installer.id.ee/media/opensuse/12.2

 ja siis installeerisin yastis esteid, id-kaaardi ja digidoc-i asjad.

Firefoxis tuli näidata õige 'Security Device', mul siis /usr/lib64/onepin-opensc-pkcs11.so.
avatar vastatud 31. jaan 2014 - akbgf (1 punkt)
See tähendab ilmselt siiski juba seda, et tuleb paigaldada värskem openSUSE ja 11.4-ga lihtsalt pole võimalik hetkel enam ID-tarkvara pruukida.
11.4-s, kui RIA veel ei pakkunud SUSE-le, siis kompileerisin lähtetekstist kogu komplekti, aga see oli tükk nikerdamist. See oli aprillis 2011 ja versioon 3.4. Varsti pärast seda tekkis RIA reposse ka SUSE komplekt rpm-e. Kui leiad kuskilt veel need, siis võiks ehk käima saada, aga v. 3.4 ei toetanud uusi ID-kaarte, nii et uue ID-kaardiga on ka uuemat id-tarkvara vaja. Praeguse komplekti sõltuvuste lahendamine SUSE-11.4-s võib tähendada ikkagi kogu SUSE väljavahetamist.
Panin Open SUSE 12.2 peale ja uuendasin 12.3. ID-kaart töötab. Aga nüüd on väike probleem, et kui varem sai 11.4 peal sättida desktopi peale käivitatavad ikoonid, siis nüüd on nad kuhugi ära peidetud.
Kas oleks võimalik selliseid ikoone teha ja kas näiteks ka koos käsuga.
Tundub olevat küsimus teisest teemast :)
...