Firefoxi uuendus

0 häält
405 vaatamist
Tere.

Mul selline küsimus kui äkki saate aidata.
Arvutil on Lubuntu 18.04.5 LTS 64Bit ja Firefox 79.0 (64Bit).
Ma olen proovinud Firefox-i uuendada käsitsi  87.0-i või 89.0-i peale,
aga alati on installimisel teinud uuenduse firefox 109.0+build2-0ubuntu0.18.04.1 bionic-uks.
Midagi läheb valesi.

Firefox 79.0-l on tehtud:

  cd /etc/firefox
  sudo mkdir policies
  cd policies
  sudo nano policies.json

{
"policies": {
    "AppAutoUpdate": false,
    "DisableAppUpdate": true,
    "DisableTelemetry": true
   }

}

Kui oleks võimalik kirjutada täielik installimise käik käskudega,
mida ja millises järjekorras peab tegema, et uuenduse tehtud saaks.

Ette tänades..
Aare
avatar küsitud 3. veebr 2023 kategoorias Algaja küsib - aareboy (0 punkti)

1 vastus

0 häält
Kuidas sa seda uuendust teed?

Kas pakihalduri kaudu?
avatar vastatud 6. veebr 2023 - spott (11 punkti)
Olen teinud terminalis. Eelmine maha ja käskudega.
Kasutasin neid kohti:
https://ftp.mozilla.org/pub/firefox/releases/
https://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/
Aga nüüd on kuhugi kaduma läinud õpetus käskudest õiges(toimivas) järjekorras.

Firefox 79.0 on koheselt peale Lubuntu 18.04.5 LTS 64Bit installi peal.
Siis kui plaadi väljastas võtsin neti tagant ära ja tegin restardi, muidu kukub koheselt uuendama.
Esimeseks peale käivitumist kohe see:

  cd /etc/firefox
  sudo mkdir policies
  cd policies
  sudo nano policies.json

{
"policies": {
    "AppAutoUpdate": false,
    "DisableAppUpdate": true,
    "DisableTelemetry": true
   }

}

Selle järgi firefoxis: https://www.technipages.com/enable-disable-automatic-updates-in-firefox
Ühesõnaga ff-i isetegevus maha.
Pakihalduri kaudu installib kõige viimase versiooni. Selle kaudu pole uuendanud.

Panin selle küsimuse siia sellepärast, et sooviks saada täielikku käskude ja tegevuse  järjekorda.
Sulle on juba teises teemas kirjutatud, mida teha:
Võta uuem versioon maha. Installi omale sobiv versioon ja siis

$ sudo apt-mark hold firefox*


https://askubuntu.com/questions/18654/how-to-prevent-updating-of-a-specific-package

See, mis sa praegu Firefoxil sisse oled kirjutanud - seda ei loe paketihaldurid. Linuxis käib uuendamine teisiti.
Ning vanema versiooni paigaldamiseks otsi vastav deb pakett - nii lihtsam.
Ehk - eemaldad vaikimisi Firefoxi. Tõmbad alla vastava deb paketi ja paigaldad selle. Kuid keelad automaatsed uuendused pakile.

Kui aga sourcest tahad paigaldada ja keelata sinu viidatud moel uuendused, siis arvatavasti muudad üldse valesid faile.
...