Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
saekaater
Uus kasutaja
Uus kasutaja


Vanus: 29
Liitunud: 28.12.2005
Postitused: 14

Distributsioon: Arch
estonia.gif
postituspostitatud: 02.05.2006, 22:26  postituse pealkiri:  X ei lähe tööle  

Muutsin siis mina natuke xorg.conf failis mõnda asja. Loomulikult enne muutmist tegin ma sellest failist ka igaksjuhuks koopia. Salvestasin siis ära ja otsustasin teha xile restarti. Panen siis xi kinni ja kirjutan mina startx. Ootan natuke aega ja vaatan, et jama lugu ei lähe käima. No mõtlen siis mina, et egas siis midagi, et taastan vana millega just enne natuke aega tagasi töötas. Taastan siis selle vana, aga ikkagi ei lähe xkäima. Proovisin seal siis veits timmida aga ei saanud mina sellest jagu. Et äkki oskab keegi palun öelda mida teha tuleks.
/var/log/Xorg.0.log faili 10 viimast rida on järgmised:
(**) Option "XkbModel" "pc105"
(**) Keyboard1: XkbModel: "pc105"
(**) Option "XkbLayout" "et"
(**) Keyboard1: Xkblayout: "et"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeyvodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
Could not init font path element /usr/X11RG/lib/X11/fonts/CID/, removeing from list!

Aitäh.


2ndalpha
Pingviini kasutaja
Pingviini kasutaja


Vanus: 32
Liitunud: 16.04.2006
Postitused: 45

Distributsioon: Gentoo
estonia.gif
postituspostitatud: 02.05.2006, 23:19  postituse pealkiri:  (teema puudub)  

Read mis algavad (EE) või (WW) -ga on tähtsad. Järsku lisad manusena logi ja confi.


spott
Admin
Admin


Vanus: 38
Liitunud: 04.06.2005
Postitused: 8779

Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 03.05.2006, 05:08  postituse pealkiri:  (teema puudub)  

mis muudatusi ja milleks sa täpsemalt tegid?
Ega modularsele X-le ei kolinud?

_________________
Tellige endale sünnipäevaks, sõbrapäevaks või muuks tähtpäevaks kingitus: Kingitused internetist - NetiKink.eu

saekaater
Uus kasutaja
Uus kasutaja


Vanus: 29
Liitunud: 28.12.2005
Postitused: 14

Distributsioon: Arch
estonia.gif
postituspostitatud: 03.05.2006, 06:33  postituse pealkiri:  (teema puudub)  

Seal kus need Display modes on, sinna lisasin ainult "1600x1200" "1280x1024".


Xorg.0.log.txt
 Kirjeldus:
Panin siis tere selle faili nagu soovisite.

Allalaadimised
 Failinimi:  Xorg.0.log.txt
 Failisuurus:  52.86 kB
 Alla laaditud:  269 kord(a)


taavi
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 25.07.2005
Postitused: 59

Distributsioon: Arch, Debian
blank.gif
postituspostitatud: 03.05.2006, 13:15  postituse pealkiri:  (teema puudub)  

xorg.conf kuluks ju ka marjaks.


HoHo
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.07.2005
Postitused: 527
Asukoht: Tallinn/Paide
Distributsioon: Gentoo
estonia.gif
postituspostitatud: 03.05.2006, 13:39  postituse pealkiri:  (teema puudub)  

Tundub et otseseid vigu ei ole, vähemalt mitte tolles logis.
Võibolla loll küsimus kuid kas restarti ei ole teinud vahepeal? Ehk on mõni X'i jupp käima jäänud ning ei lase uut käivitada?

Teine variant on et X kirjutab oma logi kusagile teise faili. Selle peaks saama kindlaks teha kui võrrelda /var/log kaustas erinevate X'i logide muutmiskuupäevasid.


saekaater
Uus kasutaja
Uus kasutaja


Vanus: 29
Liitunud: 28.12.2005
Postitused: 14

Distributsioon: Arch
estonia.gif
postituspostitatud: 03.05.2006, 15:28  postituse pealkiri:  (teema puudub)  

Restarti olen päris mitu korda teinud. Ma panin siis xorg.conf faili ka.


xorg.conf.txt
 Kirjeldus:

Allalaadimised
 Failinimi:  xorg.conf.txt
 Failisuurus:  15.49 kB
 Alla laaditud:  270 kord(a)


spott
Admin
Admin


Vanus: 38
Liitunud: 04.06.2005
Postitused: 8779

Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 03.05.2006, 15:34  postituse pealkiri:  (teema puudub)  

Muideks - kas ta lihtsalt ei lähe tööle ja viskab tagasi terminali või jääb sul must pilt ette?

_________________
Tellige endale sünnipäevaks, sõbrapäevaks või muuks tähtpäevaks kingitus: Kingitused internetist - NetiKink.eu

saekaater
Uus kasutaja
Uus kasutaja


Vanus: 29
Liitunud: 28.12.2005
Postitused: 14

Distributsioon: Arch
estonia.gif
postituspostitatud: 03.05.2006, 15:59  postituse pealkiri:  (teema puudub)  

Kõigepealt kui käima panen läheb kõik hästi. Korraks tuleb see kursor ka ette ja siis viskab terminali tagasi. Sellised kirjad tulebad siis ka:
...

/usr/bin/xfce4-session: error while loading shared libaries: libcairo.so.2: cannot open shared object file: no such file or directory
Agent pid 2988 killed

Waiting for X server to shut down


HoHo
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.07.2005
Postitused: 527
Asukoht: Tallinn/Paide
Distributsioon: Gentoo
estonia.gif
postituspostitatud: 03.05.2006, 16:31  postituse pealkiri:  (teema puudub)  

Heh, sellest oleks pidanud alustama Smile
On kolm varianti:
1) X lingiti teise Cairo versiooniga
2) Reinstallisid teise versiooni Cairost ning too symlink koristati ära
3) sul on Cairo installimata

Mina prooviks kõigepealt Cairo uuesti installida. Kui see ei aita siis X'i. Kui see ka ei aita siis võib alati proovida pisut "häkkida" ning too symlink ise tekitada.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group