Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
DeadMeat
Pingviini külastaja
Pingviini külastaja



Liitunud: 21.04.2006
Postitused: 32
Asukoht: Tartu
Distributsioon: gentoo
estonia.gif
postituspostitatud: 01.10.2006, 15:22  postituse pealkiri:  firefox fonts ja characters encoding  

Hiljuti ma muutsin oma süsteemi encodingu UTF-8 peale ja tegin seda nende õpetuste järgi:
http://www.gentoo.org/doc/en/utf-8.xml ja http://gentoo-wiki.com/HOWTO_Make_your_system_use_unicode/
aga nüüd konqueror, pine (konsooli põhine email'i klient) ja teksti editorid ei näita täpitähti, nagu ennem kui ma kasutasin ISO-8859-15, nüüd on nende asemel tühjad kastid.

Teine probleem on selles et firefox (1.5.0.7) muudab mu encodingut iga lehe jaoks, et ühel lehel on see western iso-8859-1 siis teisel on see iso-8859-15 või unicode utf-8
või veel midagi neljandat, kuigi ma olen pannud firefoxi seadetes
default character encoding is unicode (utf-8) ja olen linnukese ära võtnud "
allow pages to choose their own fonts, instead of my selection
above" ja nüüd sellepärast kui webilehtedel on utf-8 encoding siis on mul font väga väike ja kole

Näide gentoo foorumi'st kui UTF-8 encoding on peal:
http://lepo.it.da.ut.ee/~jormas/forumsgentooUTF8.png
Ja näide kui muudan selle ära Western ISO-8859-15 peale:
http://lepo.it.da.ut.ee/~jormas/forumsgentooISO8859-15.png

Aga kui ma kasutan konquerori (koos utf-8) et käia webilehtedel siis on kõik ok, fondid on korras ja õige suurusega ehk siis täpselt nii nagu on iso8859-15 puhul.

locale käsu output:
Kood:

deadmeat-pc jorma # locale
LANG=en_US.UTF-8
LC_CTYPE="et_EE.UTF-8"
LC_NUMERIC="et_EE.UTF-8"
LC_TIME="et_EE.UTF-8"
LC_COLLATE="et_EE.UTF-8"
LC_MONETARY="et_EE.UTF-8"
LC_MESSAGES="et_EE.UTF-8"
LC_PAPER="et_EE.UTF-8"
LC_NAME="et_EE.UTF-8"
LC_ADDRESS="et_EE.UTF-8"
LC_TELEPHONE="et_EE.UTF-8"
LC_MEASUREMENT="et_EE.UTF-8"
LC_IDENTIFICATION="et_EE.UTF-8"
LC_ALL=et_EE.UTF-8
deadmeat-pc jorma #


ja locale -a output:
Kood:

deadmeat-pc jorma # locale -a
C
de_DE
de_DE@euro
en_HK
en_PH
en_US
en_US.utf8
es_MX
et_EE.iso885915
et_EE.utf8
fa_IR
fr_FR
fr_FR@euro
it_IT
ja_JP
ja_JP.eucjp
ja_JP.utf8
POSIX
deadmeat-pc jorma #     


cbr
Pingviini aktivist
Pingviini aktivist


Vanus: 31
Liitunud: 31.08.2005
Postitused: 283
Asukoht: Tallinn/Rakvere
Distributsioon: Kubuntu GNU/Linux
estonia.gif
postituspostitatud: 01.10.2006, 15:48  postituse pealkiri:  (teema puudub)  

Leht paneb ise paika, millist encodingut ta kasutab. Siin ei ole sinul mõtet nendega mängida. Las brauser kasutab seda, mida veebileht ette annab.


DeadMeat
Pingviini külastaja
Pingviini külastaja



Liitunud: 21.04.2006
Postitused: 32
Asukoht: Tartu
Distributsioon: gentoo
estonia.gif
postituspostitatud: 01.10.2006, 16:13  postituse pealkiri:  (teema puudub)  

seda küll jah, kuid vaata milline ta välja näeb siis:
http://lepo.it.da.ut.ee/~jormas/forumsgentooUTF8.png


markus
Pingviini kasutaja
Pingviini kasutaja


Vanus: 33
Liitunud: 11.08.2006
Postitused: 43
Asukoht: Tartu
Distributsioon: Gentoo
blank.gif
postituspostitatud: 01.10.2006, 16:16  postituse pealkiri:  (teema puudub)  

Pakun praegu huupi, aga kas v6ib olla, et settingutes on m22ratud fondid mis ei toeta unicode'i? Yks nimekiri unicode fontidest on siin:
http://en.wikipedia.org/wiki/Unicode_fonts


antik
Pingviini aktivist
Pingviini aktivist



Liitunud: 25.08.2006
Postitused: 159


estonia.gif
postituspostitatud: 01.10.2006, 19:09  postituse pealkiri:  (teema puudub)  

DeadMeat kirjutas:
seda küll jah, kuid vaata milline ta välja näeb siis:
http://lepo.it.da.ut.ee/~jormas/forumsgentooUTF8.png


Ma Firefoxi küll ei kasuta, kuid Konqueroris näeb gentoo foorum välja selline. Kasutan DejaVu fonte. Microsofti TTF fonte ei ole installeerinud.


DeadMeat
Pingviini külastaja
Pingviini külastaja



Liitunud: 21.04.2006
Postitused: 32
Asukoht: Tartu
Distributsioon: gentoo
estonia.gif
postituspostitatud: 01.10.2006, 20:09  postituse pealkiri:  (teema puudub)  

ma tean küll kuidas peab välja nägema tegelikult ma ju kirjutasin kah esimeses postis. ( http://lepo.it.da.ut.ee/~jormas/forumsgentooISO8859-15.png )
ISO8859-15 juures ma saan muuta fonti, bitstream, dejavu kõik töötab kuid UTF-8 kohta ei ole midagi. Ja kõige huvitavam asi on see, et kui root'una panen firefoxi käima siis on kõik okey, utf-8'ga näib kõik ilus ja tore ja isegi antialiasing töötab siis.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group