Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
Meelis
Pingviini aktivist
Pingviini aktivist



Liitunud: 23.07.2007
Postitused: 273

Distributsioon: Mint xfce
estonia.gif
postituspostitatud: 23.03.2015, 19:26  postituse pealkiri:  (teema puudub)  

Tere!
Võtsin Võsandi juhendiga id kaardi tarkvara maha. Tegin uue installi aga ikka on endine tarkvara.
Skripti 4 esimest rida on:
#!/bin/bash

# Ubuntu

OPSYS=trusti

REPO_FILE=/etc/apt/sources.list.d/ria-repository.list

apt-cache show qesteidutil annab:
Package: qesteidutil
Priority: extra
Section: utils
Installed-Size: 1831
Maintainer: ria <info@ria.ee>
Architecture: i386
Version: 3.8.0.1106-99koodur3
Replaces: smartcardpp
Depends: pcscd (>= 1.5), fonts-liberation, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libpcsclite1 (>= 1.3.0), libqt5core5a (>= 5.2.0), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5network5 (>= 5.0.2), libqt5widgets5 (>= 5.0.2), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.6)
Breaks: smartcardpp
Filename: dists/trusty/main/binary-i386/qesteidutil_3.8.0.1106-99koodur3_i386.deb
Size: 612896
MD5sum: 5c578e2d83192087717be61243b19daf
SHA1: 22a96ac26f2f6b546eb3e343793a6d685de06e43
SHA256: 57bc0c3cda194ee5011af24155e31b682e4bdf34ff9ddf73cae05ca7277801a7
SHA512: 9b0c61329785dc75a8dc565d9367829628da3719d353524877b72b39080879f76a978e260e2ab5e1a87450abc0e28e7250759ab575306256f4a948c31a8d761a
Description: Smart card manager UI application
UI application for managing smart card PIN/PUK codes and certificates
Description-md5: 24e172b94163a9a046ea357c1a8f5d29
Homepage: http://www.ria.ee

Package: qesteidutil
Priority: optional
Section: universe/utils
Installed-Size: 728
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Guido Tabbernuk <boamaod@gmail.com>, Martin-Éric Racine <martin-eric.racine@iki.fi>
Architecture: i386
Version: 0.3.1-0ubuntu2
Depends: fonts-liberation | ttf-liberation, opensc, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libp11-2 (>= 0.2.Cool, libqt4-network (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.5.3), libqtwebkit4 (>= 2.2~2011week36), libsmartcardpp1, libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.2.1)
Filename: pool/universe/q/qesteidutil/qesteidutil_0.3.1-0ubuntu2_i386.deb
Size: 325552
MD5sum: bbc7aaafc89205097ff68021d7d5cfb7
SHA1: 558242401e07ec19d67d2f62b3884d5d9cb96340
SHA256: 9eb8225395651c75b154d103aed6b186624c687e267cae6e3f73abd8f997f2f0
Description-en: Estonian ID card management utility
QEsteidUtil is a user-friendly application for managing Estonian ID Cards.
It can be used to change and unlock PIN codes, examine the personal
information stored on the card, extract and view the certificates, set
up mobile ID and configure a personal @eesti.ee e-mail address.
Description-md5: 1ffef1d99e43947e360291eefabb6829
Homepage: http://code.google.com/p/esteid/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Ei mäleta kuidas on teegid või täägid et tekst kasti sisse panna? Ehk annate teada, et saan teksti korrastada!?


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 23.03.2015, 20:36  postituse pealkiri:  (teema puudub)  

Meelis kirjutas:

Skripti 4 esimest rida on:
#!/bin/bash

# Ubuntu

OPSYS=trusti


Siia on sattunud näpukas. Peaks olema

OPSYS=trusty

Kas sellisena skripti käivitades tõesti mingit veateadet ei andnud Smile


sadiini
Vana Pingviin
Vana Pingviin


Vanus: 48
Liitunud: 28.12.2007
Postitused: 1433
Asukoht: Otsige mind kolmandalt planeedilt...
Distributsioon: LXLE, Mint
estonia.gif
postituspostitatud: 23.03.2015, 20:38  postituse pealkiri:  (teema puudub)  

Meelis kirjutas:

OPSYS=trusti


trusty

_________________
Hea tarkvara kuulab kasutaja sõna Smile

natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 24.03.2015, 07:17  postituse pealkiri:  (teema puudub)  

natsa kirjutas:
Muuda Linux Mindi jaoks install-esteid-ubuntu.sh kolmandat rida:

Kood:
OPSYS=trusti


Salvesta ja lase käima.


Embarassed Embarassed

_________________
Kõige parem asi on töötav asi.

Meelis
Pingviini aktivist
Pingviini aktivist



Liitunud: 23.07.2007
Postitused: 273

Distributsioon: Mint xfce
estonia.gif
postituspostitatud: 25.03.2015, 19:22  postituse pealkiri:  (teema puudub)  

Tänan kõiki aitajaid! Sain korda.
Kõigepealt võtsin vana tarkvara maha Synaptikust, siis veel Võsandi käskudega - nendega võttis veel kraami maha. Siis kirjutasin paigaldusskripti trusty. Installisin ja tuli id kaardi tarkvara uus versioon. Sain ka Firefoxiga panka sisse.


w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 11:31  postituse pealkiri:  (teema puudub)  

Tere küsimus,niisugune ,et laadisin alla ID.ee lehelt paigaldus skripti kuid kuidas navigeerida terminalis sellese kausta kus skript on..Muidugi võib lisada kirjelduse kuidas ID kaardi tarkvara synaptic package manager-is installida.Tänan. PS.Tegemist ubuntu 14.02 LTS versiooniga..


natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 02.05.2015, 13:13  postituse pealkiri:  (teema puudub)  

w500 kirjutas:
Tere küsimus,niisugune ,et laadisin alla ID.ee lehelt paigaldus skripti kuid kuidas navigeerida terminalis sellese kausta kus skript on..Muidugi võib lisada kirjelduse kuidas ID kaardi tarkvara synaptic package manager-is installida.Tänan. PS.Tegemist ubuntu 14.02 LTS versiooniga..


Kood:
cd ~/kataloog_kus_skript_on

_________________
Kõige parem asi on töötav asi.

w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 14:43  postituse pealkiri:  (teema puudub)  

Proovisin cd ~/downloads aga ütleb no such file or directory.Fail ise asub downloads-kataloog kaustas.urmas@urmas-Vostro-270s:~$ cd ~/downloads
bash: cd: /home/urmas/downloads: No such file or directory
urmas@urmas-Vostro-270s:~$


argo
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 17.04.2014
Postitused: 73
Asukoht: Eesti
Distributsioon: Linux Mint 19
estonia.gif
postituspostitatud: 02.05.2015, 15:50  postituse pealkiri:  (teema puudub)  

cd ~/download/scripti_nimi ?

_________________
phpBB Estonia - Foorumitarkvara phpBB ametlik Eesti foorum

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2566
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 02.05.2015, 16:04  postituse pealkiri:  (teema puudub)  

Katalooogide ja failide nimed on tõstutundlikud.
Tõenäoliselt on kataloogi nimi Downloads mitte downloads
Ehk kasutada käsku: cd ~/Downloads

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 17:12  postituse pealkiri:  (teema puudub)  

Ch




Viimati muutis w500 02.05.2015, 20:34; muudetud 1 kord
natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 02.05.2015, 17:59  postituse pealkiri:  (teema puudub)  

Tarkvaraga manipuleerimiseks pead iga käsu ette lisama 'sudo', st antud juhul

Kood:
sudo sh install-esteid-ubuntu.sh
sudo apt-get install -f


jne.

_________________
Kõige parem asi on töötav asi.

w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 18:27  postituse pealkiri:  (teema puudub)  

Ütleb nii.An error occurred,please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong.The error message was:'Error:BrokenCount >0'.This usually means that your installed packages have unmet dependencies. Mida edasi teha.




Viimati muutis w500 02.05.2015, 18:49; muudetud 1 kord
imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2566
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 02.05.2015, 18:47  postituse pealkiri:  (teema puudub)  

Kui on "mingi error", siis soovitaks selgeltnägijate poole pöörduda.
Kõrvaldamiseks soovitan torusiili või piparmündi lahust.
</sarcasm>

Kui sa saad vea, siis postita see siia mitte ära kirjuta "mingi error" - meil pole õrna aimugi mida see tähendab.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 18:59  postituse pealkiri:  (teema puudub)  

urmas@urmas-Vostro-270s:~$ cd ~/Downloads
urma




Viimati muutis w500 02.05.2015, 20:35; muudetud 1 kord
imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2566
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 02.05.2015, 19:20  postituse pealkiri:  (teema puudub)  

Try 'apt-get -f install' with no packages
Ehk anna käsk: sudo apt-get -f install

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

w500
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 02.03.2013
Postitused: 48
Asukoht: Tallinn
Distributsioon: ubuntu 18.04
estonia.gif
postituspostitatud: 02.05.2015, 19:48  postituse pealkiri:  (teema puudub)  

ur




Viimati muutis w500 02.05.2015, 20:36; muudetud 1 kord
natsa
Vana Pingviin
Vana Pingviin


Vanus: 74
Liitunud: 25.03.2009
Postitused: 537
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 02.05.2015, 20:06  postituse pealkiri:  (teema puudub)  

Hakkame algusest peale:

Kood:
sudo rm /etc/apt/sources.list.d/ria-repository.list

järgmine käsk:

Kood:
sudo apt-get purge esteidcerts esteidcerts-dev esteidcerts-fin \
    esteidfirefoxplugin esteidpkcs11loader \
    libdigidoc-common libdigidocpp-common \
    qesteidutil qdigidoc opensc

kui käsuviip on jälle ees, mine

Kood:
cd ~/kataloog_kus_on install-esteid-ubuntu.sh


siis käsk:

Kood:
sudo sh install-esteid-ubuntu.sh

Pärast seda peaks asi korras olema.

Käsud sisesta ükshaaval.

Järgmine käsk antakse, kui eelmine on täidetud.

P. S. Sama teema on siinsamas natuke eespool! Wink

_________________
Kõige parem asi on töötav asi.



Viimati muutis natsa 02.03.2016, 08:00; muudetud 1 kord
Dead-Milkman
Uus kasutaja
Uus kasutaja



Liitunud: 24.09.2015
Postitused: 2


estonia.gif
postituspostitatud: 24.09.2015, 13:33  postituse pealkiri:  (teema puudub)  

Tere!

Olen talitanud id.ee lehe ja siinse foorumi info põhjal ning Terminal tahab minuga vaidlema hakata teemal: You run this script as root. DO NOT RUN RANDOM SCRIPTS AS ROOT. Ma saan aru tema moraalist aga ikkagi oleks vaja ju jooksutada, kuidas vastu vaielda terminaline?

Aitäh!


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2566
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 24.09.2015, 15:16  postituse pealkiri:  (teema puudub)  

sudo kasuta mitte root kasutajana.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group