Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
aethralis
Pingviini aktivist
Pingviini aktivist



Liitunud: 21.10.2007
Postitused: 160

Distributsioon: Ubuntu 20.04
blank.gif
postituspostitatud: 27.05.2020, 14:27  postituse pealkiri:  (teema puudub)  

Mul õnnetsus ametliku skriptiga installimine Ubuntu 20.04 peal ilusasti, aga mingil põhjusel annab digiallkirjastamisel veateate:

Kood:

Ümbriku allkirjastamine ebaõnnestus

ASiC_E.cpp:347 Failed to sign container.
SignatureXAdES_LT.cpp:227 Could not find certificate issuer 'CN=ESTEID-SK 2015,organizationIdentifier=NTREE-10747013,O=AS Sertifitseerimiskeskus,C=EE' in certificate store.


Teise masina peal (kus on ikka veel 18.04) õnnestus sama faili allkirjastamine probleemideta.


ertserts
Vana Pingviin
Vana Pingviin



Liitunud: 31.10.2013
Postitused: 443
Asukoht: Tallinn
Distributsioon: Ubuntu, Debian
estonia.gif
postituspostitatud: 05.06.2020, 15:26  postituse pealkiri:  (teema puudub)  

Probleem selles et Ubuntu 20.04 LTS pole veel id-kaarditarkvara tuge. Käsurealt skripti käivitades tuleb hoiatus et pole ametlikult toetatud.

Digiallkirjastamisel tekib tõesti veateade:
ASiC_E.cpp:347 Failed to sign container.
SignatureXAdES_LT.cpp:227 Could not find certificate issuer 'CN=ESTEID-SK 2015,organizationIdentifier=NTREE-10747013,O=AS Sertifitseerimiskeskus,C=EE' in certificate store.


Samas kui näiteks installeerida läbi APT või SNAP repo google-chrome siis Ubuntu 20.04 LTS all id-kaart pin1 ja pin2 töötavad SEB keskkonnas. Chromium all id-kaart ei tööta. Firefoxi ma enam ei kasuta sest see oli/on alalõpmata id-kaardi suhtes pipar.

Digiallkirjastamise puhul tuleb veel oodata. Kellel palju digiallkirjastada pole soovitav Ubuntu 20.04 LTS veel üle minna.

_________________
ertserts@linuxialune:~$ echo;echo Local and Remote IP connections:;netstat -at|sort -k5|grep ESTABLISHED|cut -c20-80;echo

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2595
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 05.06.2020, 20:59  postituse pealkiri:  (teema puudub)  

Üks võimalik workaround
https://askubuntu.com/questions/1247161/digital-signing-with-qdigidoc4-estonian-id-card-software-under-ubuntu-20-04/1247162

Aga soovitaks siiski oodata kuniks 20.04 ametlikult toetatuks saab.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

Gomi
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.12.2017
Postitused: 180

Distributsioon: Gentoo, Debian
estonia.gif
postituspostitatud: 07.06.2020, 13:08  postituse pealkiri:  (teema puudub)  

ertserts kirjutas:
Probleem selles et Ubuntu 20.04 LTS pole veel id-kaarditarkvara tuge. Käsurealt skripti käivitades tuleb hoiatus et pole ametlikult toetatud.

Digiallkirjastamisel tekib tõesti veateade:
ASiC_E.cpp:347 Failed to sign container.
SignatureXAdES_LT.cpp:227 Could not find certificate issuer 'CN=ESTEID-SK 2015,organizationIdentifier=NTREE-10747013,O=AS Sertifitseerimiskeskus,C=EE' in certificate store.


Samas kui näiteks installeerida läbi APT või SNAP repo google-chrome siis Ubuntu 20.04 LTS all id-kaart pin1 ja pin2 töötavad SEB keskkonnas. Chromium all id-kaart ei tööta. Firefoxi ma enam ei kasuta sest see oli/on alalõpmata id-kaardi suhtes pipar.

Digiallkirjastamise puhul tuleb veel oodata. Kellel palju digiallkirjastada pole soovitav Ubuntu 20.04 LTS veel üle minna.


Viga paistab olevat selles, et Ubuntu 20.04 kasutab (vähemalt hetkel?) OpenSSL versiooni 1.1.1f. Versioonid enne ja pärast seda, ehk siis kuni 1.1.1e ja alates 1.1.1g, töötavad korrektselt nende sertifikaatidega. Või siis ignoreerivad väikest probleemi, mis nendega on. Juttu on sellest siin:
https://github.com/open-eid/libdigidocpp/issues/341

Ups, Imre link annab täpselt sama info.


643
Pingviini aktivist
Pingviini aktivist



Liitunud: 08.07.2019
Postitused: 161

Distributsioon: debian
blank.gif
postituspostitatud: 08.06.2020, 14:52  postituse pealkiri:  (teema puudub)  

Firefoxi ei saa ühte patta panna openssl-iga.
Ja firefoxis allkirjastamine toimib just chrome rakendusega:
https://github.com/open-eid/chrome-token-signing

_________________
service

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 50
Liitunud: 25.10.2013
Postitused: 255
Asukoht: maal ja merel
Distributsioon: Mint 18.3, KDE Neon 5.20, Linux Lite
estonia.gif
postituspostitatud: 14.10.2020, 11:35  postituse pealkiri:  (teema puudub)  

Umbes nädal tagasi 08.10 tuli välja uuendus, mis JÄLLE töötava asja pekki keeras Evil or Very Mad
Swedi ei saa enam üldse sisse (aga läbi swedi pangalingi kuhugi mujale sisse logida saab) mujale saab pin1 kaudu sisse küll (eesti.ee, elisa, tele2 jne) aga digiallkirja anda ei saa.
Arvutis digidoc4-s jällegi saab dokumentidele digiallkirja panna.
Ma ei saa aru, kas olen ma ainuke maailmas, kes seda veel ID kaarti kasutab ja kellel selline jama on Evil or Very Mad
Kuidas saaks kasutada eelmist ja töötavat versiooni, sest uuesti installides lastakse peale kõige uuem versioon ??


643
Pingviini aktivist
Pingviini aktivist



Liitunud: 08.07.2019
Postitused: 161

Distributsioon: debian
blank.gif
postituspostitatud: 14.10.2020, 13:00  postituse pealkiri:  (teema puudub)  

Konsumis on müügil usb ja juhtmega ID-kaardilugeja ja see töötab. Pealegi ID-kaarti läheb vähe vaja kui smart-id on olemas.

Ja ma olen hakanud kasutama chromiumi veebis id ja pin1 ja pin2 andmiseks. Ja samuti smart-id jaoks.

_________________
service

tonks
Pingviini aktivist
Pingviini aktivist



Liitunud: 01.12.2016
Postitused: 108
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 14.10.2020, 14:20  postituse pealkiri:  (teema puudub)  

Väline kaardilugeja, ei ole probleemi. Toimetab Vivaldiga kenasti ja isegi FF-81.0 ei tõrkunud Swedis allkirjastamisel. Mul küll 18.04LTS kloon.


v6lur
Vana Pingviin
Vana Pingviin


Vanus: 32
Liitunud: 08.07.2005
Postitused: 659
Asukoht: Tartu
Distributsioon: Arch
blank.gif
postituspostitatud: 14.10.2020, 17:16  postituse pealkiri:  (teema puudub)  

tonks kirjutas:
Väline kaardilugeja, ei ole probleemi. Toimetab Vivaldiga kenasti ja isegi FF-81.0 ei tõrkunud Swedis allkirjastamisel. Mul küll 18.04LTS kloon.
Ja töötabki Vivaldis Shocked Kui mul suvel millalgi ID-kaarti vaja oli (sest Smart-ID ei sobinud mingis kohas), ei õnnestunud kuidagi Vivaldit kaarti tuvastama saada. Nüüd paigaldasin uuesti AUR-ist "esteid" asjad ja töötabki kenasti Archi all ka.

_________________
"Sleep, she is for the weak."

tonks
Pingviini aktivist
Pingviini aktivist



Liitunud: 01.12.2016
Postitused: 108
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 14.10.2020, 21:24  postituse pealkiri:  (teema puudub)  

Ma olengi viimasel ajal Vivaldit kaardiga kasutanud, pole nagu senini probleeme olnud. Teine, mida küll olen vähem kasutanud, aga ka probleemideta on töötanud, on Brave Web Browser. Opera pidavat ka kaardiga töötama, aga mina seda tööle ei saanud, võib olla, et Windowsis siis ainult.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 50
Liitunud: 25.10.2013
Postitused: 255
Asukoht: maal ja merel
Distributsioon: Mint 18.3, KDE Neon 5.20, Linux Lite
estonia.gif
postituspostitatud: 15.10.2020, 11:01  postituse pealkiri:  (teema puudub)  

Mul 20.04LTS "kloon" KDE Neon
Ei viitsinud enam selle id asjaga jamada ja tegin Windoozaga arvutis omale smart id ära.
Ju ma nii "ainulaadne" olen, et ainult minul see kaardi värgindus enam ei tööta.
Lauaarvutil taastasinn Timeshifter-iga süsteemi vanema oleku ja kustutasin "muude tarkvara allikate" alt ria repo ära, et enam ei uuendaks


643
Pingviini aktivist
Pingviini aktivist



Liitunud: 08.07.2019
Postitused: 161

Distributsioon: debian
blank.gif
postituspostitatud: 16.10.2020, 12:09  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Mul 20.04LTS "kloon" KDE Neon
Ei viitsinud enam selle id asjaga jamada ja tegin Windoozaga arvutis omale smart id ära.
Ju ma nii "ainulaadne" olen, et ainult minul see kaardi värgindus enam ei tööta.
Lauaarvutil taastasinn Timeshifter-iga süsteemi vanema oleku ja kustutasin "muude tarkvara allikate" alt ria repo ära, et enam ei uuendaks


Kui sul ennem töötas, siis on mingi seadistusfail vigane. Äkki oleksid proovinud chromium brauseriga.
Mul ühel acer seashell 64bit arvutil enam peale firefoxi uuendust brauser üldse tööle ei läinud.
Panin chromiumi peale ja ka pin1 ja pin2 töötas.
Põhiline, et masin muidugi linuxis id-kaardi ära tunneb. Käsuga saad kontrollida, mis kernel näitab.

Proovida ju võid.

_________________
service

hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 50
Liitunud: 25.10.2013
Postitused: 255
Asukoht: maal ja merel
Distributsioon: Mint 18.3, KDE Neon 5.20, Linux Lite
estonia.gif
postituspostitatud: 19.10.2020, 18:30  postituse pealkiri:  (teema puudub)  

Sain sealt suht asjaliku vastuse, suunasid mu testimise lehtedele ja tahtsid saada logifaile.
Täna aga sain sellise vastuse:
Tsitaat:
Tere

Täname Teid tagasiside eest.

Saadud info põhjal saab järeldada, et tegemist on Linux raamistiku ehk QT veaga, kus 5.15.0 versioon ei ole ühdiluv ID-kaardi tarkvaraga https://github.com/open-eid/chrome-token-signing/issues/168

Siinkohal oleks soovitatav kasutada operatsioonisüsteemi, mis ei põhine KDE töölauaga https://www.id.ee/artikkel/id-tarkvara-toetatud-operatsioonisusteemid/

Juhul, kui antud teemal tekivad lisaküsimused/mured, siis palume otse ID-tarkvara arendajale need suunata ehk aadressile help@ria.ee


acrux
Pingviini külastaja
Pingviini külastaja


Vanus: 58
Liitunud: 15.03.2010
Postitused: 32
Asukoht: Tallinn
Distributsioon: Mageia
estonia.gif
postituspostitatud: 23.10.2020, 07:04  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Mul 20.04LTS "kloon" KDE Neon

Kahjuks mitte päris kloon Smile
Neon uuendas oma Qt 5.15.0 peale, aga see tegi ID kaardiga allkirjastamise katki. Qt 5.15.1 uuendus parandas küll kohe asja ära, aga paraku Neon-i arendajatel/pakendajatel pole selle uuendusega kiiret. Üritasin küll selletemalise foorumipostitusega asjale tähelepanu tõmmata, aga seni edutult. Seal on ka link Qt puugile.
Nii et kui tahta toimivat asja, siis ikkagi ametlikult toetatav asi (Ubuntu) või siis distro, kus on "oma mees Havannas" ehk otseühendus pakendamisega (Mageia) Very Happy
See RIA vastus on natuke koomiline, sest ID kaardi soft ise põhineb Qt-l ning siis hakata soovitama töölauda, mis sellel ei põhine... Very Happy


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 50
Liitunud: 25.10.2013
Postitused: 255
Asukoht: maal ja merel
Distributsioon: Mint 18.3, KDE Neon 5.20, Linux Lite
estonia.gif
postituspostitatud: 23.10.2020, 14:17  postituse pealkiri:  (teema puudub)  

Su postitused seal jäänud jah "hüüdja hääleks kõrbes" Smile
RIA vastuse peale tahtsin esialgu neilt küsida, et kas nad kavatsevad igavesti oma QT versiooni peale jääda ja mis siis saab kui "päris" ubuntu ka selle uuema versiooni kasutusele võtab...
aga lihtsalt ei viitsinud neile enam kirjutada Very Happy




Viimati muutis hirax 23.10.2020, 19:15; muudetud 1 kord
imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2595
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 23.10.2020, 17:17  postituse pealkiri:  (teema puudub)  

Huvi pärast vaatasin libdigidocpp sõltuvuste vajadusi. Seal on sõltuvuseks näiteks xsd mille viimane reliis on 6a tagasi tehtud. IT valdkonnas on see ürgaegne asi Smile

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group