Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
acrux
Pingviini külastaja
Pingviini külastaja


Vanus: 57
Liitunud: 15.03.2010
Postitused: 31
Asukoht: Tallinn
Distributsioon: Mageia
estonia.gif
postituspostitatud: 26.01.2019, 14:29  postituse pealkiri:  (teema puudub)  

morb kirjutas:
Mageia 6 töötab allkirjastamine vaid vanade kaartidega. Uusi kaarte ei tunne ära.


Jep, awp'd Mageias veel pole. Ei 6's ega Cauldronis.


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2564
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 26.01.2019, 17:38  postituse pealkiri:  (teema puudub)  

Debiani kasutajatele ehk abiks selline dokument:
https://blog.getreu.net/_downloads/digidoc-open-eid--debian9.pdf

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

123to
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.05.2014
Postitused: 119

Distributsioon: Xubuntu 18.04 i386, x64
estonia.gif
postituspostitatud: 27.01.2019, 11:15  postituse pealkiri:  (teema puudub)  

imre kirjutas:
Debiani kasutajatele ehk abiks selline dokument:
https://blog.getreu.net/_downloads/digidoc-open-eid--debian9.pdf


väga hea ja üksikasjalik dokument, isegi kõik librade versioonid kirjas mis hetkel töötavad


janat

Pingviini kasutaja
Pingviini kasutaja



Liitunud: 25.11.2018
Postitused: 40

Distributsioon: bunsenlabs
blank.gif
postituspostitatud: 29.01.2019, 07:54  postituse pealkiri:  (teema puudub)  

Kas lubuntu live võimaldab ka torami kasutamist? Siis saaks pulgalt rami ja ramilt id kaarti jooksutada?


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 707
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 11.03.2019, 08:48  postituse pealkiri:  (teema puudub)  

Vahetasin eile ühe Ubuntu-16.04 18.04-ks. ID-tarkvara automaatne installeerimine komistas ikka veel awp otsa. OS-installeerimisel valisin 'Desktop', et ehk saan kõige vähema vaevaga pildi ette. ID-tarkvara jäigi google-chrome tuge seadistama, Ctrl-C ka ei aidanud. Järele aidates jõudsin siin kolm kuud tagasi jutuks olnud teateni:

tundmatu kasutaja: mkdir

Eks ma sain ta käima, aga imelik ikka, et RIA toetatud OS-is asjad nii käivad.


Gomi
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.12.2017
Postitused: 164

Distributsioon: Gentoo, Debian
estonia.gif
postituspostitatud: 12.03.2019, 18:41  postituse pealkiri:  (teema puudub)  

Mure põhjus: Idemia install-skriptid. Lähemalt saab lugeda siit.
Ise saab skripti kätte umbes nii:
Kood:
ar p awp_5.3.0.18.04.75_amd64.deb control.tar.gz | tar zxOf - ./postinst > skript.sh

Näiteks selline rida:
Kood:
sudo -i -u $SUDO_USER mkdir -p $HOME/.pki
jääb pisut jänni, kui SUDO_USER defineeritud pole, ja siis juhtubki "unknown user: mkdir" (sest -u argumendiks jääb siis mkdir).
Peale sudo (väär)kasutuse kasutab see skript veel apt install'i, sest pakisõltuvustest ei paista selle skripti autor midagi teadvat.
Loodan tõesti, et RIA seda lihtsalt nii ei jäta.


mckevin
Pingviini aktivist
Pingviini aktivist


Vanus: 30
Liitunud: 02.05.2007
Postitused: 114
Asukoht: tallinn
Distributsioon: Arch Linux x86_64
estonia.gif
postituspostitatud: 13.03.2019, 00:53  postituse pealkiri:  (teema puudub)  

mingit jutud olid et see IDEMIA tugi lisatakse opensc-le aga et mingit infot saada pead need kuskilt saunast kätte saama


Gomi
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.12.2017
Postitused: 164

Distributsioon: Gentoo, Debian
estonia.gif
postituspostitatud: 13.03.2019, 03:03  postituse pealkiri:  (teema puudub)  

OpenSC'sse endasse, ilma selle saadanast-tulnud AWP pakita? Arvestades seda, kui palju Eesti riik on E-riiki panustanud ja hoidnud seda ka vaba tarkvarana loodaks tõesti, et uus kaart sellele piiri ei pane.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 251
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 16.03.2019, 10:15  postituse pealkiri:  (teema puudub)  

Lihtsalt uudishimust proovisin täna paigaldada ID tarkvara Linux Lite 4.2 64bit.
Ja ülla ülla Laughing
Paigaldusskriptis midagi ei muutnud ja see ei hädaldanudki, et see OS pole toetatud.
Samamoodi ei virisenud enam awp paketi pärast.
Ühesõnaga paigaldus ilma veateateid andmata.
Kontrollisin hetkel ainult chromega (ver.73.0.3683.75) eesti.ee lehel sisselogimine ok ja swedis sai ka ülekande tehtud.
Nii et positiivsed arengud on - teine teema on see awp värk, kinnine kood ikkagi....
Mitte et ma ise seal midagi lugeda oskaks, aga siiski Smile


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2564
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 16.03.2019, 14:33  postituse pealkiri:  (teema puudub)  

Jah, ega peagi hädaldama kuna paigaldusscript tuvastab, et OS on Ubuntu bionic.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

tonks
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.12.2016
Postitused: 99
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 16.03.2019, 15:33  postituse pealkiri:  (teema puudub)  

Ka mõned korrad meelelahutusega tegeletud. Linux Mint 19.1. Esimesel korral jäi pidama peale Error: Failed to delete module opensc-pkcs11. Teisel katsel tuli sama teade, aga tänas kaardi kasutamise eest. Samas nii digidok ja tera ikoonid on, aga kaardi haldusvahendi ikooni pole. Torkasin kaardi lugejasse, vilgutas tulukest, sisselogimine ja allkirjastamine töötasid.
Järgmisena Zorin 12.3ultimate, ei uuendanud kohe 12.4 peale, sellest tuli ka kummaline probleem, millele kohe pihta ei saanud ja esimene katse luhtus. Sudo apt-get updatega kordus sama jama, siis jõudis pärale, et ühe arhiivi veebiaadress tuli uuendamishaldurist ära kustutada. Enne seda üritasin käsitsi pakke paigaldada, awp andis muidugi selle mdirri. Pärast selle aadressi kustutamist läks skriptiga kõik ludinal paika, sisselogimine ja allkirjastamine töötasid, kõik ikoonid olemas.
Edasi avastasin kettalt Black Lab Linuxi, kubuntulane vist, sellele läks esimese korraga paika, aga jälle haldusvahendi ikooni ei ole. Kaart lugejasse, tuld ei vilgutanud, avasin digidoki, näitas kaart lugejas, sisse logis, allkirjastada midagi polnud.
Black Labil skriptis midagi ei muutnud, Zorinil vanast harjumusest muutsin, nii et ei tea, kas ilma oleks paigaldatud, varem ei saanud.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 25.10.2013
Postitused: 251
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE, Kubuntu18.04, Linux Lite
estonia.gif
postituspostitatud: 16.03.2019, 16:05  postituse pealkiri:  (teema puudub)  

Seda ma ise enne tähele ei pannudki, et pole jah haldusvahendi ikooni kuskil, läbi digidoc4 saab ligi.
Mis käsku peaks haldusvahendi jaoks terminalis kasutama ?


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2564
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 16.03.2019, 17:49  postituse pealkiri:  (teema puudub)  

Haldusvahendit enam ei olegi.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

hunt_1
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.07.2009
Postitused: 306

Distributsioon: Mageia 7.1 mate 64-bit
estonia.gif
postituspostitatud: 27.03.2019, 00:08  postituse pealkiri:  (teema puudub)  

Ei saa aru miks Firefox id kaarti ei leia värskel paigaldusel.
Panin arvutisse mageia 6 ja uuendused.
ID- kaardi 3 versioon ei töötanud ja paigaldasin qdigidoc4, see ka ei tööta.
SEB ja riigi leheküljel ütleb, et kaarti ei leitud.
Samas Firefox leheküljel https://hwcrypto.github.io/hwcrypto.js/sign.html toimib.
Töötab qdigidoc4 programm ja PIN1 saab pilti laadida.
Mis sellel Firefox häda?
Ainuke mida näitab on aegunud firefox pkcs11 loader mis keelatud(miks see üldse paigaldatakse?)
PHP:
<?php KeeleseadedEstonian et_EE.UTF-8

Rakenduse versioon
4.2.0.0 (64 bit)
Operatsioonisüsteem: &quot;Mageia 6&quot;

Teegid:
qesteidutil (3.12.7)
chrome-token-signing (1.0.8)
openssl (1.0.2r)
pcsc-lite (1.8.20)
opensc (0.19.0)
QT (5.9.4)

Argumendidqdigidoc4
Teegi otsing
: /usr/lib64/qt5/plugins;/usr/bin
URLs
:
CONFIG_URLhttps://id.eesti.ee/config.json
TSL_URLhttps://ec.europa.eu/information_society/policy/esignature/trusted-list/tl-mp.xml
SIVA_URLhttps://siva.eesti.ee/V2/validate

TSL signeerimise sertifikaadid:
Jean-Marc Verbergt (Signature)
Maarten Joris Ottoy
Michael Theodoor de Boer

Konfiguratsiooni andmed
:
DATE20181212104811Z
SERIAL
82
URL
https://id.eesti.ee/config.json
VER1

Smart Card teenuse staatus
Töötab
Kaardilugejad
:
OMNIKEY CardMan 1021 00 00 max APDU size 65536
Reader state
PRESENTINUSE
ATR cold 
3BFA1800008031FE45FE654944202F20504B4903
ATR warm 
3BFE1800008031FE45803180664090A4162A00830F9000EF
AID34
6a82 (Not found)
AID359000 (OK)
UPDATER_AID6a82 (Not found)

Veebibrauserid:
chromium-browser (68.0.3440.106)
firefox (60.6.0?>


tonks
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.12.2016
Postitused: 99
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 27.03.2019, 09:40  postituse pealkiri:  (teema puudub)  

Firefoxiga oli vist kolm kaardiga seotud laiendust, mis pidid olemas olema, saan täpsustada veidi hiljem, vähemalt mul brauseris oli, skriptiga paigaldasin. Alles mõned päevad tagasi ühe ubuntulasega eksperimenteerisin. Siis ka algul swedis jamas allkirjastamisel kuni selleni välja, et pani isegi pildi tasku. Aga lõpuks sai tehtud. Aga võid proovida Vivaldit, minul on see kõige paremini, vist üldse ilma probleemideta opereerinud ID-kaardiga, või Chromium.

Täiendan. FF-is skript paigaldas ja olid kohe lubatud, ise midagi ei näppinud.

Firefox PKCS11 loader
IDEMIA PKCS11 loader
Token signing

Vivaldil ainult Token signing.




Viimati muutis tonks 27.03.2019, 12:10; muudetud 1 kord
hunt_1
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.07.2009
Postitused: 306

Distributsioon: Mageia 7.1 mate 64-bit
estonia.gif
postituspostitatud: 27.03.2019, 12:04  postituse pealkiri:  (teema puudub)  

Viskasin käsitsi turvamooduli onepin-opensc-pkcs11.so Firefox.
Nüüd toimib.


ertserts
Vana Pingviin
Vana Pingviin



Liitunud: 31.10.2013
Postitused: 431
Asukoht: Tallinn
Distributsioon: Ubuntu, Debian
estonia.gif
postituspostitatud: 27.03.2019, 21:06  postituse pealkiri:  (teema puudub)  

ID-kaarditarkvaraga on tavaliselt kaks võimalust: töötab ja ei tööta. Nimetatud variandid võivad tekkida random, ajast ja kohast sõltumata. Kui võtta kogemuslikult Ubuntu seisukohast siis on alati id-kaardi puhul stabiilsem Chromium. Firefox on selles suhtes ebastabiilsem. Firefox on kohati nii ebastabiilne et ma lausa pankade puhul viimast mitte kunagi ei kasuta. Ma kasutan oma kunagist lemmik brauserit Firefoxi minimaalselt. Kui mäletate, siis alles hiljuti kräshis Firefox pisteliselt non-stop igal veebisessioonil. Lõpuks soovisin oma vananevat närvikava sellest kõigest säästa ja päästa. Võõrutasin ennast Firefox brauserist ja hakkasin kasutama brausereid mis on stabiilsemad.

Netipankadest kasutan ma id-kaardiga SEB ja siis seda, teate ju küll, kurikuulsat mafioosode expanka DanskeBank. Viimane viskas õnneks "püssi põõsasse" ja lahkub Baltikumi "marjamaalt".

ID-kaardi puhul on veel segadust tekitav see, et jämedas laastus liigub rahva käes ajatempli seisukohast 3-sorti id-kaarte: vanemad, uuemad ja kõige uuemad. Kas teate, et kõige uuem ja ilusam id-kaart on oma "x-ühiku" võrra vanadest id-kaartidest paksem. Uue id-kaardiga võib nii mõnegi brändi süleka sisemine id-kaardiluger keelduda korralikult koostööd tegemast.

Ja kui sul juhtub olema see kõige uuem id-kaart siis lühiromaani "Kevade" seisukohast on see sulle õnnistuseks nagu Kiire'le 1905 aastal see õige magus "Lati Pats". Uusima id-kaardi kasutamine võib tekitada netiteenuste pruukimises bohmelli laadse seisundi.

Näiteks läksin täna kodukale https://ankeet.geenidoonor.ee/ et täita ära oma doonoriankeet. Kes meist ei tahaks teada millesse ta lõpuks sureb. Kodukalt vaatas mulle vastu kaks rahustavat teadet - Serveri hooldustööd ja Teade uue id-kaardi omanikele: "Teie kaardiga ei ole võimalik sisse logida."

Ütle veel et id-kaardiga arvutikasutajal, sõltumata operatsioonisüsteemist pole sellel it-sajandil sündmuste- ja üllatuste rohke netielu. Smile

_________________
ertserts@linuxialune:~$ echo;echo Local and Remote IP connections:;netstat -at|sort -k5|grep ESTABLISHED|cut -c20-80;echo

ats
Pingviini külastaja
Pingviini külastaja


Vanus: 50
Liitunud: 26.01.2007
Postitused: 26
Asukoht: Türi
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 28.03.2019, 10:07  postituse pealkiri:  (teema puudub)  

Pean tõepoolest nentima, et Firefoxil on id-kaardiga mingi kana kitkuda. Chrome (ka Vivaldi ja Chromium) klapivad id-kaardiga palju paremini. Seda, muida, ka win 10 all. Sellepärast on vist mõttekas Firefoxi kõrval teist brauserit pidada id-kaardi tarbeks, kui tulirebasest just lahti ei taha saada.


muidumees1234
Pingviini külastaja
Pingviini külastaja



Liitunud: 06.05.2014
Postitused: 23

Distributsioon: mint 18.1 mate
estonia.gif
postituspostitatud: 29.03.2019, 17:36  postituse pealkiri:  (teema puudub)  

Ma ei tea, windoosas viimasel ajal ikka mitmeid kordi lasknud id tarkvara maha ja peale ja siis uuesti rikub kõikides brauserites midagi miski asi ära. Ühesõnaga isegi autoriseerida isegi ei saa. See algas siis kui uuele id kaardile see uus versioon tuli. Kuigi vana kaart, siis kunagi ei tea ette, kui programm uuesti kooma jookseb. Võibolla ka asi minu arvutis, aga samas ei ole midagi uut ka siia installinud. Vahva oleks mingi smart id variant tavaarvutis, ei pea jamama mingite programmidega.


mait
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 14.12.2012
Postitused: 96
Asukoht: Tartu
Distributsioon: OpenSuse 12.2; 13.2, Leap
estonia.gif
postituspostitatud: 08.04.2019, 21:57  postituse pealkiri:  (teema puudub)  

OpenSUSE 42.3. Tõmbasin git-st ja kompileerisin opensc ja libdigidoc, libdigidocpp ja digidoc4. Vanu ID-kaarte saab kasutada probleemideta, aga äsja saadud uue kaardi kohta ütleb, et:
Kood:
opensc-tool -n
Using reader with a card: Broadcom Corp 5880 [Contacted SmartCard] (0123456789ABCD) 01 00
Unsupported card


Millest alustada?


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group