Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 06.05.2018, 11:36  postituse pealkiri:  CentOS 6.9 + libc.so.6 sõltuvuse rahuldamine ei õnnestu  

Üritan paigaldada Darkice tarkvara rpm pakist kuid see nõuab libc.so.6 sõltuvuse rahuldamist.

Proovinud erinevaid varjante mida googlest leidnud ning tundub, et see libc.so.6 pakett on ise enesest nagu täiesti olemas aga Darkice paigaldus ei õnnestu siiski ja väidab ikka antud paketi puudumist.

Olen ka CentOS ja RPM maailmas täiesti võhik, kasutanud CentOS-i vast miski mõni nädal teatud tarkvara pärast.

Pistan väikese terminaali väljundi siia, et ehk teadjamad oskavad selle põhjal miskit järeldada... loomulikult viskan juurde lisa infot kui seda on vaja ning oskan seda teile pakkuda
Kood:
[root@rdhost Downloads]# rpm -Uvh darkice-1.1-3-omv2015.0.x86_64.rpm
warning: darkice-1.1-3-omv2015.0.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID bf81de15: NOKEY
error: Failed dependencies:
   libc.so.6(GLIBC_2.14)(64bit) is needed by darkice-1.1-3.x86_64
   libc.so.6(GLIBC_2.15)(64bit) is needed by darkice-1.1-3.x86_64
[root@rdhost Downloads]# yum -y install glibc.i686
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.funet.fi
 * epel: mirror.yandex.ru
 * extras: ftp.funet.fi
 * updates: ftp.funet.fi
Package glibc-2.12-1.209.el6_9.2.i686 already installed and latest version
Nothing to do
[root@rdhost Downloads]# rpm -q --whatprovides libc.so.6
glibc-2.12-1.209.el6_9.2.i686
[root@rdhost Downloads]# whereis libc.so.6
libc.so: /lib/libc.so.6 /lib64/libc.so.6 /usr/lib64/libc.so
[root@rdhost Downloads]# ls -l /lib/libc.so.6 /lib64/libc.so.6 /usr/lib64/libc.so
lrwxrwxrwx 1 root root  12 May  5 23:15 /lib64/libc.so.6 -> libc-2.12.so
lrwxrwxrwx 1 root root  12 May  6 11:05 /lib/libc.so.6 -> libc-2.12.so
-rw-r--r-- 1 root root 253 Jun 20  2017 /usr/lib64/libc.so


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2494
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 06.05.2018, 11:55  postituse pealkiri:  (teema puudub)  

Miks sa just glibc.i686 üritad paigaldada?
yum install -y glibc võiks aidata.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 06.05.2018, 12:13  postituse pealkiri:  (teema puudub)  

Kusagil lugesin, et kui on 64bit süsteem mis ka minul on siis võiks proovida esmalt paigaldada selle. Muidugi minu keele oskus jätab ka kõvasti soovida Razz

Sinu pakutud varjandiga ütleb ka sama moodi, et on paigaldatud ja värskeim versioon.

Kood:
yum install -y glibc
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.funet.fi
 * epel: ftp.acc.umu.se
 * extras: ftp.funet.fi
 * updates: ftp.funet.fi
Package glibc-2.12-1.209.el6_9.2.x86_64 already installed and latest version
Nothing to do


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2494
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 06.05.2018, 12:54  postituse pealkiri:  (teema puudub)  

glibc versioon ei ole toetatud. Sul on 2.12, aga vaja läheb 2.14 võ 2.15
EDIT:
Ära püüa uuemat glibc peale ajada. Võid oma süsteemi päris metsa keerata.
Upgrade 6 -> 7 peale ei ole ka toetatud. Loe siit
Võimalik, et käsitsi kompileerides saad selle ka vanema glic-ga käima.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.



Viimati muutis imre 06.05.2018, 13:39; muudetud 1 kord
-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 06.05.2018, 13:37  postituse pealkiri:  (teema puudub)  

Miks see kõik nii keeruline peab olema Confused

Üritasin siis nüüd paigaldada selle õpetuse järgi uuemat versiooni https://wiki.mikejung.biz/How_to_install_Glibc-2.15_on_CentOS6

...ja tulemuseks ikka nagu alati ei midagi Crying or Very sad miskit on taas kusagil mäda

Mu toimetamiste tulemus. Algab see lõpu osast kui sai sisestatud käsk "sudo make install" ennem seda on pikk jorus kompileerimist ja paigaldamsit

Kood:

....all/glibc-2.15/build/libidn/stubs /root/glibc_install/glibc-2.15/build/nptl_db/stubs /root/glibc_install/glibc-2.15/build/inet/stubs /root/glibc_install/glibc-2.15/build/hesiod/stubs /root/glibc_install/glibc-2.15/build/sunrpc/stubs /root/glibc_install/glibc-2.15/build/nis/stubs /root/glibc_install/glibc-2.15/build/nscd/stubs /root/glibc_install/glibc-2.15/build/streams/stubs /root/glibc_install/glibc-2.15/build/login/stubs /root/glibc_install/glibc-2.15/build/elf/stubs) > /root/glibc_install/glibc-2.15/build/stubs.h
if test -r /opt/glibc-2.15/include/gnu/stubs-64.h && cmp -s /root/glibc_install/glibc-2.15/build/stubs.h /opt/glibc-2.15/include/gnu/stubs-64.h; \
   then echo 'stubs.h unchanged'; \
   else /usr/bin/install -c -m 644 /root/glibc_install/glibc-2.15/build/stubs.h /opt/glibc-2.15/include/gnu/stubs-64.h; fi
rm -f /root/glibc_install/glibc-2.15/build/stubs.h
/root/glibc_install/glibc-2.15/build/elf/sln /root/glibc_install/glibc-2.15/build/elf/symlink.list
rm -f /root/glibc_install/glibc-2.15/build/elf/symlink.list
test ! -x /root/glibc_install/glibc-2.15/build/elf/ldconfig || LC_ALL=C LANGUAGE=C \
     /root/glibc_install/glibc-2.15/build/elf/ldconfig  \
                   /opt/glibc-2.15/lib /opt/glibc-2.15/lib
/root/glibc_install/glibc-2.15/build/elf/ldconfig: Can't open configuration file /opt/glibc-2.15/etc/ld.so.conf: No such file or directory
make[1]: Leaving directory `/root/glibc_install/glibc-2.15'
[root@rdhost build]# export LD_LIBRARY_PATH=/opt/glibc-2.15/lib
[root@rdhost build]# cd /home/rd/Downloads/
[root@rdhost Downloads]# rpm -Uvh darkice-1.1-3.2.x86_64.rpm
Segmentation fault (core dumped)


Vist on lihtsam teha puhas paigaldus kuna ennem siia pöördumist proovisin ja paigaldasin ka muid erinevaid lisasid mis osad õnnestusid kuidagi ja osa mitte. Vahepeal olid ka CentOS 7 repod kasutuses ja segadust oli kui palju. Sai need piak guugeldamise järgi õnneks eemaldatud.

Hetkel arvan ise, et teeks uue puhat paigalduse ja siis proovisk uuesti kõik vajaliku paigaldada nii nagu siiani olen saanud vajaliku korralikult paigaldatud.
Ennem veel küsin, et kas praegu siia postitatud probleemi kõrvaldamine on väga keerukas ja aega nõudev?


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2494
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 06.05.2018, 13:40  postituse pealkiri:  (teema puudub)  

MIksitud repod on paha mõte. Tundub, et oled jõudnud juba midagi metsa keerata.
Võta parem Centos 7 ja paigalda see parem kui sul seal midagi olulist ei ole.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 06.05.2018, 15:45  postituse pealkiri:  (teema puudub)  

Uhh-ohh ..nokk kinni saba lahti jne jne jne...mõtetu pask tõesti. Ma ei mõista miks ei panda vajalike lisasid kaas kui soov mingi tarkvara paigaldada.
Hakkan ühte puudu olevat sõltuvust paigaldama siis kukub tututama, et veel msikit puudu ja veel rohkem...täiesti surnud ring ...ei jõua neid nii ühekaupa paigaldada.

Paigaldasin nüüd CentOS 7 ja selle õnnestus paigaldada Darkice problemideta koheselt rpm pakist mis ei õnnestunud CentOS 6-es

Nüüd on probleem paigaldada Jack Connection Kit + qjackctl ja lisaks sellele ei saa veel paigaldatud icecast serevrit

taas miljon asja mis on puudu ja vaja paigaldada. Vähemasti CentOS 6 ei olnud probleeme nende paigalduses.

Proovin veel korra paigaldada CentOS 7 DVD pealt. Hetkel oli paigaldatud minimal server instalation.


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2494
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 06.05.2018, 16:26  postituse pealkiri:  (teema puudub)  

Kui oled graafilise keskkonna püsti saanud, siis ehk piisab nendest:
Kood:
yum install jack-audio-connection-kit icecast -y
wget http://dl.fedoraproject.org/pub/epel/6/x86_64/Packages/q/qjackctl-0.3.6-1.el6.x86_64.rpm
yum localinstall qjackctl-0.3.6-1.el6.x86_64.rpm


Minimaalse graafilise (Gnome) keskkonna saad selliselt:
Kood:
yum groupinstall "X Window System"
yum install gnome-classic-session gnome-terminal nautilus-open-terminal control-center liberation-mono-fonts

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 06.05.2018, 20:33  postituse pealkiri:  (teema puudub)  

Very Happy tänud linkide eest. Hetkeks on seis selline, et kõik vajaliku olen saanud paigaldatud (qjackctl, Darkice, Icecast).

Nüüd ei saa jagu kuidagi jack serveriga. Nimelt kui üritan lasta käima qjackctl ehk vajutan Start nuppu siis logis näitab, et ei saa ühendust Jack serveriga

LOGI
Kood:
20:27:41.818 Patchbay deactivated.
20:27:41.819 Statistics reset.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
20:27:41.829 ALSA connection graph change.
20:27:42.026 ALSA connection change.
20:27:43.250 Startup script...
20:27:43.251 artsshell -q terminate
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
sh: artsshell: command not found
20:27:43.655 Startup script terminated with exit status=32512.
20:27:43.655 JACK is starting...
20:27:43.655 /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2
20:27:43.658 JACK was started with PID=2949.
jackdmp 1.9.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
ATTENTION: The playback device "hw:0" is already in use. Please stop the application using it and run JACK again
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
20:27:43.994 JACK was stopped with exit status=255.
20:27:43.994 Post-shutdown script...
20:27:43.994 killall jackd
jackd(2674): Operation not permitted
jackd: no process found
20:27:44.408 Post-shutdown script terminated with exit status=256.
20:27:45.837 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
20:27:55.456 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started


Terminalis käsule jackd -r -d alsa -r 44100 ...jutustab ta, et keegi juba kasutab seda hw:0 seadet

Kood:
[rd@musicrocks ~]$ jackd -r -d alsa -r 44100
jackdmp 1.9.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit


ATTENTION: The playback device "hw:0" is already in use. Please stop the application using it and run JACK again
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server


Et kuidas ma leian selle kasutaja või kuidas saada see killitud ning asjandus toimima? See probleem on jäänud viimaseks ning siis juba saaks teha test audio striimi Very Happy

Nüüdseks kasutuses CentOS 7 minimal server install koos XFCE töölauaga

Kui peaks olema abi
Kood:
[rd@musicrocks ~]$ pulseaudio -v
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 10.0
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is 6c29ef288bf747a3b4766d10745d55dd.
I: [pulseaudio] main.c: Session ID is 1.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/rd/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-10.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
[rd@musicrocks ~]$ pulseaudio -vv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 10.0
D: [pulseaudio] main.c: Compilation host: x86_64-redhat-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1  -m64 -mtune=generic -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 3.10.0-693.21.1.el7.x86_64 #1 SMP Wed Mar 7 19:03:37 UTC 2018
D: [pulseaudio] main.c: Found 2 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 6c29ef288bf747a3b4766d10745d55dd.
I: [pulseaudio] main.c: Session ID is 1.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/rd/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-10.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
 


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2494
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 06.05.2018, 21:42  postituse pealkiri:  (teema puudub)  

root kasutajana: ps auxf
Näitab ära mis asi mingitel portidel töötab.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 42
Liitunud: 25.06.2005
Postitused: 1341
Asukoht: Lappeenranta-Turku
Distributsioon: Debian - CentOS
finland.gif
postituspostitatud: 10.05.2018, 11:07  postituse pealkiri:  (teema puudub)  

Ok sain selle probleemi lõpuks lahendatud, et tegin reinstalli järgmistele jubinatele

jack-audio-connection-kit-dbus
jack2
qjackctl

Ilmselt järgmist allolevat tuleb teha ainult siis kui kasutuses on Rivendell süsteem. Teisi see vist ei mõjuta!?

Avada fail /etc/security/limits.d/99-realtime.conf ja lisada lõppu järgmise read
Kood:
@realtime   -  rtprio     99
@realtime   -  memlock    unlimited


siis luua grupp realtime ning lisada sinna oma kasutajanimi
Kood:
groupadd realtime
usermod -a -G realtime yourUserID


seda eelnevat tuleb teha command lines ja pikema jutu sellest leiab aadressilt: http://jackaudio.org/faq/linux_rt_config.html


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group