Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
mocambo
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 10.06.2007
Postitused: 80

Distributsioon: Arch Linux
estonia.gif
postituspostitatud: 23.11.2017, 17:21  postituse pealkiri:  (teema puudub)  

mckevin kirjutas:
opensc git versiooni pead kasutama


Jep, see töötas. ID-kaart nüüd töötab kõigis brauserites ja DigiDoc's.


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 571
Asukoht: eu
Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 26.11.2017, 09:59  postituse pealkiri:  (teema puudub)  

Ma olen 100% kindel, et uued jamad on tulemas. See tarkvara, mis on seotud andmebaasidega väljaspool iseenda 100%-list tarkvaralist riistvara - on nuhkvara.

Ja kõik, kes ei kasuta nuhkvara on riigivastane!!

_________________
estolinux

123to
Pingviini külastaja
Pingviini külastaja



Liitunud: 31.05.2014
Postitused: 26

Distributsioon: Ubuntu 14.04 i386,x86_64, 17.10 (Vbox)
estonia.gif
postituspostitatud: 27.11.2017, 07:44  postituse pealkiri:  (teema puudub)  

tris kirjutas:
Ma olen 100% kindel, et uued jamad on tulemas. See tarkvara, mis on seotud andmebaasidega väljaspool iseenda 100%-list tarkvaralist riistvara - on nuhkvara.

Ja kõik, kes ei kasuta nuhkvara on riigivastane!!


Eestlase õnn on siis kui üks jama saab kaelast ära ja teine pole veel alanud!


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 571
Asukoht: eu
Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 29.11.2017, 13:22  postituse pealkiri:  (teema puudub)  

123to kirjutas:


Eestlase õnn on siis kui üks jama saab kaelast ära ja teine pole veel
alanud!


meie tulevik:
https://gnusocial.no/notice/2704068

_________________
estolinux

sanderk
Uus kasutaja
Uus kasutaja



Liitunud: 04.12.2017
Postitused: 4


blank.gif
postituspostitatud: 04.12.2017, 17:01  postituse pealkiri:  ID tarkvara Ubuntu 14.04 all  

Tervist.

Tunnen huvi, kas Ubuntu 14.04 (Trusty) all on keegi edukalt ID-kaardi tarkvara käima saadud ja
kui on, siis äkki oleks võimalik paigaldusjuhiseid positada?

installer.id.ee Trusty repos on kõige hilisem ID-kaardi haldustarkvara qesteidutil 3.12.5.1233-1404.
Samas Tšehhi teadlaste avastatud turvaveaga ID-kaardi uuendamiseks on tarvis vähemalt versiooni 3.12.7,
nii et ametlikus Trusty repos on aegunud paketid.

Siin foorumiteemas on see küsimus mitu korda läbi käinud (nt fpost84290.html#84290).

Pakutakse erinevaid lähenemisi (nt Xenial distro pakettide kasutamine või
pakettide lähtekoodist kompileerimine).

Näiteks siin on kasutaja üritanud EID-rakendused lähtekoodist kompileerida:
fpost84285.html#84285
fpost84294.html#84294
Aga postituste lõpus mainib, et ei tööta.

Siin väidetakse, et RIA OpenSC paketi paigaldamisega on brauseris
autentimine ja allkirjastamine (osaliselt?) tööle saadud.
https://pingviin.org/fpost84320.html#84320
https://pingviin.org/fpost84342.html#84342

***

Hea oleks, kui selguks, millist osa on lootust Trusty all tööle saada ja veel parem, kui selguks ka, kuidas seda teha:
1) ID-kaardi sertifikaatide/firmware uuendamine (qesteidutil-ga)
2) Brauseris (Firefox/Chrome) autentimine
3) Brauseris digiallkirjastamine
4) qdigidoc rakendusega digiallkirjastamine


hannes
Pingviini aktivist
Pingviini aktivist


Vanus: 32
Liitunud: 18.06.2009
Postitused: 187
Asukoht: Pärnu
Distributsioon: Debian | Ubuntu
estonia.gif
postituspostitatud: 05.12.2017, 00:39  postituse pealkiri:  (teema puudub)  

Mina soovitan distrot uuendada kas või 16.04 peale ja ilmselt jääb kogu see keberniit olemata.


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 31.03.2007
Postitused: 1004
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 05.12.2017, 00:49  postituse pealkiri:  (teema puudub)  

hannes kirjutas:
Mina soovitan distrot uuendada kas või 16.04 peale ja ilmselt jääb kogu see keberniit olemata.


Soovitan samuti uuendada, juhised leiab siit.


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 571
Asukoht: eu
Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 05.12.2017, 10:09  postituse pealkiri:  (teema puudub)  

Soovitan mitte kasutada ID tarkvara ja isegi mitte anda id kaarti kauplusetöötajale tuvastamiseks nende aparaatides.
Kõik lisakaardid ja tuvastused viivad kõik ühte kohta: identiteedi andmebaasi registrisse!
Sinu kohta on mobiiliträkk, sõrmejälje või gps, id kaardi tuvastused, pangamaksed, rahvusvaheline ja kohalik politseiregister, sinu reisid, lennukireisid, meditsiiniregister, mis tabletti ja kes on su arst: kõigi kohta saab teada, politsei, salapolitsei, minister, valimiste spetsialistid .jne.

Lisaks häkkerid, kes saavad sisse turvaaukude kaudu.
Muretse parem pass ja viska minema isegi kaubanduskeskuste kaardid, sooduskaardid, liikmekaardid .jne

https://www.no2id.net/what-is-the-database-state/

_________________
estolinux

imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2416
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 05.12.2017, 10:45  postituse pealkiri:  (teema puudub)  

tris, lisaks passile soovitaks soojalt foolium mütsi, psühhiaatrit, tugevaid ravimeid.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

123to
Pingviini külastaja
Pingviini külastaja



Liitunud: 31.05.2014
Postitused: 26

Distributsioon: Ubuntu 14.04 i386,x86_64, 17.10 (Vbox)
estonia.gif
postituspostitatud: 05.12.2017, 13:18  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

sanderk kirjutas:
Tervist.

Tunnen huvi, kas Ubuntu 14.04 (Trusty) all on keegi edukalt ID-kaardi tarkvara käima saadud ja
kui on, siis äkki oleks võimalik paigaldusjuhiseid positada?

Siin foorumiteemas on see küsimus mitu korda läbi käinud (nt fpost84290.html#84290).


1) ID-kaardi sertifikaatide/firmware uuendamine (qesteidutil-ga)
2) Brauseris (Firefox/Chrome) autentimine
3) Brauseris digiallkirjastamine
4) qdigidoc rakendusega digiallkirjastamine


Browserid sain tööle:
https://pingviin.org/viewtopic.php?p=84320#84320

aga utiliitide kompilleerimiseks on vaj suur hulk librasid välja vahetada ja ma loobusin, panin oopis vituaalmasinas 17.10 tööle ja toimetan ID-kaartiga seal kui vaja.

16.04-le praegult upgradeda pean mõttetuks kuna kevadel tuleb 18.04
mule ei ole need upgraded kunagi lihtsalt läinud ja mõni rakendus on ikka järeleaitamist tahtnud ja teistpidi jälle mingid vanad librad on segama jäänud, siis juba panen puhtalt 18.04


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 571
Asukoht: eu
Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 05.12.2017, 15:21  postituse pealkiri:  (teema puudub)  

imre kirjutas:
tris, lisaks passile soovitaks soojalt foolium mütsi, psühhiaatrit, tugevaid ravimeid.

foolium müts lubatud, arstid ja retseptiravimid välistatud, sest sisestatakse autom. andmebaasi.

_________________
estolinux

sanderk
Uus kasutaja
Uus kasutaja



Liitunud: 04.12.2017
Postitused: 4


blank.gif
postituspostitatud: 05.12.2017, 17:03  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

zeroconf kirjutas:
hannes kirjutas:
Mina soovitan distrot uuendada kas või 16.04 peale ja ilmselt jääb kogu see keberniit olemata.


Soovitan samuti uuendada, juhised leiab siit.

Aitäh nõuannete eest, samas release upgradet ma ei hakka hetkel uisa-päisa tegema, küll aga võtan arvesse soovituse, et Trusty all ei ole mõtet ID-kaardi utiliidi tarkvara käivitamisega mässata.

Paigaldasin VirtualBox virtuaalmasinas Ubuntu 17.10 koos eid-tarkvaraga (kasutasin install-open-eid.sh skripti). ID-kaardi sertifikaatide/firmware uuendamine läbi ID-kaardi töötas nagu kellavärk. Pärast uuendamist tundis ID-kardi utiliit ID-kaardi ilusti ära ja DigiDoc Client rakendusega töötas ka dokumendi allkirjastamine.

Brauseris käivitamiseks tuli lisaks Firefoxi seadetes Security device laadida: PreferencesPrivacy&SecurityCertificatesSecurityDevicesLoad ⟶ Lisa Path /usr/lib/x86_64-linux-gnu/onepin-opensc-pkcs11.so OK.
Siis töötas allkirjastamine ja autentimine brauseris ka.

123to kirjutas:
sanderk kirjutas:
Tervist.

Tunnen huvi, kas Ubuntu 14.04 (Trusty) all on keegi edukalt ID-kaardi tarkvara käima saadud ja
kui on, siis äkki oleks võimalik paigaldusjuhiseid positada?

Siin foorumiteemas on see küsimus mitu korda läbi käinud (nt fpost84290.html#84290).


1) ID-kaardi sertifikaatide/firmware uuendamine (qesteidutil-ga)
2) Brauseris (Firefox/Chrome) autentimine
3) Brauseris digiallkirjastamine
4) qdigidoc rakendusega digiallkirjastamine


Browserid sain tööle:
https://pingviin.org/viewtopic.php?p=84320#84320

aga utiliitide kompilleerimiseks on vaj suur hulk librasid välja vahetada ja ma loobusin, panin oopis vituaalmasinas 17.10 tööle ja toimetan ID-kaartiga seal kui vaja.

16.04-le praegult upgradeda pean mõttetuks kuna kevadel tuleb 18.04
mule ei ole need upgraded kunagi lihtsalt läinud ja mõni rakendus on ikka järeleaitamist tahtnud ja teistpidi jälle mingid vanad librad on segama jäänud, siis juba panen puhtalt 18.04

Trusty masinas tegin 123to toodud juhendi kohaselt (väikeste muudatustega) ja sain tänu sellele allkirjastamise ja autentimise brauseris tööle.

Aitäh!

Panen siia muutused võrreldes algse postitusega, kuna URL-d on muutunud ja mul oli 64-bitine OS.
Kood:
# wget tõmbab alla 'opensc-pkcs11_0.17.0-1RIA4_amd64.deb' ja 'opensc_0.17.0-1RIA4_amd64.deb'
wget -m -p -E -k -K -A 'RIA4_amd64.deb' -np -nd https://installer.id.ee/media/ubuntu/pool/main/o/opensc/
# Eemalda vanad 'opensc' ja 'opensc-pkcs11' librad (sellega eemaldatakse ka vanad brauseripluginad)
sudo apt-get purge opensc opensc-pkcs11
sudo apt-get autoremove
# Paigalda uued 'opensc' ja 'opensc-pkcs11' librad
sudo dpkg -i opensc-pkcs11_0.17.0-1RIA4_amd64.deb
sudo dpkg -i opensc_0.17.0-1RIA4_amd64.deb
sudo apt install pcscd

# Kaardilugeja ja sertifikaatide kuvamine
pkcs15-tool -c

Käsk pkcs15-tool -c peaks andma kaks sertifikaati: "Isikutuvastus" ja "Allkirjastamine"
mul oli tarvis kaardilugeja korra välja võtta ja siis tagasi ühendada, enne näitas tühjust.

Mul oli /usr/lib/x86_64-linux-gnu/onepin-opensc-pkcs11.so moodul juba lisatud Firefox Preferences Security Devices all. Pärast brauseri restarti ID-kaardiga autentimine töötas.

Allkirjastamise brauseri extensioni kompileerimine käis täpselt sama moodi nagu 123to juhendis, ainult lähtekoodi asukoht oli muutunud:
Kood:
sudo apt install build-essential qt5-default libssl-dev libpcsclite-dev
wget https://installer.id.ee/media/ubuntu/pool/main/c/chrome-token-signing/chrome-token-signing_1.0.6.485.orig.tar.xz
mkdir chrome-token-signing
tar xvfJ chrome-token-signing_1.0.6.485.orig.tar.xz -C chrome-token-signing
cd chrome-token-signing/
make
cd host-linux/
sudo make install

Siis brauseri restart, extension Token Signing 0.0.28 oli lisatud ja allkirjastamine töötas

tris kirjutas:
Soovitan mitte kasutada ID tarkvara ja isegi mitte anda id kaarti kauplusetöötajale tuvastamiseks nende aparaatides.
Kõik lisakaardid ja tuvastused viivad kõik ühte kohta: identiteedi andmebaasi registrisse!
Sinu kohta on mobiiliträkk, sõrmejälje või gps, id kaardi tuvastused, pangamaksed, rahvusvaheline ja kohalik politseiregister, sinu reisid, lennukireisid, meditsiiniregister, mis tabletti ja kes on su arst: kõigi kohta saab teada, politsei, salapolitsei, minister, valimiste spetsialistid .jne.

Lisaks häkkerid, kes saavad sisse turvaaukude kaudu.
Muretse parem pass ja viska minema isegi kaubanduskeskuste kaardid, sooduskaardid, liikmekaardid .jne

https://www.no2id.net/what-is-the-database-state/


Selgelt esitatud ja tugevad argumendid, aga minu arvates liiga idealistlikud. Täielik digitaalse isikutuvastuse kasutamisest loobumine teeb inimese elu väga raskeks. Näiteks internetipanka on tarvis kasutada, et kuu lõpus arved tasuda ning sinna sisenemiseks on vaja autentida.

Samas sellega olen nõus, et kui on võimalik, siis ei tasu oma andmeid välja jagada. Eks see ole rohkem inimese personaalne valik, kui paljust privaatsusest ta mugavuse nimel valmis loobuma on.


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 31.03.2007
Postitused: 1004
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 05.12.2017, 18:15  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

sanderk kirjutas:

Aitäh nõuannete eest, samas release upgradet ma ei hakka hetkel uisa-päisa tegema


See pole küll "uisa-päisa" vaid täpselt kirjutatud ja korduvalt läbi testitud tegevusjuhis.


sanderk
Uus kasutaja
Uus kasutaja



Liitunud: 04.12.2017
Postitused: 4


blank.gif
postituspostitatud: 05.12.2017, 19:19  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

zeroconf kirjutas:
See pole küll "uisa-päisa" vaid täpselt kirjutatud ja korduvalt läbi testitud tegevusjuhis.

Juhend on korralik, ei tahtnud seda kritiseerida.

Sõltuvalt kasutajast võib olla paigaldatud erinevaid rakendusi ja teeke, mistõttu do-release-upgrade peab silmitsi seisma erinevate olukordadega. Vahel läheb upgrade libedalt, aga vahel tuleb välja, et teatud pakette ei saa uuendada - tekivad konfliktid sõltuvuste vahel või on vanade pakettide tugi uuest releasest välja võetud.

Seetõttu tuleb upgrade jaoks sobiv hetk leida. Seda ei saa ülepeakaela tegema tormata ja loota, et pärast kõik toimib - seda mõtlesin "uisa-päisa" all.

(EDIT: järgnev tsitaat oli valele inimesele omistatud, muutsin õigeks)
123to kirjutas:
16.04-le praegult upgradeda pean mõttetuks kuna kevadel tuleb 18.04
mule ei ole need upgraded kunagi lihtsalt läinud ja mõni rakendus on ikka järeleaitamist tahtnud ja teistpidi jälle mingid vanad librad on segama jäänud, siis juba panen puhtalt 18.04

Mulle tundub samuti hetkel selline lähenemine mõistlikum.




Viimati muutis sanderk 05.12.2017, 21:32; muudetud 1 kord
zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 31.03.2007
Postitused: 1004
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 05.12.2017, 19:58  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

sanderk kirjutas:

Sõltuvalt kasutajast võib olla paigaldatud erinevaid rakendusi ja teeke, mistõttu do-release-upgrade peab silmitsi seisma erinevate olukordadega. Vahel läheb upgrade libedalt, aga vahel tuleb välja, et teatud pakette ei saa uuendada - tekivad konfliktid sõltuvuste vahel või on vanade pakettide tugi uuest releasest välja võetud.


Eks siin peab analüüsima - mis on olulisem kas võimalikud konfliktid või ID-kaarditarkvara. Olles ise korduvalt uuendanud siis ei mäleta konflikte. Muidugi mõni rakendus (nt LibreOffice) on tahtnud uuesti paigaldamist ent see on läinud kiirelt (täielik eemaldus + uuestipaigaldus). Kusjuures on ka käsitsi paigaldatud (autonoomsed - paki lahti & kasuta) rakendusi on kasutusel.


sanderk kirjutas:

zeroconf kirjutas:
16.04-le praegult upgradeda pean mõttetuks kuna kevadel tuleb 18.04
mule ei ole need upgraded kunagi lihtsalt läinud ja mõni rakendus on ikka järeleaitamist tahtnud ja teistpidi jälle mingid vanad librad on segama jäänud, siis juba panen puhtalt 18.04

Mulle tundub samuti hetkel selline lähenemine mõistlikum.


See paistab olema kasutaja 123to postitus.

Samas 18.04 muutub küpseks ilmselt 2018 suvel. Sinna aga on palju aega ja seni saaks juba ID-kaarti kasutada.


sanderk
Uus kasutaja
Uus kasutaja



Liitunud: 04.12.2017
Postitused: 4


blank.gif
postituspostitatud: 05.12.2017, 21:49  postituse pealkiri:  Re: ID tarkvara Ubuntu 14.04 all  

zeroconf kirjutas:
See paistab olema kasutaja 123to postitus.

Jah, tõepoolest. Parandasin ära.

zeroconf kirjutas:
Samas 18.04 muutub küpseks ilmselt 2018 suvel. Sinna aga on palju aega ja seni saaks juba ID-kaarti kasutada.


Kasutaja 123to juhiste kohaselt sain brauseris Trusty all autentimise ja digiallkirjastamise tööle, mind see rahuldab, kuna muud funktsionaalsust kasutan harva.
Kui ka on vaja, saan virtuaalmasina käima panna.


hannes
Pingviini aktivist
Pingviini aktivist


Vanus: 32
Liitunud: 18.06.2009
Postitused: 187
Asukoht: Pärnu
Distributsioon: Debian | Ubuntu
estonia.gif
postituspostitatud: 06.12.2017, 10:59  postituse pealkiri:  (teema puudub)  

imre kirjutas:
tris, lisaks passile soovitaks soojalt foolium mütsi, psühhiaatrit, tugevaid ravimeid.


OT: Vooleriga paras paar. Mõlemal on kalduvus hakata teemaväliselt mingit liigset jahu ajama.


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 571
Asukoht: eu
Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 06.12.2017, 14:09  postituse pealkiri:  (teema puudub)  

hannes kirjutas:
imre kirjutas:
tris, lisaks passile soovitaks soojalt foolium mütsi, psühhiaatrit, tugevaid ravimeid.


OT: Vooleriga paras paar. Mõlemal on kalduvus hakata teemaväliselt mingit liigset jahu ajama.


mingi anomaalia vist
http://forte.delfi.ee/news/digi/tu-teadlane-avastas-kevadel-15-id-kaardi-praakeksemplari-ria-teatel-pole-sel-seost-suvelopu-suure-turvariskiga?id=80404816

_________________
estolinux

al(tm)
Pingviini külastaja
Pingviini külastaja


Vanus: 46
Liitunud: 28.03.2017
Postitused: 25
Asukoht: Tartu

estonia.gif
postituspostitatud: 06.12.2017, 17:00  postituse pealkiri:  (teema puudub)  

Samal ajal kuskil mujal.... Wink

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/6ZAMXPQFROMKM7ZX2JDLH3HA46KJY3GJ/

Vt Adam'i viimast kommentaari Wink


123to
Pingviini külastaja
Pingviini külastaja



Liitunud: 31.05.2014
Postitused: 26

Distributsioon: Ubuntu 14.04 i386,x86_64, 17.10 (Vbox)
estonia.gif
postituspostitatud: 06.12.2017, 17:55  postituse pealkiri:  (teema puudub)  

tris kirjutas:


siin rohkem juttu https://tehnika.postimees.ee/4334991/ametid-sulgesid-turvaveaga-id-kaarte-juba-kevadel-kuna-tartu-teadlane-oli-voltsinud-digiallkirja

kas keegi kujutab ette kuidas näeb välja 1 bitine võti millest seal kirjutatakse?

kas 0 või 1?

ja kunagi keegi telekas väitis, et kui esimene võti lahti murtakse siis tuleb kõik serdid tühistada, kas rikuti seadust?


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group