Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
tonks
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.12.2016
Postitused: 35
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 09.09.2017, 18:49  postituse pealkiri:  (teema puudub)  

On keegi mingit viimast ID tarkvara paigaldanud? Mis versiooni numbrit kaardi haldusvahendi akna all servas kuvab? Mul kuvab 3.12.5.1233, sisselogimine ja allkirjastamine toimib, samas pärast paari-kolme nädalast mittekasutamist nüüd avamisel teadustas, et on uuem versioon saadaval. Senini on süsteem automaatselt ise uuendanud, nüüd sundkorras uuendamine ei vii kuhugi, jääb endine. Huvi pärast helistasin infosse, sealt öeldi, et see versioon ei peaks üldse enam töötama. Või on linuxis numbrid teisemad, kui windowsis?


ertserts
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.10.2013
Postitused: 399
Asukoht: Tallinn
Distributsioon: Ubuntu, Debian
estonia.gif
postituspostitatud: 10.09.2017, 12:44  postituse pealkiri:  (teema puudub)  

Minu ühes Ubuntu 16.04 LTS Mate arvutis on versioonideks:
ID-kaardi haldusvahend 3.12.5.1233
DigiDoc3 klient ja DigiDoc krüpto 3.13.1.1495


Kõik töötab tipp-topp. Minu teada uuemat id-kaardi tarkvara versiooni Linuxile pole. Chrome brauseriga töötab id-kaart korralikult. Firefox on id-kaardi puhul selline nii ja naa tegelane. Kord töötab ja siis jälle ei tööta (eriti pin2), ei saa 100% neti toimingutes usaldada.

ID-Kaardi tarkvara installatsiooni puhul kasutan alati automaatset paigaldusskripti. Juhul kui on probleeme siis võiks kas skripti uuesti käivitada või siis vana id-kaardi tarkvara maha võtta ja uuesti installeerida.

_________________
ertserts@linuxialune:~$ echo;echo Local and Remote IP connections:;netstat -at|sort -k5|grep ESTABLISHED|cut -c20-80;echo

natsa
Vana Pingviin
Vana Pingviin


Vanus: 72
Liitunud: 25.03.2009
Postitused: 534
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 10.09.2017, 13:03  postituse pealkiri:  (teema puudub)  

ertserts kirjutas:
Minu ühes Ubuntu 16.04 LTS Mate arvutis on versioonideks:
ID-kaardi haldusvahend 3.12.5.1233
DigiDoc3 klient ja DigiDoc krüpto 3.13.1.1495


... Firefox on id-kaardi puhul selline nii ja naa tegelane. Kord töötab ja siis jälle ei tööta (eriti pin2), ei saa 100% neti toimingutes usaldada...


esteidfirefoxplugin on beta.

_________________
Kõige parem asi on töötav asi.

al(tm)
Uus kasutaja
Uus kasutaja


Vanus: 46
Liitunud: 28.03.2017
Postitused: 6
Asukoht: Tartu

estonia.gif
postituspostitatud: 27.09.2017, 19:45  postituse pealkiri:  (teema puudub)  

Hei,

F26 all on õnnestunud kokku saada selline qesteidutil, mis väidab end olevat 3.12.6.0

ei saa kokku qdigidoc klienti ja F25 oma enam ei tööta ühest hetkest. Kompileerimisel jääb katki-
[ 84%] Building CXX object client/CMakeFiles/qdigidocclient.dir/DigiDoc.cpp.o
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp: In member function ‘QString DigiDocSignature::signedBy() const’:
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp:340:17: error: ‘const class digidoc::Signature’ has no member named ‘signedBy’
return from(s->signedBy());
^~~~~~~~
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp: In member function ‘DigiDocSignature::SignatureStatus DigiDocSignature::validate() const’:
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp:402:37: error: ‘POLv1’ is not a member of ‘digidoc::Signature’
if ( validate(digidoc::Signature::POLv1) == Valid )
^~~~~
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp: In member function ‘DigiDocSignature::SignatureStatus DigiDocSignature::validate(const string&) const’:
/home/al/rpmbuild/qdigidoc/qdigidoc/client/DigiDoc.cpp:420:21: error: no matching function for call to ‘digidoc::Signature::validate(const string&) const’
s->validate(policy);


Mis see on, ebasobiv Qt?

libdigidoc ei kompileeru samuti, ilmselt ei sobi uus openssl

On võimalik tööle saada Chrome (autentimine ja allkirjastamine).


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 31.03.2007
Postitused: 997
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 08.10.2017, 13:46  postituse pealkiri:  (teema puudub)  

ID-kaarditarkvara komponentide versioonid leiab artiklist "ID-tarkvara komponentide kõige uuemad versioonid" https://www.id.ee/index.php?id=36785


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 25.10.2013
Postitused: 233
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Q4OS
estonia.gif
postituspostitatud: 11.10.2017, 00:53  postituse pealkiri:  (teema puudub)  

tonks kirjutas:
On keegi mingit viimast ID tarkvara paigaldanud? Mis versiooni numbrit kaardi haldusvahendi akna all servas kuvab? Mul kuvab 3.12.5.1233, sisselogimine ja allkirjastamine toimib, samas pärast paari-kolme nädalast mittekasutamist nüüd avamisel teadustas, et on uuem versioon saadaval. Senini on süsteem automaatselt ise uuendanud, nüüd sundkorras uuendamine ei vii kuhugi, jääb endine. Huvi pärast helistasin infosse, sealt öeldi, et see versioon ei peaks üldse enam töötama. Või on linuxis numbrid teisemad, kui windowsis?

Linux Mint 18.2 KDE ja täpselt sama jama samade versiooninumbritega.
Proovisin automaatse paigaldusskriptiga üle installida ja see teatas, et:
Kood:
open-eid is already the newest version (17.6.0.1724-1604).

Kuid id kaardi haldusvahend jaurab ikka, et "saadaval on uuendus ja installi need id.ee lehelt"
Mis siis tegema peab ??


tonks
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.12.2016
Postitused: 35
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 11.10.2017, 03:21  postituse pealkiri:  (teema puudub)  

Tuleb vist oodata ära see uuendus, kui hakatakse novembris sertifikaate uuendama.
Vaatasin, mis paigaldatud pakettide numbrid on.
Open-id on 17.01.1686-1610, peaks olema 17.06
Samas qdigidoc on 3.13.1-1495-1404, id.ee lehe järgi saadaval 3.13.1-1492
esteidfirefoxplugin olemas 3.12.2-1145beta-1404, saadaval 3.12.1.1142-1510
opensc vastavalt 0.13.0-3ubuntu1-2 ja 0.15.0-1ubuntu1
tera ei ole
Ülejäänud paketid on samad, mis id.ee lehel.


merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 154
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu 16.04
estonia.gif
postituspostitatud: 11.10.2017, 19:32  postituse pealkiri:  (teema puudub)  

hirax kirjutas:
Proovisin automaatse paigaldusskriptiga üle installida ja see teatas, et:
Kood:
open-eid is already the newest version (17.6.0.1724-1604).

Kuid id kaardi haldusvahend jaurab ikka, et "saadaval on uuendus ja installi need id.ee lehelt"


Mind hakkas ka see hiljuti huvitama (loe häirima) ja kirjutasin neile. Aga teravamatel pliiatsitel on vist tööd liiga palju ja seni pole vastust saanud. Aga faktiliselt ongi repost viimane saadaval olev 17.6 versioon. Windowsile samas 17.8.


tonks
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.12.2016
Postitused: 35
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 11.10.2017, 20:43  postituse pealkiri:  (teema puudub)  

Ma helistasin neile, kui see probleem tekkis, et milline see number olema peab. Öeldi, et peab näitama 17.6. No ei näita. Siis tegingi oma postituse siia, et mis teistel on.
Ma pole nende käest mõned korrad, mis küsinud õiget abi saanudki või siis tagantjärgi, kui juba ise hakkama saanud.
Üks kontrastne näide oli see, kui mul oli vaja üks dokument allkirjastada. Millegi pärast ei olnud mul installitud seda allkirjastamise osa. Helistasin ja küsisin nõu. Jõudsime siis sinna välja, et kui arvutis ei saa, siis id.ee lehel on selline koht, aga seda avalikult netis ei ole. Nii mulle see tibi seal teisel pool väitis. Ütles siis, selle aadressi, ma juhm küsisin vist, et kas sellele käib ette www või oli see http. Öeldi, jah käib. No ei ava, pole sellist lehte. Kui ei ava, kirjutage neile, siis vastavad täpsemalt. Kirjutasin. Vaja oli siiski kiiresti allkirjastada. Googeldama. Pärast vandusin, et kus mu mõistus oli, neil lehtedel käib ju ees https ja lehe aadress avalikult neil olemas id.ee lehel. Nii palju siis nende poolsest abist. Paari päeva pärast tuli ka kirjale vastus lehe aadressiga ja veidi hiljem veel küsitlus, et kas saite abi ja jäite rahule.


merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 154
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu 16.04
estonia.gif
postituspostitatud: 11.10.2017, 22:38  postituse pealkiri:  (teema puudub)  

Minu hämming oli suuresti sellest, et miks üldse keskse tarkavarahaldusega opsüsteemil sellist versioonikontrolli tehakse. Ja siis uusima versiooniga uuendada palutakse, mis võimatu on.
Kirjutanud olen varem korra, kui ka suurem tehniline pähkel oli. Lahendust kahjuks sellele ei leidnudki, aga asjaliku vastuse siiski sai. Seepärast sai ka seekord kirjutatud. Saavad kauem seedida, õigele inimesele edastada, saab ka vastus/vepaparandus ehk parem olema kui telefoni teel asju ajades. Aga mul ka põhiasjad töötavad ja kiiret otseselt pole sellega. Tahaks asja paremaks saada lihtsalt.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 25.10.2013
Postitused: 233
Asukoht: maal ja merel
Distributsioon: Mint 18.2 KDE 64bit , Q4OS
estonia.gif
postituspostitatud: 12.10.2017, 01:43  postituse pealkiri:  (teema puudub)  

Seal tundub olema nii, et telefonile ja kirjadele esimestena vastavad "eesliini lihtsõdurid" Very Happy
Kunagi kui Chrome enam eesti id pin2 andmist ei tunnistanud saatsin neile oma esimeses kirjas spetsiaalselt igasugu terminali vastuseid ja diagnostika tulemused, aga sealt vastus ajas päris vihale. Hakati mingite automaatvastustega nullist pihta: mis versioon on, kas on ikka id.ee lehelt alla laetud tarkvara, kas vastavad pluginad on lubatud jne jne.
Ometigi olid vastused neile küsimustele juba esimese kirjaga antud. Nagu poleks üldse mu kirja lugenudki Mad
Vist mingi kaks nädalat muudkui edastati kiri järgmise astme "spetsialistini", kellele tuli siis jälle otsast peale seletama hakata. Kuni lõpuks vastas keegi (kes seal isegi vist mingitpidi koodi kirjutamisega seotud on) niimoodi: "Lugesin läbi alloleva kirjavahetuse ning tuleb tõdeda, et Teile on antud asjatult lootust saada Linux'i distributsioonis Mint tööle digitaalne allkirjastamine veebilehitseja Google Chrome M35 versioonist "
Alles peale seda hakkasid asjad liikuma. Jutt muutus konkreetseks, saadeti linke testlehtedele jne.

Muidu praegu mul ka pin1 ja pin2 värgid toimivad ja ma saan aru, et tuleb mul see haldusvahendi uuenduse jutt ära kannatada kuniks repost uuendus tuleb Smile


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group