Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 25.06.2005
Postitused: 1285
Asukoht: Lappeenranta-Turku
Distributsioon: buntulased
finland.gif
postituspostitatud: 05.09.2017, 17:54  postituse pealkiri: Snif ! Ei õnnestu lisada uut monitori resolutsiooni!?  

Üritan lauaarvutile järgi saada ASUS LCD monitor VW222U 22"

Hetkel on pilt ees resoga 1366x768 Parempoolsest ekraanist on osa pilti kadunud ehk siis kusagil ääretaga.

Üritan uut resolutsiooni lisada järgmise õpetuse järgi https://community.linuxmint.com/tutorial/view/877


Ning olen hetkel jõudnud nii kaugele kui:
Kood:
 $ cvt 1600 900
# 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

$  xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync
xrandr: Failed to get size of gamma for output default

$ xrandr --addmode default "1600x900_60.00"
xrandr: Failed to get size of gamma for output default

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1366 x 768, current 1366 x 768, maximum 1600 x 900
default connected primary 1366x768+0+0 0mm x 0mm
   1366x768       0.00*
   1600x900_60.00  59.95


Edasi enam ei oska midagi teha, ehk jagab keegi maakeelset rohtu ja abi. :S

Masina info https://gist.github.com/anonymous/4432154304409464b5d79489197bd1b8




Viimati muutis -IFFI- 14.09.2017, 21:25; muudetud 3 korda
hunt_1
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.07.2009
Postitused: 290

Distributsioon: Mageia 6 mate 64-bit
estonia.gif
postituspostitatud: 05.09.2017, 21:55  postituse pealkiri: Snif ! Re: Ei õnnestu lisada uut monitori resolutsiooni!?  

ASUS LCD monitor VW222U 22" parim rezo on 1680 x 1050
Seega suhe 16:10.
Saad veel proovida 1440x900 ja 1280x800.

Hetkel sinul 1366x768 16:9


vooler3
Pingviini aktivist
Pingviini aktivist



Liitunud: 21.12.2015
Postitused: 288


blank.gif
postituspostitatud: 05.09.2017, 22:32  postituse pealkiri:  (teema puudub)  

Ei tasu kiusata ennast nende "muude ekraanilahutustega" kuna arvuti andmetes on kenasti kirjas, et see masin on aastast 2007 ning tollased videod ei tunne tänapäevaseid kõrglahutusi ära.

HP Compaq dc7800p Small Form Factor Chassis: type: 4
Mobo: Hewlett-Packard model: 0AA8h Bios: Hewlett-Packard v: 786F1 v01.04 date: 07/18/2007
CPU: Dual core Intel Core2 Duo E6550 (-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 9309
clock speeds: min/max: 1998/2333 MHz 1: 2333 MHz 2: 2333 MHz
Graphics: Card: Intel 82Q35 Express Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:29b2

Nii, et esmastl tuleb kasutusele võtta - kui võimalik- lisakaardina tänapäevane videokaart.

PS: Olen paar korda ka samasuguse nähtuse üle elanud kus arvutisse tuleb kõigepealt tekitada tänapäevane videokaart ning alles siis tänapäevane monitor külge.


hunt_1
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.07.2009
Postitused: 290

Distributsioon: Mageia 6 mate 64-bit
estonia.gif
postituspostitatud: 05.09.2017, 23:57  postituse pealkiri:  (teema puudub)  

Media Accelerator 3100 chip-ID: 8086:29b2 saab ilusti kätte 1680x1050:
https://forums.linuxmint.com/viewtopic.php?t=214817


-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 25.06.2005
Postitused: 1285
Asukoht: Lappeenranta-Turku
Distributsioon: buntulased
finland.gif
postituspostitatud: 06.09.2017, 15:46  postituse pealkiri:  (teema puudub)  

Tänud vastuse eest.

Hetkel on minu XORG faili sisu selline
Kood:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # <str>
        #Option     "fbdev"                 # <str>
        #Option     "debug"                 # [<bool>]
   Identifier  "Card0"
   Driver      "fbdev"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Kas ma võin oma xorg sisu julgelt asendada minti foorumis jagatud selle sisuga

Kood:
Section "Monitor"         
   Identifier    "Monitor0"
   HorizSync       24.0 - 94.0   
   VertRefresh     24.0 - 87.0
   Modeline "1680x1050_60.00"  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync
   Option "PreferredMode" "1680x1050"
EndSection

Section "Device"
   Identifier   "Device0"
   Driver   "intel"   
   Option "Monitor-VGA1" "Monitor0"
EndSection

Section "Screen"
   Identifier   "Screen0"
   DefaultDepth   24
   SubSection     "Display"
      Depth       24
      Modes "1680x1050"
   EndSubSection
EndSection


või lisan need sektsioonid lihtsalt juurde?
VASTUS: lisasin/asentasin selle faili ja toimetab põhimõteliselt. Resoga 1680x1050 (16:10) oleks pilt täiesti ok aga pilt nihkub ekraanil paremale ja vasakusse äärde jääb 3-4cm must ehk tühi riba.
Ja pärast masina rebooti ei tule enam pilt ette, tuleb uuesti panna järgi 19" monitor ja sellega reso paika sätida ja siis tagasi 22" monitor

Hetkel jookseb pilt 1440x900 resoga ja on täiesti ok kuigi tahaks saada siiski tööle selle 1680x1050

Eks tuleb veel kusagilt muterdada midagi....jääb tuleviku ilmselt see Very Happy


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 675
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 07.09.2017, 07:49  postituse pealkiri:  (teema puudub)  

-IFFI- kirjutas:
Ja pärast masina rebooti ei tule enam pilt ette, tuleb uuesti panna järgi 19" monitor ja sellega reso paika sätida ja siis tagasi 22" monitor

Tee töötavast xorg.conf-ist teise nimega koopia ja kui xorg.conf-i muutes ei tule pilt ette, siis mine Ctrl-Alt-F?-ga teisele konsoolile, logi sealt tekstimoodis sisse ning kopeeri töötava xorg.confi koopia tagasi xorg.conf-iks. Ctrl-Alt-Bck peaks ka X-ist välja tekstimoodi tooma.


-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 25.06.2005
Postitused: 1285
Asukoht: Lappeenranta-Turku
Distributsioon: buntulased
finland.gif
postituspostitatud: 14.09.2017, 21:29  postituse pealkiri:  (teema puudub)  

Jätkan probleemi lahendust kuna see jäi poolikuks viimane kord.

Hetke seis on järgmine, et pilt on kenasti ees resoga 1440x900 (16:10) Kui teen restardi siis näen seda Linux Mint logo kus all on need 5-6 täpikest, mingi aeg on see ees ja siis pilt kaob ära. Ootan siis mingi "X" aeg tunde järgi umbes kunas peaks olema ees login aken. Kirjutan parooli ja vajutades enter login sisse ...ja mõne ajapärast siis ilmub taas pilt ette kenasti.
Et mingi aeg masina ülesse tulemisel ei ole pilti kuid pärast on kõik ok. Otseselt see polegi nagu probleem, vastupidiselt tõstab turvalisust võõrastel sisselogimiseks Razz Very Happy kuigi jah, peale enda nagu polegi kedagi kes kodus sisse võiks logida Razz See-selleks, paluksin abi järgmistele küsimustele;

Kuidas või mida teha, et ka logimisel oleks pilt kõik aeg ees?

Kas on võimalik muuta mul veel resolutsiooni?
Valikus on olemas veel kaks varjanti, 1600x1200(4:3) ja 1680x1050(16:10) Kui valida see 1600x1200(4:3) siis kaob ära vasakust ekraani servast töölaua osa mingi 4cm ehk siis kogu pilt on selle võrra nihutatud paremale ja parempoolne osa on ekraani ääre taga peidus. Ise arvan, et peaks saama selle (4.3) kuidagi muudetud (16:10) peale siis vast äkki on normaalne??!!

Aga kui valida 1680x1050(16:10) siis lööb ekraani mustaks ja ei kuva miskit ette. Samas läbi teamvieweri vaadates on pilt ees.

Hetke XORG.CONF fail asukohaga /etc/X11/xorg.conf sisu on järgmine
Kood:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"         
   Identifier    "Monitor0"
   HorizSync       24.0 - 94.0   
   VertRefresh     24.0 - 87.0
   Modeline "1680x1050_60.00"  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync
   Option "PreferredMode" "1680x1050"
EndSection

Section "Device"
   Identifier   "Device0"
   Driver   "intel"   
   Option "Monitor-VGA1" "Monitor0"
EndSection

Section "Screen"
   Identifier   "Screen0"
   DefaultDepth   24
   SubSection     "Display"
      Depth       24
      Modes "1680x1050"
   EndSubSection
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # <str>
        #Option     "fbdev"                 # <str>
        #Option     "debug"                 # [<bool>]
   Identifier  "Card0"
   Driver      "fbdev"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Et siis mida ja kuidas mudida ja kuhu liigutada?


bobc
Pingviini aktivist
Pingviini aktivist


Vanus: 36
Liitunud: 09.07.2005
Postitused: 165
Asukoht: undef
Distributsioon: SouRCe64 GNU/Linux
estonia.gif
postituspostitatud: 21.09.2017, 10:27  postituse pealkiri:  (teema puudub)  

Kas see monitor on VGA pordis? Kui jah siis vaata kas
antud monitoril on selline "nupp" või menus "Auto Set" mis siis
seab pildi monitori raamidesse kui on nihkes.

Kui DVI siis pole seda vaja teha.

Teine asi kui pilt ees kas siis pilt on 1:1 st. monitori reso on 1680x1050 aga kui paned 1600x1200 siis pilt liigub ülesse alla kui hiirega liigutad. Et kas
pilt on terav/selge või on zuumitud.

Ja kui sa X ette ei anna reso mis siis juhtub, kas X ise ei testi reso välja.


-IFFI-
Vana Pingviin
Vana Pingviin


Vanus: 41
Liitunud: 25.06.2005
Postitused: 1285
Asukoht: Lappeenranta-Turku
Distributsioon: buntulased
finland.gif
postituspostitatud: 24.09.2017, 11:18  postituse pealkiri:  (teema puudub)  

Tänud Very Happy need monitoril nuppudega seadistamine oligi abiks. Sain kenasti 1600x1200 resoga pildi fookusesse ja kõik on ok nüüd. See 1680x1050 võibolla jääks isegi liiga väikseks.
Hetkel on selle 1600x1200 resoga pilt veidi venitatud laiaks, võibolla kui saaks reso muditud 1600x1400 oleks täitsa ok.
Ja hetkel on veel see jama, et logimise akna pilt on must. Et kui lasen masina käima siis alguses näitab neid buut kirjasid ja isegi minti logo ning siis kaob pilt ära. Umbes miski teatud ajatagant kui arvan, et ees on logimise aken siis kirjutan pimesi sisse parooli ja login nii sisse. siis tuleb pilt taas ette.
Kui keegi oskab miskit rohtu jagada siis võiks edasi muterdada antud puudustega kuigi see otseselt aksutamist enam ei häiri.


vooler3
Pingviini aktivist
Pingviini aktivist



Liitunud: 21.12.2015
Postitused: 288


blank.gif
postituspostitatud: 24.09.2017, 11:49  postituse pealkiri:  (teema puudub)  

-IFFI- kirjutas:
Tänud Very Happy need monitoril nuppudega seadistamine oligi abiks. Sain kenasti 1600x1200 resoga pildi fookusesse ja kõik on ok nüüd. See 1680x1050 võibolla jääks isegi liiga väikseks.
Hetkel on selle 1600x1200 resoga pilt veidi venitatud laiaks, võibolla kui saaks reso muditud 1600x1400 oleks täitsa ok.
Ja hetkel on veel see jama, et logimise akna pilt on must. Et kui lasen masina käima siis alguses näitab neid buut kirjasid ja isegi minti logo ning siis kaob pilt ära. Umbes miski teatud ajatagant kui arvan, et ees on logimise aken siis kirjutan pimesi sisse parooli ja login nii sisse. siis tuleb pilt taas ette.
Kui keegi oskab miskit rohtu jagada siis võiks edasi muterdada antud puudustega kuigi see otseselt aksutamist enam ei häiri.

See käivitamise "must ekraan" võib tulla lihtsast värgist:
- vanake videokaart kasutab "rauas olevat lahutust" 800x600 kuid monitor ise enam sellist lahutust omaks ei võta ja tahab saada suuremat, tänapäevasemat lahutust.

Olen ise sellist varianti ka täiesti näinud kus uuema aja monitor ei tunnistanud enam 800x600 pilti. Ja asi lõppes tollal uuema aja videokaardi ostmisega.
"piir oli tollal umbes nii", et 17 ja 19 tolliste monitoridega probleemi polnud kuid probleemid tekkisid vist 22 tollise monitorga.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group