Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 25.10.2013
Postitused: 225
Asukoht: maal ja merel
Distributsioon: Mint 18.1 KDE 64bit
estonia.gif
postituspostitatud: 04.02.2017, 04:41  postituse pealkiri:  (teema puudub)  

Kui Zorin on ka "ubuntuline", siis võid proovida sama asja, mis teisel "buntu lähisugulasel" (ehk Linux Mint) aeg-ajalt aitab.
Ava juurkasutaja õigustes fail /etc/lsb-release
(Ma ise avan tavaliselt failihalduris parema hiireklahviga -> ava juurksutajana või siis avada terminalis: sudo mis-iganes-tekstiredaktor-sul-on /etc/lsb-release)
Peaks avanema fail, kus kirjas:
DISTRIB_ID=mingi jutt
DISTRIB_RELEASE=mingi number
DISTRIB_CODENAME=mingi ilus nimi
DISTRIB_DESCRIPTION=süsteemi täisnimi

Nende ridade ette pane kõigile trellid -> #

Nüüd näeb välja niimoodi:

#DISTRIB_ID=mingi jutt
#DISTRIB_RELEASE=mingi number
#DISTRIB_CODENAME=mingi ilus nimi
#DISTRIB_DESCRIPTION=süsteemi täisnimi

ja kohe selle alla kleebi:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

Nüüd peaks fail selline välja nägema:

#DISTRIB_ID=mingi jutt
#DISTRIB_RELEASE=mingi number
#DISTRIB_CODENAME=mingi ilus nimi
#DISTRIB_DESCRIPTION=süsteemi täisnimi
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

- salvesta fail
- tee oma installimised (installer peaks arvama, et ta on Ubuntu 16.04 LTS süsteemis)
- kustuta failist see, mille kleepisid, et ta näeks jälle selline välja nagu algselt ja kustuta trellid
- salvesta uuesti fail
- reboot system

Ehk mõjub Wink


tonks
Pingviini külastaja
Pingviini külastaja



Liitunud: 01.12.2016
Postitused: 30
Asukoht: Harjumaa
Distributsioon: Zorin OS
estonia.gif
postituspostitatud: 04.02.2017, 05:13  postituse pealkiri:  (teema puudub)  

Kindlasti proovin, mul kaks prooviketast 9 ja 12 ilma ID-ta Smile Ultimatel sain paika ja sisselogimine Chromiumiga ka töötab. Synaptic aitas, hakkasin sealt pakette vaatama, kuni jõudsin Tarkvaraallikateni. Seal ühel ee. lehel olid paketid olemas, uusimale versioonile kasti linnuke, ülejäänud vajalikud paketid tõmbas ise roheliseks ja oligi olemas. Jälle targem.
Ainul Vivaldiga ei taha töötada. Token signing 0.0.22 on lubatud, aga ei toimeta. Vanas igapäevaselt kasutatavas süsteemis senini töötab probleemideta. Ainult seal jälle selline kiiks, et esimesel korral, kui ei käivitunud, sai Chromiumiga sisselogitud, siis pärast seda hakkas Vivaldi ka sisselogimisel sertifikaadi ja pinkoodi aknaid tekitama. Pärast seda enam topkat vaja ei olnud, võis arvuti välja lülitada, pärast töötas iseseisvalt edasi. Siin sellist mõju ei ole. Eks peab edasi pusima või ei sobi kõige uuema ID-tarkvaraga kokku. Vanas süsteemis oli ka mingi ID-tarkvara uuendus, seal jäi tööle. Eks jälle peab Synapticuga pakette süsteemides võrdlema, mis versiooninumbrid on.

Sai siis edasi urgitsetud. Kõike peab kaasajal häkkima, isegi ID-kaardi paigaldusskripti Evil or Very Mad
# check if Debian or Ubuntu >> # check if Debian or Zorin

Ubuntu)
case $codename in
>>
Zorin)
case $codename in


Ja paigas ta oligi.

Vivaldi sain isegi korraks koostöös Chromiumiga sisse logima paarile lehele. Pärast arvuti restarti aga enam ei saanud ja Chromium ka ei aidanud. Moditud skriptiga kettal ka proovisin FF-i abiga, ei mõjunud. Jääb selline mulje, et Vivaldi nagu isesisvalt ei vea mingit vajalikku paketti alati käima.




Viimati muutis tonks 04.02.2017, 12:23; muudetud 1 kord
mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 04.02.2017, 12:20  postituse pealkiri:  (teema puudub)  

Või siis muuda https://github.com/open-eid/linux-installer/blob/master/install-open-eid.sh skripti nii, et Zorin oleks lubatud Smile


Meelis
Pingviini aktivist
Pingviini aktivist



Liitunud: 23.07.2007
Postitused: 265

Distributsioon: Mint xfce
estonia.gif
postituspostitatud: 11.02.2017, 18:09  postituse pealkiri:  (teema puudub)  

Proovisin installida ID kaardi tarkvara Debian 8.6-le, Ütleb, et Debian ei ole toetatud ja install jääb pooleli. Kas keegi on saanud Debian 8.6-l ID tarkvara tööle? Kui jah, siis kuidas?


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 25.10.2013
Postitused: 225
Asukoht: maal ja merel
Distributsioon: Mint 18.1 KDE 64bit
estonia.gif
postituspostitatud: 11.02.2017, 18:32  postituse pealkiri:  (teema puudub)  

Mul on jäänud märkmetesse (minu mäletamist mööda kasutaja natsa poolt kunagi tehtud) järgmised juhised Debiani jaoks:

## Repo paigaldamiseks (Debian-8 )
sudo apt-get install -y software-properties-common

## ID-kaardi repo
sudo add-apt-repository "deb https://installer.id.ee/media/ubuntu trusty main"

## Repo võti
wget -qO - https://installer.id.ee/media/install-scripts/ria-public.key | sudo apt-key add -

## Uuendamiseks valalik pakett (Debian-8 )
sudo apt-get install -y apt-transport-https

## Uuendamine
sudo apt-get update

## Vajalikud pakid
sudo apt-get install -y pcscd libccid libxerces-c3.1 opensc ttf-liberation libxml-security*

## Ja lõpuks saab installida
sudo apt-get install -y estonianidcard


Meelis
Pingviini aktivist
Pingviini aktivist



Liitunud: 23.07.2007
Postitused: 265

Distributsioon: Mint xfce
estonia.gif
postituspostitatud: 11.02.2017, 20:08  postituse pealkiri:  (teema puudub)  

Suur tänu hirax!

Sain ID tarkvara tööle. Töötab nii Firefoxi kui Chromega.


guccimucci
Uus kasutaja
Uus kasutaja


Vanus: 22
Liitunud: 05.08.2014
Postitused: 1


estonia.gif
postituspostitatud: 16.02.2017, 13:30  postituse pealkiri:  (teema puudub)  

Ma ei tahaks uut teemat teha, seega postitan esialgu siia. Kas ArchLinuxi baasil Manjarole on ka võimalik ID-tarkvara peale laadida? Järgisin seda linki: https://wiki.archlinux.org/index.php/Estonian_ID-card, aga juba qdigidoc'i laadimisel tekkis probleeme vananenud pakettidega. Isegi kui selle kuidagi tööle saaksin, kas siis pärast igat suuremat uuendust peaksin jälle otsast alustama või on võimalik kuidagi automaatseid uuendusi saada?


Skorzeny
Pingviini aktivist
Pingviini aktivist



Liitunud: 30.06.2007
Postitused: 353

Distributsioon: /LinuxMint Mate18.1/Backbox 4.5
burkinafaso.gif
postituspostitatud: 17.02.2017, 11:12  postituse pealkiri:  (teema puudub)  

guccimucci kirjutas:
Ma ei tahaks uut teemat teha, seega postitan esialgu siia. Kas ArchLinuxi baasil Manjarole on ka võimalik ID-tarkvara peale laadida? Järgisin seda linki: https://wiki.archlinux.org/index.php/Estonian_ID-card, aga juba qdigidoc'i laadimisel tekkis probleeme vananenud pakettidega. Isegi kui selle kuidagi tööle saaksin, kas siis pärast igat suuremat uuendust peaksin jälle otsast alustama või on võimalik kuidagi automaatseid uuendusi saada?


Pamac(Octopi)->Lisa endale sobiv(ad) AUR'-> tegutse.
Manjaro all töötab praktiliselt kõik. Mõne asja käima saamine võib lihtsalt aega võtta ...

_________________
Image

ats
Uus kasutaja
Uus kasutaja


Vanus: 47
Liitunud: 26.01.2007
Postitused: 6
Asukoht: Türi
Distributsioon: Mageia
estonia.gif
postituspostitatud: 27.02.2017, 19:37  postituse pealkiri:  (teema puudub)  

Tere!
Mageias (mageia Cauldron) ei toimi ID - kaardiga pangas allkirjastamine. Seda siis Firefoxiga. Chromiumi kasutades ei saa isegi panka sisse logida. Digidoc programmiga allkirjastamine töötab. Mida ma saaksin ette võtta? Kui on mingit infot vaja, küsige, püüan kiirelt teavet anda.


hunt_1
Pingviini aktivist
Pingviini aktivist



Liitunud: 24.07.2009
Postitused: 284

Distributsioon: Mageia 5 mate 64-bit, mint 17 mate
estonia.gif
postituspostitatud: 27.02.2017, 20:58  postituse pealkiri:  (teema puudub)  

Kood:
Cauldron is not for the faint of heart!
It may break down your computer, eat your data, burn down your house or kill your kittens. You have been warned! ;)

Kasuta mageia 5.1 ehk viimane töötav, 6 on veel testimisel.
Võib olla keegi palub ID testimist 6 versiooniga, aga seda ikka pärast ametlikku ilmumist.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 652
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 28.02.2017, 09:41  postituse pealkiri:  (teema puudub)  

Firefoxis peavad laiendustes vastu vaatama:

Plugins - EstEID plug-in (mul 3.7.2.1106) - Always Activate

Extensions - Estonian ID Card PKCS11 modul loader (mul 3.7.2.1043) - lubatud

Seadetes 'Advanced' -> Certificates -> Security Devices -> Estonian ID Card -> Path: /usr/lib64/onepin-opensc-pkcs11.so
- see .so peab seal kaustas olema. Kui on mujal, siis kopeeri sinna või tee link

Mul on 64-bitine openSUSE-13.1, aga FF peaks teistes OS-ides samamoodi käima. Kuidas need menüüde valikud eestikeelses OS-is välja näevad, seda ma ei tea.


ats
Uus kasutaja
Uus kasutaja


Vanus: 47
Liitunud: 26.01.2007
Postitused: 6
Asukoht: Türi
Distributsioon: Mageia
estonia.gif
postituspostitatud: 28.02.2017, 11:13  postituse pealkiri:  (teema puudub)  

Tänud kiirete vastuste eest!
Kõik pluginad on kontrollitud - lubatud. Ka see onepin-opensc-pkcs11.so on seal, kus ta peab olema. Katseks tõmbasin alla Firefoxi uusima versiooni. Mageias on kasutusel tulirebase ESR versioon, ja see ei kõssagi, kui pangas klikin nuppu "Allkirjasta ID-kaardiga". Uusim versioon (51.0.1) annab veateate, et plugin on küll installitud, aga ei tööta. Ja soovitab brauserile restart teha. Seda olen teinud mitmel korral, kuid tulemusteta. Hunt_1 tean küll, mis cauldron on. Aga tahaks lihtsalt uurida, kas viga on vaid minu süsteemis, või on see üldisem. Ja võimalusel ka aidata seda lahendada. Mageia mulle meeldib. Kasutan 32 - bitist mageiat.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 652
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 28.02.2017, 13:19  postituse pealkiri:  (teema puudub)  

Firefoxi sõltuvuste loetelu on pikk:

% ldd /usr/lib64/firefox/firefox
linux-vdso.so.1 (0x00007ffec436d000)
/usr/lib64/libfreeimage.so.3 (0x00007fd7001e0000)
/opt/google/earth/free/baifaao.so (0x00007fd6fffde000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fd6ffdc0000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fd6ffbbc000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fd6ff8b4000)
libm.so.6 => /lib64/libm.so.6 (0x00007fd6ff5b1000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fd6ff39a000)
libc.so.6 => /lib64/libc.so.6 (0x00007fd6fefec000)
/lib64/ld-linux-x86-64.so.2 (0x00007fd70056a000)
libz.so.1 => /lib64/libz.so.1 (0x00007fd6fedd6000)
libIlmImf-Imf_2_0.so.20 => /usr/lib64/libIlmImf-Imf_2_0.so.20 (0x00007fd6feabf000)
libHalf.so.10 => /usr/lib64/libHalf.so.10 (0x00007fd6fe87c000)
libIex-2_0.so.10 => /usr/lib64/libIex-2_0.so.10 (0x00007fd6fe65b000)
libraw.so.9 => /usr/lib64/libraw.so.9 (0x00007fd6fe3bf000)
libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007fd6fe182000)
libopenjpeg.so.1 => /usr/lib64/libopenjpeg.so.1 (0x00007fd6fdf5a000)
libIlmThread-2_0.so.10 => /usr/lib64/libIlmThread-2_0.so.10 (0x00007fd6fdd53000)
libjasper.so.1 => /usr/lib64/libjasper.so.1 (0x00007fd6fdaf9000)
libjpeg.so.8 => /usr/lib64/libjpeg.so.8 (0x00007fd6fd8a8000)
liblcms2.so.2 => /usr/lib64/liblcms2.so.2 (0x00007fd6fd653000)
libgomp.so.1 => /usr/lib64/libgomp.so.1 (0x00007fd6fd444000)

Arvatavasti mõni neist ei sobi konkreetse FF versiooniga.
Ei oska muud nõu anda kui tuhnida mööda ID-tarkvara ja FF nõuete loetelusid, et siis katsuda neid teekide versioone kokku korjata.
Ega see kerge pole - umbes nagu ise lähtetekstist kompileerimine.

Või ehk proovida mõnda veidi vanemat FF versiooni? Mul on FF-50.1.0 for openSUSE.


ats
Uus kasutaja
Uus kasutaja


Vanus: 47
Liitunud: 26.01.2007
Postitused: 6
Asukoht: Türi
Distributsioon: Mageia
estonia.gif
postituspostitatud: 28.02.2017, 14:58  postituse pealkiri:  (teema puudub)  

Uurisin ja puurisin seda asja ja sain chromiumis id-kaardi tarkvara tööle. Nii panka logimise kui ka digiallkirjastamise. Selleks tuli terminalis anda selline käsk
Tsitaat:
modutil -dbdir sql:$HOME/.pki/nssdb -add onepin-opensc-pkcs11 -libfile onepin-opensc-pkcs11.so -mechanisms FRIENDLY
See käsk lisab opensc mooduli Chromiumi. Leidsin selle siit: https://aur.archlinux.org/packages/chrome-token-signing/ Vähemalt Chromiumiga saan nüüd id - kaardiga omad asjad ära ajada. Ehk on kellelegi abiks. Firefoxiga digiallkirjastamist veel tööle ei saanud.


sander85
Vana Pingviin
Vana Pingviin


Vanus: 31
Liitunud: 08.08.2005
Postitused: 4328
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 03.03.2017, 11:18  postituse pealkiri:  (teema puudub)  

Firefoxi jaoks on vaja praegu ilmselt see lisa paigaldada:

https://addons.mozilla.org/en-US/firefox/addon/est-pkcs11-load/

Mageiaga kaasas olev lisa ei ühildu enam uuemate Firefoxi versioonidega ja ma ei saanud seda ka paraku tööle. Mageia 6 peaks olukorda jälle natuke parandama ja värskemad versioonid kaasa tooma.

_________________
Image Image Image

vatson
Pingviini külastaja
Pingviini külastaja



Liitunud: 01.03.2009
Postitused: 29

Distributsioon: openSUSE
estonia.gif
postituspostitatud: 23.03.2017, 21:42  postituse pealkiri:  (teema puudub)  

Küsimus Ubuntu kasutajatele kellel on ametlik installer.id.ee lehelt paigaldatud ID tarkvara. Kas keegi teist on ID kaardi utiliidi abil sertifikaate uuendanud või näinud et utiliit seda võimalust pakub?

Mul on openSUSE Leap 42.1 peale paigaldatud kõige uuem ID tarkvara mille jaoks suutsin pakid leida: https://build.opensuse.org/project/show/home:kentaur_est:open-eid

eesti.ee ja SEB internetipank räägivad mulle pärast sisselogimist et sertitifikaadid vajavad uuendamist, aga ID utiliit mis versiooninumbriks näitab 3.12.4 ei paku uuendamise võimalust. RIA blogis ilmunud materjalidest olen aru saanud et vastav võimalus peaks olema ID utiliidil alates versioonist 3.12.2.

Üritangi nüüd aru saada kas sertifikaatide uuendamine "ei peagi" Linuxi all töötama või on asi minu kasutatavas liiga alternatiivses distros.


hirax
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 25.10.2013
Postitused: 225
Asukoht: maal ja merel
Distributsioon: Mint 18.1 KDE 64bit
estonia.gif
postituspostitatud: 24.03.2017, 00:32  postituse pealkiri:  (teema puudub)  

Just täna tegelesin oma ID kaardi sertide uuendamisega.
Mul on küll "Ubuntu lähisugulane" ehk Linux Mint 18.1 KDE 64bit, kernel 4.4.0-53
ID kaardi tarkvara paigaldatud installer.ee lehelt ja haldusvahend on ver. 3.12.4.1226
Sellel tuli küll kiri ette, et oleks aeg serte uuendada.
Uuendamine toimus ilma tõrgeteta.
Sisselogimine (PIN1) - OK , Digiallkiri (PIN2) - OK


natsa
Vana Pingviin
Vana Pingviin


Vanus: 72
Liitunud: 25.03.2009
Postitused: 533
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 24.03.2017, 09:18  postituse pealkiri:  (teema puudub)  

LMDE uuendas korralikult kõik serdid.

_________________
Kõige parem asi on töötav asi.

Skorzeny
Pingviini aktivist
Pingviini aktivist



Liitunud: 30.06.2007
Postitused: 353

Distributsioon: /LinuxMint Mate18.1/Backbox 4.5
burkinafaso.gif
postituspostitatud: 24.03.2017, 09:40  postituse pealkiri:  (teema puudub)  

vatson kirjutas:
Küsimus Ubuntu kasutajatele kellel on ametlik installer.id.ee lehelt paigaldatud ID tarkvara. Kas keegi teist on ID kaardi utiliidi abil sertifikaate uuendanud või näinud et utiliit seda võimalust pakub?

Mul on openSUSE Leap 42.1 peale paigaldatud kõige uuem ID tarkvara mille jaoks suutsin pakid leida: https://build.opensuse.org/project/show/home:kentaur_est:open-eid

eesti.ee ja SEB internetipank räägivad mulle pärast sisselogimist et sertitifikaadid vajavad uuendamist, aga ID utiliit mis versiooninumbriks näitab 3.12.4 ei paku uuendamise võimalust. RIA blogis ilmunud materjalidest olen aru saanud et vastav võimalus peaks olema ID utiliidil alates versioonist 3.12.2.

Üritangi nüüd aru saada kas sertifikaatide uuendamine "ei peagi" Linuxi all töötama või on asi minu kasutatavas liiga alternatiivses distros.


Töötas.
Paar kuud tagasi sai uuendatud.
btw, toodud tekst on kuidagi tuttav.
Ka minu puhul teatas algul et "vajab uuendamist", uuendada ei saanud.
Siis mingi aja pärast sai uuendamist alustada ...
veateateni.
Ja siis ühel päeval uuendas ära.
Sai RIA kodanike-seltsimeeste käest uuritud, et mis värk oli.
Kui selgitus kokku võtta, siis "sinu kaardi aeg ei olnud veel kätte jõudnud".

"Alternatiivsetest" distrodest rääkides töötab kindlasti Arch/Manjaro peal.

_________________
Image

akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 652
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 24.03.2017, 10:18  postituse pealkiri:  (teema puudub)  

Uuendasin mõned päevad tagasi Ubuntu-16.4-l ID sertifikaate.
ID-kaart oli 2013 välja antud.
ID-haldusvahend ütles alguses, et sertifikaadid kehtivad ja uuendamise võimalust ei pakkunud.
Siis FF-ga riik.ee-sse minnes ütles too, et sertifikaate vaja uuendada.
Pärast seda tuli ka ID-haldusvahendil kollane uuendamisteade ette.

Ubuntu ja selle ID-tarkvara on kodus, nii ei saa versiooninumbreid öelda.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group