Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 28.06.2006, 00:55  postituse pealkiri:  ADSL Gentoos.[lahendatud]  

Gentoo installiga sain hakkama(adsl-setup käsuga internet olemas) ja põhisüsteem töötab.
Nüüd oleks vaja hakata süsteemi edasi ehitama(emerge). Mingil põhjusel, aga ei suuda ma internetti ühendada.
Toimin nii nagu live-cd puhul, ainult adsl-setup'i asemel on pppoe-setup, aga ühendust ei ole võimalik luua.

Ehk keegi valgustaks mind, kus võib probleem peituda. Vajalikud moodulid puudu? Võrguliideseid vaja seadistada?
Hindan kiiret vastamist. Tänan.


spott
Admin
Admin


Vanus: 38
Liitunud: 04.06.2005
Postitused: 8778

Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 28.06.2006, 05:02  postituse pealkiri:  (teema puudub)  

äkki seletad täpsemalt, miks võrguühendust pole võimalik luua?
kas muidu võrgukaardi modulid on ikka laetud?

_________________
Tellige endale sünnipäevaks, sõbrapäevaks või muuks tähtpäevaks kingitus: Kingitused internetist - NetiKink.eu

commodore

Vana Pingviin
Vana Pingviin


Vanus: 32
Liitunud: 02.10.2005
Postitused: 745


blank.gif
postituspostitatud: 28.06.2006, 10:17  postituse pealkiri:  (teema puudub)  

kustutatud




Viimati muutis commodore 16.08.2015, 15:54; muudetud 2 korda
Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 28.06.2006, 10:55  postituse pealkiri:  (teema puudub)  

pppoeconf script on ubuntus. Gentoos on selleks, kas adsl-setup või pppoe-setup. Minuteada...
Käivitan pppoe-setup scripti, sisestan vajaliku info. pppoe-start, aga tekib timeout ning ühendus jääb loomata.
Mis moodulitesse puutub, siis pole ma 100% kindel. Kust saaks järele vaadata, mis moodulid on laetud?


vih
Moderaator
Moderaator



Liitunud: 10.08.2005
Postitused: 654


blank.gif
postituspostitatud: 28.06.2006, 11:35  postituse pealkiri:  (teema puudub)  

lsmod

Ja lisad modprobe mooduli_nimi

Tuli meelde, et Gentoo tahtis kunagi minu lauaarvutil pcmcia moodulit adsli jaoks.


Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 28.06.2006, 13:14  postituse pealkiri:  (teema puudub)  

Lähtudes lsmod'i vastusest pole ühtegi moodulit laetud.
Üritasin prooviks lisada neid mooduleid, mis olid livce cd'l kasutusel, kuid teatati, et moodulit pole võimalik leida.
Sama tulem ka pppoe ja pcmia puhul.


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2564
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 28.06.2006, 14:12  postituse pealkiri:  (teema puudub)  

Kui moodulite nimekiri on tühi, siis võib vast eeldada, et need on tuuma sisse ehitatud.
Otsi tuuma konfiguratsioonist üles, et kas see on sisse ehitet või hoopis välja jäänud.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

ingram
Pingviini aktivist
Pingviini aktivist


Vanus: 26
Liitunud: 19.01.2006
Postitused: 225
Asukoht: Viljandi
Distributsioon: Arch Linux
estonia.gif
postituspostitatud: 28.06.2006, 17:44  postituse pealkiri:  (teema puudub)  

nano /etc/resolv.conf

lisa:
nameserver 194.126.101.34
nameserver 194.126.115.18

_________________
- i pwn n00bs -

Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 30.06.2006, 18:20  postituse pealkiri:  (teema puudub)  

Olin paar päeva eemal, kuid ega probleem siis kuhugi kadunud ole. Tänan seniste vastuste eest.

imre kirjutas:
Kui moodulite nimekiri on tühi, siis võib vast eeldada, et need on tuuma sisse ehitatud.
Otsi tuuma konfiguratsioonist üles, et kas see on sisse ehitet või hoopis välja jäänud.

Kahjuks ei suutnud leida kerneli konfiguratisoonifaili.

ingram kirjutas:
nano /etc/resolv.conf

lisa:
nameserver 194.126.101.34
nameserver 194.126.115.18

Ei olnud sellest tuhkagi kasu. Kuid küsin siiski, milleks selline liigutus vajalik oleks olnud?


konna
Pingviini aktivist
Pingviini aktivist


Vanus: 31
Liitunud: 08.07.2005
Postitused: 119
Asukoht: Tartu
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 30.06.2006, 19:08  postituse pealkiri:  (teema puudub)  

1. No egas siis midagi, lähed rooduna kausta /usr/src/linux ja jooksuta seal käsu make menuconfig.
Ja siis tuleks sul liikuda edasi järgmistes menüüdes:
Device drivers --> Network device support -->
Seal tuleks üle vaadata k6ik PPP algavad read.

<*> PPP (point-to-point protocol) support jne...mina olen tihtipeale kõigile * ette pannud kuna ei ole aega olnud süveneda iga ühe sisusse Wink.

Nüüd muidugi tuleb loota, et vähemalt võrkar on sul juba eelnevalt korralikult kerneli confis kirjas. No ja ega siis midagi, kobid menüüdest välja ja salvestad muudatused. See järel jooksutad
Kood:
make && make modules_install

ja edasi ma usun, et oskad ise kah.

2. Nameservereid ehk DNS on selleks vaja, et lahendada domeene. Maybe millekski veel kuid nii suur võrgu spets ma ei ole, et sulle seda öelda. Vaata lisa googlist loomulikult.




Viimati muutis konna 30.06.2006, 19:09; muudetud 1 kord
Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 30.06.2006, 19:08  postituse pealkiri:  (teema puudub)  

Nojah, arvasin et tuumakonfigurtatsiooni all peetakse silmas mingisugust faili.
Igatahes tuumakonfigurtatsioonis(make menuconfig siis...) olin juba varem kõik ppp, adsl jms ära märkinud ning kerneli uuesti kompileerinud. Võin ka uuesti proovida, ega see häda ei tee Smile . Kuid kardetavasti ei anna see loodetud tulemust.

Edit: Mõni ppp'd sisaldav valik oli vahele jäänud, märkisin ka need. Nüüd peaks kernel sisaldama igast jama, mida tegelikkuses ilmselt vaja pole.
make && make modules_install...
Ikka sama olukord.




Viimati muutis Kristo 30.06.2006, 19:42; muudetud 1 kord
konna
Pingviini aktivist
Pingviini aktivist


Vanus: 31
Liitunud: 08.07.2005
Postitused: 119
Asukoht: Tartu
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 30.06.2006, 19:40  postituse pealkiri:  (teema puudub)  

Kristo kirjutas:
Nojah, arvasin et tuumakonfigurtatsiooni all peetakse silmas mingisugust faili.
Igatahes tuumakonfigurtatsioonis(make menuconfig siis...) olin juba varem kõik ppp, adsl jms ära märkinud ning kerneli uuesti kompileerinud. Võin ka uuesti proovida, ega see häda ei tee Smile . Kuid kardetavasti ei anna see loodetud tulemust.

Noo eks seal ole conf fail kah olemas, aga kahjusk ei ole enamus surelikke võimelised seda peast muutma. Oled sa kindel, et sul on kenasti võrkar tööle üldse tõmmatud? ( labane küsimus, kui tihtipeal on lahendused vägagi haigglased).
Tegeltlikult oleks hirmus tore kui sul oleks syslog-ng emergetud töötle tõmmatud..siis oleks vähemalt error msg. võimalik vaadata.
Ühesõnage kui sul seda installitud pole siis võiksid uuesti live-cd pealt bootida ja sellele systeemil juurde emergeda syslog-ng ning peale emerge kirjutada
Kood:
rc-update add syslog-ng default

Peale seda boodid jälle HDD`lt üritad teha pppoe-start ning kui see jälle TIMED OUT annab siis peaks olema /var/log/messages faili lõppu mingisugune veateade ilmunud seoses pppoe.


vih
Moderaator
Moderaator



Liitunud: 10.08.2005
Postitused: 654


blank.gif
postituspostitatud: 30.06.2006, 20:10  postituse pealkiri:  (teema puudub)  

Tsitaat:
olin juba varem kõik ppp, adsl jms ära märkinud ning kerneli uuesti kompileerinud.


Oma võrgukaardi draiver samuti märgitud?


Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 30.06.2006, 20:35  postituse pealkiri:  (teema puudub)  

Minuteada peaks v6rgukaart olema installitud. Toimisin nii nagu Gentoo k2siraamatus v6rgu seadistamise all kirjas. Yhtlasi viskasin pilgu ka Gentoo vikisse. V6i on sellega ka mingi nipp?
Peale TIMEOUT'i j2rgnenud veateade ytleb, et kernelil puudub ppp toetus, moodulit pole v6imalik laadida, ppp pole kerneli konfiguratsioonis.
Ometi on k6ik ppp'd sisaldav m2rgitud konfis. Veateates oli ka paar n2pun2idet, mis k2ske v6iks proovida (mknod /dev/ppp c 108 o ja /sbin/modprobe -v ppp). Kumbki ei toonud edu.

BTW, kas see on minu viga, et foorumi kell on ligi 20 minutit taga?


Zen

Pingviini aktivist
Pingviini aktivist


Vanus: 31
Liitunud: 07.10.2005
Postitused: 155

Distributsioon: openSUSE 11.1
estonia.gif
postituspostitatud: 30.06.2006, 23:23  postituse pealkiri:  (teema puudub)  

Tee igaks juhuks: cp arch/i386/boot/bzImage /boot/<kernel-version> ja vaata, et bootloaderis oleks /boot/kernelblabla sama, mis eelmises reas ja restart ja proovi uuesti. Vöibolla panen väga puusse, aga ise jamasin ka ADSLiga tükk aega (sarnane mure oli).
Kontrolli ka, et /etc/resolv.conf oleksid õigused tavakasutajal lugeda ja kirjutada. Mul ei olnud millegipärast õigused paigas ja tavakasutaja ei saanud internetti.


spott
Admin
Admin


Vanus: 38
Liitunud: 04.06.2005
Postitused: 8778

Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 01.07.2006, 06:39  postituse pealkiri:  (teema puudub)  

Kristo kirjutas:


BTW, kas see on minu viga, et foorumi kell on ligi 20 minutit taga?

nop
see oli serveri viga.
Parandatud ja pandud iga nädal aega sünkroniseerima NTP-ga.


ingram
Pingviini aktivist
Pingviini aktivist


Vanus: 26
Liitunud: 19.01.2006
Postitused: 225
Asukoht: Viljandi
Distributsioon: Arch Linux
estonia.gif
postituspostitatud: 01.07.2006, 08:42  postituse pealkiri:  (teema puudub)  

Kristo kirjutas:
ingram kirjutas:
nano /etc/resolv.conf

lisa:
nameserver 194.126.101.34
nameserver 194.126.115.18

Ei olnud sellest tuhkagi kasu. Kuid küsin siiski, milleks selline liigutus vajalik oleks olnud?


Ubuntus seatakse pppoeconfiga nimeserverid paika, see on rp-pppoe ja vajab nimeservereid.

_________________
- i pwn n00bs -

Kristo
Pingviini kasutaja
Pingviini kasutaja


Vanus: 30
Liitunud: 25.01.2006
Postitused: 89
Asukoht: Tartu
Distributsioon: Ubuntu 10.04
estonia.gif
postituspostitatud: 01.07.2006, 10:26  postituse pealkiri:  (teema puudub)  

Zen kirjutas:
Tee igaks juhuks: cp arch/i386/boot/bzImage /boot/<Kernel-version> ja vaata, et bootloaderis oleks /boot/kernelblabla sama, mis eelmises reas ja restart ja proovi uuesti. Vöibolla panen väga puusse, aga ise jamasin ka ADSLiga tükk aega (sarnane mure oli).
Kontrolli ka, et /etc/resolv.conf oleksid õigused tavakasutajal lugeda ja kirjutada. Mul ei olnud millegipärast õigused paigas ja tavakasutaja ei saanud internetti.

Ju siiski kerneli recompile aitas, lihtsalt oli eelpool nimetatud etapp tegemata ning laeti vana kernel. Probleem lahendatud! Kusjuures eemaldasin nimeserverid resolv.conf'ist ja nende puudumine ei takistanud ühendamist.

Tänan kõiki, kes vastasid. Küllap kohtume mõne aja pärast taas siin samas gentoo alamfoorumis Smile


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group