Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 02.02.2012, 13:17  postituse pealkiri:  Ubuntu 12.04 LTS ja eesti lisad  

Tänu Esteid projektile ja konkreetsemalt Martin-Éric Racine'ile on ID-kaardi tarkvara jõudnud Ubuntu ametlikesse varamutesse (ja on teel Debiani), mis tähendab, et lisareposid pole enam ID-kaardi kasutamiseks vaja seadistada ja eestikeelses süsteemis peaks ID-kaart vaikimisi tööle hakkama. Probleeme siiski on, varasemast teada olevad opensc/openssl ja udev/ccid vead on jätkuvalt alles, kuid nendest saab vajadusel mööda.

Ka oleks oluline valgustada riigiametnikke kasutajate vajaduste osas (rääkige sellest oma asjaga tegelevatele tuttavatele või tutvustage oma vajadusi help@ria.ee aadressil jne). Pole kindel, kas nad on ikka suutnud nüüdseks asjast õigesti aru saada, tsitaat RISO vikist:

Tsitaat:
Probleemiks on Linuxite tugi, kus meie tarkvara on ajaliselt maas Linuxite reliisidest. Näiteks Ubuntu puhul oleme oma toega ühe põlvkonna võrra maas. Ettepanekuks on toetada üksnes Ubuntu distributsiooni kui enimlevinut ja ülejäänute Linuxite jaoks valmistada lähtekoodi pakid koos kompileerimisjuhendiga.

Asi pole mitte ainult selles, et nad on Ubuntust ühe väljalaske võrra maas, vaid nad ka

1) ei tee koostööd Debiani/Ubuntu kogukonnaga ja Esteid projektiga, mistõttu pole nende paketid Ubuntu varamutest kasutajatele loogilisel viisil saadaval,
2) nad ei järgi Ubuntu/Debiani kogukonna vaba tarkvara arenduse reegleid/häid praktikaid, mistõttu keeravad oma pakendustega segi kooskõla Ubuntu ametlike repode pakettidega ja teevad oma ID-tarkvara pakettide kasutamise tülikaks,
3) nad ei paista saavat aru, et lisaks Ubuntu viimase väljalaske toetamisele on vaja toetada ka (või isegi pigem) pikaajalise toega väljalaset.

Estobuntu rindelt niipalju, et on valminud esimene proovitõmmis LXDE töölauaga, st kergekaaluline Estobuntu vanadele arvutitele. Kui keegi võtab LXDE-ga süsteemi seadistamise ja peamiste tõlgete ülevaatamise enda kanda, siis võib Ubuntu 12.04 põhjal ilmuda ka esimene LXDE-ga Estobuntu. Vastav sedel Estobuntu veahalduses on http://estobuntu.itcollege.ee/trac/estobuntu/ticket/104 ja juhised kaastööks on http://estobuntu.org/aita-kaasa. Tuletame meelde, et 10.04 LTS põhjal ilmus esimene Ubuntu standardtöölauaga Estobuntu (toona siis GNOME, nüüd Unity), äkki on aeg lisada veel üks töölaud. Ka GNOME'i seadistamisel oleks vaja abi ja KDE töölaua seadistamisega tegeleja on hetkel täiesti puudu.

Kuna aprillis tuleb välja Ubuntu on pikaajalise toega elik n-ö ärikasutaja versioon, siis võiks selliste versioonide eelistajad (koolid, ettevõtted jne) ka iseäranis panustada järgmise Ubuntu ja Estobuntu valmistamisse. Kuigi suuremaks tegutsemiseks läheb alles märtsis, siiski tasub end juba varem valmis panna ja tegevusi plaanda. Ubuntu esimene beetaversioon ilmub juba 1. märtsil ja siis on 1,5 kuud aega tegeleda tõlgetega. Ubuntu töögraafik on https://wiki.ubuntu.com/PrecisePangolin/ReleaseSchedule.

Ubuntust paratamatult sisse jäävate vigade parandamine ja kohalike seadistuste tuunimine Estobuntus algab Ubuntu 12.04 väljalaskmisega. Selleks ajaks võiks välja mõelda ja läbi rääkida, mis kohandusi peaks järgmine Estobuntu sisaldama, et see võiks maksimaalselt hästi tavakasutaja ja kogukonna huve teenida. Muuseas, igasugu suuremate ideedega koos tuleks pakkuda ka abikäsi vms ressurssi, mis neid ideid ellu viima hakkab.


kessu
Vana Pingviin
Vana Pingviin


Vanus: 44
Liitunud: 16.07.2007
Postitused: 1106

Distributsioon: Ubuntu 16.04 LTS 64bit
estonia.gif
postituspostitatud: 02.02.2012, 23:29  postituse pealkiri:  (teema puudub)  

Facebooki leht andis teada ka uuest videost:

Ubuntu 12.04 Alpha 2 Released
www.omgubuntu.co.uk
As Ubuntu 12.04 is a ‘Long Term Support’ release development is focused on creating a dependable stable experience. As such this latest Alpha features only a handful of modest user-visible changes to the desktop.




Kas see kiirus on konkreetse töölauaga või on Ubuntu ise nii kiireks tehtud ....

_________________
Olen umbkeelne mulk ja ei saa võõrastest keeltest piisavalt aru

arvomagi
Pingviini aktivist
Pingviini aktivist



Liitunud: 22.12.2007
Postitused: 164
Asukoht: Tallinn

estonia.gif
postituspostitatud: 03.02.2012, 08:04  postituse pealkiri:  (teema puudub)  

Precise varamutes on rida Esteide pakke, Ubuntu Software Center näitab neist ainult qesteidutil. Synapticu abil saab lisaks sellele paigaldada qdigidoc ja browser-plugin-esteid. Millised pakid ja mis järjekorras tuleks paigaldada? Kas opensc 0.12.1 tuleb asendada pakiga 0.12.2-esteid5? Kust selle 32- ja 64-bitist versiooni Precise jaoks tõmmata saab? Mida veel on vaja teha teada olevatest vigadest jagu saamiseks?


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 03.02.2012, 09:11  postituse pealkiri:  (teema puudub)  

arvomagi kirjutas:
Precise varamutes on rida Esteide pakke, Ubuntu Software Center näitab neist ainult qesteidutil. Synapticu abil saab lisaks sellele paigaldada qdigidoc ja browser-plugin-esteid. Millised pakid ja mis järjekorras tuleks paigaldada? Kas opensc 0.12.1 tuleb asendada pakiga 0.12.2-esteid5? Kust selle 32- ja 64-bitist versiooni Precise jaoks tõmmata saab? Mida veel on vaja teha teada olevatest vigadest jagu saamiseks?

Lõpuks peaks kõik ID-kaardi paketid paigaldatama automaatselt siis, kui süsteem lülitatakse eestikeelseks, st ise pakettide nimesid teadma ei peagi. Muidu peaks olema asi loogiline, st vaja on neid pakette, mida tahad kasutada, st kui tahad kasutada DigiDoc'i ja Nautiluse kontekstimenüüd, siis paigaldad paketi nautilus-qdigidoc, kui tahad ainult DigiDoc'i, siis lihtsalt qdigidoc, kui tahad veebis allkirjastada, siis browser-plugin-esteid jne.

Et tarkvarakeskus Qdigidoc'i ei näita, see on minu jaoks üllatav.

Vigadest jagu saamiseks tuleb need parandada. Kuna tegemist on alfastaadiumis Ubuntuga, siis ma parandamisviiside üle spekuleerima ei hakka, aga kutsun üles kõiki, kes asja jagavad, raporteerima leitud vigu ja tegema parandusettepanekuid. Hea oleks, kui saaks ID-kaardi tarkvara LTS ajaks sellisesse seisu, et kasutajal kõik lihtsalt töötab ja midagi ise putitama ei peagi.


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 31.03.2007
Postitused: 1018
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 05.02.2012, 01:34  postituse pealkiri:  (teema puudub)  

See on väga tänuväärne, et LXDE baasil ka nüüd olemas on. Ma soovin seda kindlasti kasutada ja seeläbi saan ka testimisega kaasa aidata. Mul on 20 masinat, millel 512 MB RAM - seal kulub LXDE baasil Estobuntu marjaks ära. Samas miks mitte panna ka võimsatele masinatele peale - siis jääb rohkem ressurssi päriselt vajalike rakenduste jooksutamiseks. Kasutan palju ka virtuaalmasinaid (ka mitu korraga) - siis on riistvara ressursid eriti arvel. Tõlkida võiks ka kui süsteemi käppa saab. Seni tõlgitud mõned rakendused - FreeMind, ISO Master, WiCD ja mõned pisemad asjad.


Citywalker
Uus kasutaja
Uus kasutaja



Liitunud: 01.05.2012
Postitused: 1


estonia.gif
postituspostitatud: 01.05.2012, 17:26  postituse pealkiri:  (teema puudub)  

Ubuntu 12.04 LTS 64-bit õnnestus ID-kaardiga seonduva paigaldus kenasti. Esmalt tarkvara allika lisamine (kirjeldatud http://code.google.com/p/esteid/wiki/Ubuntu).
Kood:
sudo apt-get update
andis külle seepeale veateate "W: Failed to fetch https://installer.id.ee/media/ubuntu/dists/precise/main/binary-amd64/Packages The requested URL returned error: 404", aga
Kood:
sudo apt-get install esteid
töötas sellest hoolimata korralikult, nagu ka
Kood:
sudo apt-get install nautilus-qdigidoc
. Digidoc paigaldatud ja töötab kenasti.


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 01.05.2012, 17:53  postituse pealkiri:  (teema puudub)  

Citywalker, ära sega omavahel RIA ja googlecode-i tarkvara! Kui soovid viimast kasutada, siis eemalda enne RIA oma koos varamutega ning alles siis paigalda esteid pakk.


ops

Pingviini aktivist
Pingviini aktivist


Vanus: 41
Liitunud: 23.12.2012
Postitused: 113

Distributsioon: lubuntu
estonia.gif
postituspostitatud: 31.12.2012, 11:40  postituse pealkiri:  (teema puudub)  

old style




Viimati muutis ops 15.04.2013, 15:51; muudetud 1 kord
tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 31.12.2012, 15:33  postituse pealkiri:  (teema puudub)  

ops kirjutas:
xubuntu-et.iso remastered cd tõmmis sisaldab siis ria repositooriumi id tarkvara. EN ja ET,
eemaldatud on paigaldusfailid windowsile.
Proovisin usb pealt unetbooti abiga, kuid cd-romi pole kasutanud, usb pealt boodib inglise keelena.

Kas sa seda Estobuntu servereid jms vahendeid kasutades ei tahaks teha? Märkimisväärne osa asju on meil juba olemas, väheneks vajadus jalgrattaid leiutada ja tulemus oleks eeldatavasti üldkasutatavam. XFCE töölaual põhineva versiooni lisaks seadistamine peaks olema LXDE versiooni baasil väga lihtne, kui keegi initsiatiivi üles näitaks (pole sellist inimest veel leidunud).

Kui vaja, siis siia tööversioonide hulka saaks meie serverite abil tõmmise automaatselt genereerida: http://estobuntu.itcollege.ee/images/

Eelnevalt tuleks täiendada skriptid XFCE jaoks sobivaks. Ehk siis siin all *.lxde tuleks natuke ümber teha ja veel mõnda kohta natuke täiendusi teha. Kui huvitab, siis potentsiaalsed juhendajad protsessi jaoks on irc.freenode.net kanalis #estobuntu.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group