Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
arvomagi
Pingviini aktivist
Pingviini aktivist



Liitunud: 22.12.2007
Postitused: 164
Asukoht: Tallinn

estonia.gif
postituspostitatud: 04.03.2011, 08:44  postituse pealkiri:  Ubuntu 11.04 & ID-kaart  

Ilmus Ubuntu 11.04 Alpha 3. Unity kasutajaliidese põhikomponent - ekraani vasakul serval paiknev dokk - on üsna kasutuskõlblik. LibreOffice 3.3.1 saab väikese lisavaevaga eestikeelseks. Ubuntu varamutes on videoredakror OpenShot 1.3, mis pakub palju uusi võimalusi. Lisainfot loe ubuntupingviinist.

Probleemiks on Eesti ID-kaardi tugi, kuna Natty jaoks varamuid (veel) ei ole. Kas keegi pakub toimiva lahenduse?


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 22.05.2011, 09:23  postituse pealkiri:  (teema puudub)  

Esialgsed lahendused on mõlemalt poolt olemas:

* RIA: http://support.sk.ee/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=1660
* Esteid: https://launchpad.net/~boamaod/+archive/esteid-test/


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 31.03.2007
Postitused: 1018
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 22.05.2011, 22:12  postituse pealkiri:  (teema puudub)  

RIA lahendus testitud - sai sisse nii Riigiportaali kui ka DigiDoc-i portaali ja mõlemas sai ka digiallkirja antud.

Kusjuures esteid softiga on probleemid... - testitud küll Estobuntu 10.09 peal, mis ei ole kuuldavasti puhas esteid vaid miski hübriid... Samas kasutan uusimat Firefox 4.0.1-te ja Sun JRE-d

Riigiportaali saab sisse ja digiallkirja ka antud. Samas käib digiallkirja andmine veel läbi Java kuid uus RIA soft kasutab juba oma pluginat, mis ei ole java-põhine.

Kui aga seejärel lähen kohe DigiDoc portaali siis saan ID-kaardiga sisselogimisel teateks:
Kood:
Turvalise ühenduse viga
Esines viga ühendumisel aadressiga digidoc.sk.ee.
The operation failed because the PKCS#11 token is not logged in.
(Veakood: sec_error_token_not_logged_in)


Kui Firefoxi sulgen & uuesti avan - alles siis saan sisse logida. Allkirjastamisel avaneb kõigepealt java rakenduse aken, nõustun sellega. Siis avaneb hüpikaken ja tuleb ka kohe teade: "undefined". Kui siis klõpsan "Allkirjasta" nuppu siis ei juhtu midagi.

DigiDoc kliendi juures on märgata seda, et esteid soft tahab kasutaja sekkumist (tuleb ise seadetest näidata eelnevalt käsitsi veebilehitseja abil allalaaditud sertifikaadi asukoht ning tuleb ette anda ka selle salasõna), et juurdepääsutõend paigaldada kuid uusim RIA soft teeb selle automaatselt ära - isegi mingit veebilehitsejat ei avane - mõne hetke pärast küsitakse juba PIN2-te ja olemas.

Mõlema tarkvaraga töötab ka SPR532 ehk siis pinpad-iga lugeja ja seda nii veebilehitsejas kui ka DigiDoc kliendis. Kusjuures esteid tarkvara puhul tuleb Riigiportaalis veel vanasse java-põhisesse appletisse digiallkirja andes ilma PIN2-te sisestamata vajutada nupule "Allkirjasta" ja siis alles küsitakse PIN2-te ehk siis SPR532 teeb iseloomuliku piiksu ja seejärel alles saab sisestada PIN2-te, mis ka vastu võetakse. Kui lahtrisse tahta seda sisestada siis seda ta vastu ei võta ja ei peagi võtma kuna pinpad-iga lugeja ei sisesta kunagi lahtrisse vaid otse siis kui küsitakse.

Lisaks tasub jälgida, et ka uusimad sertifikaadid Firefoxil olemas on.

Seega paistab RIA soft praegu rohkem abiks olema...


merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 155
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 23.05.2011, 13:30  postituse pealkiri:  (teema puudub)  

Proovisin esteid varianti Ubuntu 11.4-ga virtuaalmasinas. Tööle ei saanud. Ei leita kaarti lugejast: "Using reader with a card: OmniKey CardMan 3121 00 00
Failed to connect to card: Unresponsive card (correctly inserted?)"

Kaart on korralikult sees ja lugeja töökorras, Ubuntu 10.10-ga virtuaalmasinas esteid pakkidega töötab.


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 23.05.2011, 21:19  postituse pealkiri:  (teema puudub)  

merike kirjutas:
Proovisin esteid varianti Ubuntu 11.4-ga virtuaalmasinas. Tööle ei saanud. Ei leita kaarti lugejast: "Using reader with a card: OmniKey CardMan 3121 00 00
Failed to connect to card: Unresponsive card (correctly inserted?)"

Kaart on korralikult sees ja lugeja töökorras, Ubuntu 10.10-ga virtuaalmasinas esteid pakkidega töötab.

Ka mul oli Ubuntu 11.04 laivplaadiga probleem, et kaardilugejat ei leitud ja siis mingil hetkel äkki korraks leiti ja jälle kohe kaotati. Samas tarkvarauuendustega 11.04 peal töötas ilusti. Põhjus ei pruugi muidugi lihtsalt tarkvarauuendustes olla, aga see oleks esimene asi, mida proovida. Sama soovitab ka ju http://code.google.com/p/esteid/wiki/Ubuntu.

Muide, tavalise Ubuntu kasutajad peavad Nautiluse kontekstimenüü ("Allkirjasta ID-kaardiga") töötamiseks paigaldama ka paketi python-nautilus (see on seni pakendajatel kuidagi kahe silma vahele jäänud) või siis alates Natty'st on ka eraldi olemas qdigidoc-nautilus.


merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 155
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 23.05.2011, 21:37  postituse pealkiri:  (teema puudub)  

tramm kirjutas:
Ka mul oli Ubuntu 11.04 laivplaadiga probleem, et kaardilugejat ei leitud ja siis mingil hetkel äkki korraks leiti ja jälle kohe kaotati. Samas tarkvarauuendustega 11.04 peal töötas ilusti. Põhjus ei pruugi muidugi lihtsalt tarkvarauuendustes olla, aga see oleks esimene asi, mida proovida. Sama soovitab ka ju http://code.google.com/p/esteid/wiki/Ubuntu.

Mul ei ole live versioon. Virtuaalmasin on sellest ajast, kui 11.4 veel beeta oli, kõik uuendused on peale lastud. Ehk peaks nagu korralik seadistus olema, kui beetas mingeid suuremaid kalasid just ei olnud, mis edaspidist uuendamist on mõjutanud kuidagi.


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 24.05.2011, 06:33  postituse pealkiri:  (teema puudub)  

merike kirjutas:
Mul ei ole live versioon. Virtuaalmasin on sellest ajast, kui 11.4 veel beeta oli, kõik uuendused on peale lastud. Ehk peaks nagu korralik seadistus olema, kui beetas mingeid suuremaid kalasid just ei olnud, mis edaspidist uuendamist on mõjutanud kuidagi.

Proovisin huvi pärast järele ja paigaldasin puhta Ubuntu 11.04. Lisasin kõik uuendused ja paigaldasin värskelt avaldatud paketid varamust ppa:esteid/ppa. Käivitasin opensc-tool -l ja kaardilugejat ei leitud. Käivitasin lsusb ja lugeja oli kenasti näha. Tegin taaskäivituse ja opensc-tool -l näitas lugejat. Proovisin haldusvahendit, allkirrjastamist DigiDoc'is ja pangas --- kõik töötas nagu õlitatult.

Oleks võinud muidugi proovida ka paigaldust ilma uuenduste, aga taaskäivitusega.

zeroconf kirjutas:
Kusjuures esteid softiga on probleemid... - testitud küll Estobuntu 10.09 peal, mis ei ole kuuldavasti puhas esteid vaid miski hübriid... Samas kasutan uusimat Firefox 4.0.1-te ja Sun JRE-d

Riigiportaali saab sisse ja digiallkirja ka antud. Samas käib digiallkirja andmine veel läbi Java kuid uus RIA soft kasutab juba oma pluginat, mis ei ole java-põhine.

Kui aga seejärel lähen kohe DigiDoc portaali siis saan ID-kaardiga sisselogimisel teateks:
Kood:
Turvalise ühenduse viga
Esines viga ühendumisel aadressiga digidoc.sk.ee.
The operation failed because the PKCS#11 token is not logged in.
(Veakood: sec_error_token_not_logged_in)

Mida sa katsetasid üldse? Selles teemas on juttu Ubuntu väljalaskest 11.04 ja selle ID-kaardi tarkvaradest... Estobuntu 10.09 peal on aga iidvana ID-kaardi tarkvara versioon, mis peaks küll põhimõtteliselt töötama (vähemalt laivplaadilt ja kui allkirjastatakse Java'ga), aga mille seos praeguse Esteid projektiga on isegi väiksem kui selle seos RIA projektiga.


merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 155
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 24.05.2011, 20:58  postituse pealkiri:  (teema puudub)  

Mingi kotermann on selle asjaga.

Tegin uue virtuaalmasina 11.4 lõppversiooni alusel (oletusel, et eelmisega oli midagi valesti) ja paigaldasin esteid ppast natty paketid. Lõpptulemus täpselt sama, kaardilugeja tuntakse veel ära, aga kaarti lugeda ei suuda.

Proovisin siis ka väljaspool virtuaalmasinat (oletades, et äkki on mingi probleem kombinatsiooniga VirtualBox, usb ja 11.4), ja tulemus on veel kesisem. Pärast restarti näitab lugejat vaid lsusb, opensc-tool lugejat ei leia. Eelnevalt eemaldasin siis kõik id-kaardiga seotud paketid, mis mul varasemast olemas olid ja asendasin esteid ppa mavericki versiooni natty omaga.

Paistab, et tuleb veel mõnda aega 10.10 virtuaalmasinat kasutada, see on hetkel kõige töökindlam.


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 25.05.2011, 13:54  postituse pealkiri:  (teema puudub)  

merike kirjutas:
Proovisin siis ka väljaspool virtuaalmasinat (oletades, et äkki on mingi probleem kombinatsiooniga VirtualBox, usb ja 11.4), ja tulemus on veel kesisem. Pärast restarti näitab lugejat vaid lsusb, opensc-tool lugejat ei leia. Eelnevalt eemaldasin siis kõik id-kaardiga seotud paketid, mis mul varasemast olemas olid ja asendasin esteid ppa mavericki versiooni natty omaga.

Esteid arendajatega rääkides selgitati mulle, et tegemist võiks olla libccid paketi puudujäägiga. Nimelt ei uuendata ID-kaardi pakette esmakordselt paigaldades udev reegleid USB kaardilugejate jaoks (see on seotud asjaoluga, et Natty's muudeti vastavate kasutajate/õiguste struktuuri).

Et asja lahendada on vaja kas

* teha taaskäivitus (mille tulemusel peaks kõik ilusti uuendatama ja tööle hakkama)
* või anda käsklus udevadm control --reload-rules ning kaardilugeja uuesti USB-porti ühendada.

Niimoodi sain mina Natty Live-CD peal igatahes asja veatult käima.


pisi
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 09.07.2007
Postitused: 65
Asukoht: Eesti
Distributsioon: Debian / Darwin
estonia.gif
postituspostitatud: 25.05.2011, 15:50  postituse pealkiri:  (teema puudub)  

merike kirjutas:

Paistab, et tuleb veel mõnda aega 10.10 virtuaalmasinat kasutada, see on hetkel kõige töökindlam.


Windowsil pole 10.10 versiooni. Windowsil on versioon 7. See on kõige töökindlam.

Ärge näkku lööge...

_________________
pisi - muidumees ja maailmaparandaja
@MartinPaljak.net

asjameez
Vana Pingviin
Vana Pingviin


Vanus: 29
Liitunud: 09.03.2007
Postitused: 428
Asukoht: Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 25.05.2011, 17:08  postituse pealkiri:  (teema puudub)  

pisi kirjutas:
merike kirjutas:

Paistab, et tuleb veel mõnda aega 10.10 virtuaalmasinat kasutada, see on hetkel kõige töökindlam.


Windowsil pole 10.10 versiooni. Windowsil on versioon 7. See on kõige töökindlam.

Ärge näkku lööge...

Mis see Windows siia puutub?

_________________
"Dumbusers use Windows. Powerusers use Linux. Dumbusers who think they are powerusers use Mac."

merike
Pingviini aktivist
Pingviini aktivist



Liitunud: 06.04.2007
Postitused: 155
Asukoht: Laagri/Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 25.05.2011, 23:06  postituse pealkiri:  (teema puudub)  

tramm kirjutas:

Et asja lahendada on vaja kas

* teha taaskäivitus (mille tulemusel peaks kõik ilusti uuendatama ja tööle hakkama)
* või anda käsklus udevadm control --reload-rules ning kaardilugeja uuesti USB-porti ühendada.

Niimoodi sain mina Natty Live-CD peal igatahes asja veatult käima.

Mul paraku kumbki neist olukorda ei lahendanud. Ju on midagi veel valesti. Ühel juhul leidsin, et pcscd ei käivitu korralikult millegipärast, põhjust pole veel tuvastanud. Võimalik, et praegune paigaldus ongi kuskilt mujalt katki ja oleks mõistlik (ajalise töömahu mõttes vähemalt) nullist uuesti paigaldada. Tegemist siiski upgrade (mis küllalt sageli päris korralikult ei tööta) läbinud süsteemiga ja on siin ka igasuguseid beeta jm test reposid kasutuses olnud. Mavericki ajal oli asi seadistatud töötama hoopis PCMCIA lugejaga, nii et võib-olla ka sellest midagi segavat jäänud.
Virtuaalmasina puhul mõtteid ei ole, nii 10.10 kui kui 11.4 on samamoodi seadistatud, aga tulemus on erinev.


Cancer
Pingviini kasutaja
Pingviini kasutaja


Vanus: 44
Liitunud: 14.10.2007
Postitused: 76

Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 28.05.2011, 22:56  postituse pealkiri:  (teema puudub)  

Küsimus, et millist JRE-d kasutada, kui seda enam üldse vaja on? IMO OpenJDK ja Java JRE on nagu siga ja kägu!?!


tramm
Vana Pingviin
Vana Pingviin



Liitunud: 03.11.2008
Postitused: 897

Distributsioon: *buntu
blank.gif
postituspostitatud: 29.05.2011, 11:24  postituse pealkiri:  (teema puudub)  

Cancer kirjutas:
Küsimus, et millist JRE-d kasutada, kui seda enam üldse vaja on? IMO OpenJDK ja Java JRE on nagu siga ja kägu!?!

Javat ei ole enam üldse vaja, tasub jälgida täpseid juhiseid kasutatavate projektide lehtedel.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group