Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 17.04.2009, 08:49  postituse pealkiri:  (teema puudub)  

root@kodu:~# sudo ls -l /dev/raw*
crw-rw---- 1 root disk 171, 0 2009-04-17 07:14 /dev/raw1394


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 17.04.2009, 08:55  postituse pealkiri:  (teema puudub)  

Paistab, et kasutajal pole seadmele ligipääsuõigust, seal ilmselt see kala peidus ongi.Tundub, et pead lisama kasutaja "disk" gruppi kui ta seal pole või siis muutma seadme õigusi.

_________________
IT teenused

wk
Vana Pingviin
Vana Pingviin



Liitunud: 24.10.2007
Postitused: 1133
Asukoht: Tallinn, vahel Vastseliina vald
Distributsioon: Debian, Kubuntu
estonia.gif
postituspostitatud: 17.04.2009, 09:09  postituse pealkiri:  (teema puudub)  

Lisaks veel, et pärast gruppi lisamist tuleb korraks välja ja uuesti sisse logida.

_________________
Kõike hääd,
WK

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 17.04.2009, 14:14  postituse pealkiri:  (teema puudub)  

obundra kirjutas:
Paistab, et kasutajal pole seadmele ligipääsuõigust, seal ilmselt see kala peidus ongi.Tundub, et pead lisama kasutaja "disk" gruppi kui ta seal pole või siis muutma seadme õigusi.

Ma olen ikka juhm. Kus ma saan kasutajat "disk" gruppi lisada?
Kas see on Süsteemi seadistused-Advanced-ketas ja failisüsteemid- sel on ainult kõvakas , burner ja mälupulk näha.


sander85
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 17.04.2009, 14:22  postituse pealkiri:  (teema puudub)  

jaakeensalu kirjutas:
obundra kirjutas:
Paistab, et kasutajal pole seadmele ligipääsuõigust, seal ilmselt see kala peidus ongi.Tundub, et pead lisama kasutaja "disk" gruppi kui ta seal pole või siis muutma seadme õigusi.

Ma olen ikka juhm. Kus ma saan kasutajat "disk" gruppi lisada?
Kas see on Süsteemi seadistused-Advanced-ketas ja failisüsteemid- sel on ainult kõvakas , burner ja mälupulk näha.


http://kudos.berlios.de/kf/kisimlar/useradmin.html#kuser ehk sellest juhendist midagi abi, idee poolest peaksid muutma siis oma kasutaja seadeid, mitte ketta seadeid

_________________
Image Image Image

hr.john
Pingviini aktivist
Pingviini aktivist



Liitunud: 12.06.2006
Postitused: 181
Asukoht: Eesti

kiribati.gif
postituspostitatud: 17.04.2009, 14:30  postituse pealkiri:  (teema puudub)  

jaakeensalu kirjutas:
obundra kirjutas:
Paistab, et kasutajal pole seadmele ligipääsuõigust, seal ilmselt see kala peidus ongi.Tundub, et pead lisama kasutaja "disk" gruppi kui ta seal pole või siis muutma seadme õigusi.

Ma olen ikka juhm. Kus ma saan kasutajat "disk" gruppi lisada?
Kas see on Süsteemi seadistused-Advanced-ketas ja failisüsteemid- sel on ainult kõvakas , burner ja mälupulk näha.


root kasutajana editeerid /etc/group faili Wink
Applications -> System -> Users ang Groups


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 17.04.2009, 14:39  postituse pealkiri:  (teema puudub)  

Pole vaja mingit faili editeerida.Lihtsalt terminalis ütled:
Kood:
sudo usermod -G disk sinukasutajanimi

ja peale uuesti sisselogimist hakkavad selle grupi õigused kasutajale külge.

_________________
IT teenused

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 17.04.2009, 16:03  postituse pealkiri:  (teema puudub)  

obundra kirjutas:
Pole vaja mingit faili editeerida.Lihtsalt terminalis ütled:
Kood:
sudo usermod -G disk sinukasutajanimi

ja peale uuesti sisselogimist hakkavad selle grupi õigused kasutajale külge.

jessss! Nii ma tegin ja Kino hakkas kohe kaamerat mängitama . Suurim tänu ja loodan , et ehk on sellest kogemusest kasu ka mõnel teisel.


jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 04.05.2009, 09:04  postituse pealkiri:  Äkki saab ka siin abi  

Video sain käima aga digikast pilte ikka arvutisse ei saa. Saab aru küll , et olympus on aga nii minuti pärast peale kataloogi laadimist tuleb akna alla
Faili Could not lock the device lugemine ebaõnnestus.
Äkki on siin ka nii , tuleb üks rida konsooli lisada ja kõik töötab?


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 04.05.2009, 09:19  postituse pealkiri:  (teema puudub)  

Mis digika mudeliga tegu?Enne digika ühendamist terminali
Kood:
tail -f /var/log/messages
ja vaata mida sinna räägib kui digika sappa ühendad.

_________________
IT teenused

Sisyphos
Vana Pingviin
Vana Pingviin


Vanus: 57
Liitunud: 24.02.2008
Postitused: 602

Distributsioon: Slackware
estonia.gif
postituspostitatud: 04.05.2009, 09:22  postituse pealkiri:  (teema puudub)  

Vast on olympusel ka nii nagu minu nikonil , et saab valida usb-mode'i ja PTP-mode'i vahel.
Mina kasutan usb-mode'i ja minu nikon paistab linuxile tavalise usb-mälupulgana.

_________________
Image

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 04.05.2009, 10:00  postituse pealkiri:  (teema puudub)  

Olympusel on valik PC, print ja exit. Andmekandjate aknas on fotokas ilusti olemas . Tundub , at arvuti näeb teda USB mass storage interface. Aparaat on Olympus FE-100
jaak@kodu:~$ $ tail -f /var/log/messages
bash: $: command not found
Miskit sellist vastati konsoolis.
kirjutasin uuesti ja
jaak@kodu:~$ tail -f /var/log/messages
tail: ei õnnestu avada `/var/log/messages' lugemiseks: Permission denied
tail: rohkem faile pole


Sisyphos
Vana Pingviin
Vana Pingviin


Vanus: 57
Liitunud: 24.02.2008
Postitused: 602

Distributsioon: Slackware
estonia.gif
postituspostitatud: 04.05.2009, 10:06  postituse pealkiri:  (teema puudub)  

Tee seda rooduna:
Kood:
sudo tail -f /var/log/messages


Kas käsitsi ei saa haakida seda usb mass storage device'i ?

_________________
Image

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 04.05.2009, 10:17  postituse pealkiri:  (teema puudub)  

Nüüd tuli päris pikk jutt
oot@kodu:~# sudo tail -f /var/log/messages
May 4 10:04:24 kodu kernel: [ 8931.844325] usb 3-2: configuration #1 chosen from 1 choice
May 4 10:04:24 kodu kernel: [ 8931.865566] scsi5 : SCSI emulation for USB Mass Storage devices
May 4 10:08:58 kodu kernel: [ 9206.435696] usb 3-2: USB disconnect, address 5
May 4 10:09:11 kodu kernel: [ 9219.022533] usb 3-2: new full speed USB device using ohci_hcd and address 6
May 4 10:09:11 kodu kernel: [ 9219.235639] usb 3-2: configuration #1 chosen from 1 choice
May 4 10:09:11 kodu kernel: [ 9219.245857] scsi6 : SCSI emulation for USB Mass Storage devices
May 4 10:10:56 kodu kernel: [ 9324.149512] usb 3-2: USB disconnect, address 6
May 4 10:15:40 kodu kernel: [ 9607.713855] usb 3-2: new full speed USB device using ohci_hcd and address 7
May 4 10:15:40 kodu kernel: [ 9607.925783] usb 3-2: configuration #1 chosen from 1 choice
May 4 10:15:40 kodu kernel: [ 9607.946587] scsi7 : SCSI emulation for USB Mass Storage devices


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 04.05.2009, 11:50  postituse pealkiri:  (teema puudub)  

Kood:
sudo fdisk -l

peaks näitama kõiki süsteemis olevaid kettaid, fotokas võiks olla näiteks /dev/sdb või mingi sarnase seadmena.

_________________
IT teenused

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 04.05.2009, 12:14  postituse pealkiri:  (teema puudub)  

jaak@kodu:~$ sudo fdisk -l

Disk /dev/sda: 30.7 GB, 30750031872 bytes
255 heads, 63 sectors/track, 3738 cylinders
Units = silindrit of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd76cd76c

Seade Boot Start End Blocks Id System
/dev/sda1 * 1 3645 29278431 83 Linux
/dev/sda2 3646 3738 747022+ 5 Extended
/dev/sda5 3646 3738 746991 82 Linux swap / Solaris
tuli vastuseks


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 04.05.2009, 12:55  postituse pealkiri:  (teema puudub)  

Tundub, nagu ei leiaks kettana fotoka mälukaarti.Pista fotokas külge, vali fotokal PC ja terminali ütle
Kood:
dmesg| tail -n 50

ehk on sealt näha mis talle ei meeldi.

_________________
IT teenused

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 04.05.2009, 13:24  postituse pealkiri:  (teema puudub)  

[ 9813.920803] usb 3-2: configuration #1 chosen from 1 choice
[ 9813.941240] scsi8 : SCSI emulation for USB Mass Storage devices
[ 9813.943363] usb-storage: device found at 8
[ 9813.943373] usb-storage: waiting for device to settle before scanning
[ 9838.263577] usb 3-2: USB disconnect, address 8
[ 9920.065298] usb 4-3: new high speed USB device using ehci_hcd and address 10
[ 9920.199229] usb 4-3: configuration #1 chosen from 1 choice
[ 9920.219946] scsi9 : SCSI emulation for USB Mass Storage devices
[ 9920.225621] usb-storage: device found at 10
[ 9920.225631] usb-storage: waiting for device to settle before scanning
[ 9925.222975] usb-storage: device scan complete
[ 9925.224088] scsi 9:0:0:0: Direct-Access ST316081 5A 0014 PQ: 0 ANSI: 0
[ 9925.241061] sd 9:0:0:0: [sdb] 312581808 512-byte hardware sectors (160042 MB)
[ 9925.242700] sd 9:0:0:0: [sdb] Write Protect is off
[ 9925.242710] sd 9:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 9925.242713] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 9925.244543] sd 9:0:0:0: [sdb] 312581808 512-byte hardware sectors (160042 MB)
[ 9925.245676] sd 9:0:0:0: [sdb] Write Protect is off
[ 9925.245686] sd 9:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 9925.245690] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 9925.245702] sdb: sdb1 < sdb5 >
[ 9925.269840] sd 9:0:0:0: [sdb] Attached SCSI disk
[ 9925.269929] sd 9:0:0:0: Attached scsi generic sg2 type 0
[10024.716625] usb 4-3: USB disconnect, address 10
[10024.755122] Buffer I/O error on device sdb5, logical block 786433
[10024.755526] Buffer I/O error on device sdb5, logical block 786433
[10024.824239] Buffer I/O error on device sdb5, logical block 786433
[10024.854769] Buffer I/O error on device sdb5, logical block 786433
[10025.079976] Buffer I/O error on device sdb5, logical block 786433
[10112.764179] audit(1241421845.752:3): type=1503 operation="inode_permission" requested_mask="::rw" denied_mask="::rw" name="/dev/tty" pid=7450 profile="/usr/sbin/cupsd" namespace="default"
[16037.353212] audit(1241427773.161:4): type=1503 operation="inode_permission" requested_mask="::rw" denied_mask="::rw" name="/dev/tty" pid=8859 profile="/usr/sbin/cupsd" namespace="default"
[16538.845301] usb 3-2: new full speed USB device using ohci_hcd and address 9
[16539.057267] usb 3-2: configuration #1 chosen from 1 choice
[16539.060319] scsi10 : SCSI emulation for USB Mass Storage devices
[16539.061286] usb-storage: device found at 9
[16539.061297] usb-storage: waiting for device to settle before scanning
[16544.066874] usb-storage: device scan complete
[16544.081910] scsi 10:0:0:0: Direct-Access OLYMPUS FE100/X710 PQ: 0 ANSI: 0 CCS
[16544.093873] sd 10:0:0:0: [sdb] 512000 512-byte hardware sectors (262 MB)
[16544.106894] sd 10:0:0:0: [sdb] Write Protect is off
[16544.106904] sd 10:0:0:0: [sdb] Mode Sense: 00 06 00 00
[16544.106909] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[16544.144609] sd 10:0:0:0: [sdb] 512000 512-byte hardware sectors (262 MB)
[16544.161837] sd 10:0:0:0: [sdb] Write Protect is off
[16544.161848] sd 10:0:0:0: [sdb] Mode Sense: 00 06 00 00
[16544.161852] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[16544.161868] sdb: sdb1
[16544.172023] sd 10:0:0:0: [sdb] Attached SCSI removable disk
[16544.172128] sd 10:0:0:0: Attached scsi generic sg2 type 0
[16828.067532] usb 3-2: USB disconnect, address 9

Nüüd tuli väga pikk jutt


obundra
Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 05.05.2009, 09:14  postituse pealkiri:  (teema puudub)  

Proovi käsitsi ühendada
Kood:
sudo mount -t vfat /dev/sdb1 /mnt/sdb

enne ilmselt pead /mnt alla looma kataloogi sdb
Kood:
sudo mkdir /mnt/sdb

kui niimoodi toimib, siis võib udev reeglites mingi kala olla.

_________________
IT teenused

jaakeensalu
Pingviini aktivist
Pingviini aktivist


Vanus: 55
Liitunud: 02.12.2008
Postitused: 186
Asukoht: Otepää

estonia.gif
postituspostitatud: 05.05.2009, 17:37  postituse pealkiri:  (teema puudub)  

jaak@kodu:~$ sudo mkdir /mnt/sdb
[sudo] password for jaak:
jaak@kodu:~$ sudo mount -t vfat /dev/sdb1 /mnt/sdb
mount: special device /dev/sdb1 does not exist
Ja ei midagi. Naise windosa läpakas võtab kohe kui usb seadme taha ja pildid tulevad ludinal. Nii , et aparaat päris peetis ei saa olla


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group