Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
sips
Pingviini aktivist
Pingviini aktivist



Liitunud: 20.05.2006
Postitused: 288

Distributsioon: Arch
estonia.gif
postituspostitatud: 09.04.2007, 12:59  postituse pealkiri:  Alsa juhtimine gnome-volume-manageriga  

Tuli kah tahtmine gentood proovida..

Esimesel päeval instaleerisin portage, genkernel'i, grub'i ja gnome-light'i, mis lõppes sellega, et juhe koos, manual sagamini ja x pilti ette ei võta.

Teisel päeval alustasin kõike nullist, seekord intallisin enne baasi, x'i ja ati kraami (ilma make.confi lipukesi määramata ja x'i confi tegin nö. --textmode's, misjärel modisin tulemust ka nanos (1280x1024->1280x800) )
ning alles siis gnome-light'i (lipukestega USE="-qt3 -qt4 -arts -kde gtk gnome hal avahi")
ja sellega asi lõppes. Aaa... nö. tavakasutaja tekitasin ka.

Kolmanda päeva hommikul panin tuhinaga masina käima ja oh seda rõõmu... buudib kiiresti ühegi veateateta ja peale sisselogimist ning startx'i ongi puhas gnome töölaud ees.

OK, siinkohal tutvustaks oma käru:
Aceri läpakas: Aspire 3100 (AMD64 Mobile Sempron)
OS: Gentoo-2.6.19-r5 (genkernel)
Wifi kaart: Atheros (madwifi aitas)
Heli kaart: ATI Technologies Inc SB450 HDA Audio (driver: hda-intel) .. ja siin ongi minu hambavalu!

Mis ma siis kolmandal päeval tegin?
Paigaldasin madwifi ja kuna see ei andnud teada ühestki vast, lugesin selle sammu lõpenuks (mida ta ka oli, kui välja arvata paar katset instaleerida networkmanager, mis osutus suht võimatuks (alternatiivina hetkel wifi-radar)).
Ülejäänud 10-11 tundi (tööpaev mul 12h) tegelesin heilga..
Esimesel katsel kompileerisin kerneli koos alsa toega ja tulemus oli peaaegu rahuldav, st. driverid vähe bugised.
E. kui masin käivitada, siis tuleb heli ainult paremast kanalist, peale seda kui h.mikseris vähe heebleid liigutada hakkab tööle ka vasak kanal. (Sama jama oli ka opensuse 10.1'l, kuid opensuse 10.2'l oli see viga parandatud).
Niisiis arvasin, et gentoo kernelisse pole veel piisavalt uuendusi siise viidud ja otsustasin, et installin alsa-driverid väljaspoole tuuma (uus genkernel --menuconfig ilma alsa'ta ja eralid emerge alsa-driveritele), tulemus täpselt sama (osa kanaleid alguses puudu).
Ok, mõtlesin, et kui nii, siis nii - eks spean lepima nende jooksutajatega mis on ja ootan uuendusi.
Kuid sellega asi ei piirdund, nimelt ei oksa gnome-volume-manager alsa'ga ühendust võtta,
kui soovin g-menüüst käivitada Volume Control'i siis see karjub, et gstreameril puuduvad vastavad pluginad ja/või ei leia ta seadet.
Ja siis sai linuxi võlusid nautida: päev otsa /gentoo-wiki, google, gentoo-forum, emerge, nano \/etc(\/..)?\/.., emerge --unmerge../ jne.
Gnome Volume Control'i poole pöördudes tulemus ikka sama: "No volume control GStreamer plugins and/or devices found".

Olen katsetanud kümneid varjante, igasugu gst-plugins-alsa, gst-plugins, gst-plugins-base ja muid seda sorti pakke,
igasugu graafilised confid läbi käind, gnome-configurationis foorumite õpetustes järgi vajalikud ossjurad alsajurad'eks muutnud..

Viimases foorumis, mida lugesin räägiti sellest kuidas gnome paigaldamisel tuleks USE lipukestes kindlasti ära märkida -oss, muidu imeb gnome endale oss'i sisse ja siis on pärast jama.
Proovisin siis uuest "emerge gnome-light" (USE'le -oss lisatud), kuid ei instaleeritud mule midagi uut (gnome-light vist vaatas üle, et kõik "vajalik" on olemas ja asi vaska).

Neljas päev, suur mure: mis teha?
Alustan jälle algusest (vanade partatsioonide kustutamine)?
Või on võimalus, et gnome-volume-manager leiab kuidagi ka alsa?
Annab ehk uuest mergeda juba olemasolevad pakid (kasutades viimaseid USE lippe (sh. -oss))?

Vabandan, kui väga segast panen, kuid mu gentoo kogemus pole just eriti pikk Sad


sips
Pingviini aktivist
Pingviini aktivist



Liitunud: 20.05.2006
Postitused: 288

Distributsioon: Arch
estonia.gif
postituspostitatud: 09.04.2007, 15:57  postituse pealkiri:  (teema puudub)  

ja tundub, et see on alles algus...

Vaatasin, et kuidagi seisab mingi internei-ühendus üleval,
et siis võiks oma töö dokumendid üle vaadata (oo.org),

kriban siis ruuduna konsooli "emerge -av openoffice", alguses on kõik ok, kuid mingi aga pärast leian terminali aknast teataande
"
!!! ERROR: dev-libs/STLport-5.1.2 failed.
Call stack:
ebuild.sh, line 1614: Called dyn_compile
ebuild.sh, line 971: Called qa_call 'src_compile'
environment, line 3567: Called src_compile
STLport-5.1.2.ebuild, line 79: Called die

!!! Compile failed
"



Kui esmamulje gentoost oli ilgelt positiivne (kuigi, näpukad ikka sees, huu geers), siis nüüd hakkab minu arvamus muutuma.

Tundub, et tuleb (paljusid ei huvita millega ma töötan) tagasi vanale töötavale susele ronida,
kuigi vahepeal (petlikud esmamuljaed gentoost) tekkis tahtmine kustada oma arhiivist kõik,
mis sisaldab sõna suse ... ja , et hakkan õnnelikuks gentoo user'iks ... ,
kuid kahjuks see viimane tundub/on võimatu Sad (tahaks/vajadus nagu rohkem arvutit kasutada, mitte, ei tea mida, kompileerida)
Ohh.. Kurb, väga kurb..

Samas on väga oodatud kõigi gentoo kasutajatate/fännide vastuväited ja igasugu genToo promod,
sest ei tahks nagu nii kergelt loobuda.
Ning keegi võiks lahti seletada mis põhjusel ei saa emergeda kaasaegset softi,
ma ei nõua ju viimast sofit vaid kriban lihtsalt emerge openoffice.

tänks,
Sips


nüüd avastasin, et läpaka hiire-padja scroll ka ei tööta...
tundub, et järjest hullemaks läheb Sad


kui siin veel kaua istuda, siis võiks gentoo puudulikusest raamatu kirjutada.

huvitav, kui palju on neid, kes samaaegselt armastavad ja vihkavad ,mingit, üht ja sama leiutist ??


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2547
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 09.04.2007, 16:48  postituse pealkiri:  (teema puudub)  

OpenOffice puhul kasutaksid ehk binaar pakki?
Ikkagi paarsada MB vaja kokku lasta ja see võtab üsna palju aega.
BIN pakk palju lihtsam peale panna.

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

HoHo
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 08.07.2005
Postitused: 527
Asukoht: Tallinn/Paide
Distributsioon: Gentoo
estonia.gif
postituspostitatud: 09.04.2007, 17:34  postituse pealkiri:  (teema puudub)  

Tsitaat:
Annab ehk uuest mergeda juba olemasolevad pakid (kasutades viimaseid USE lippe (sh. -oss))?
Puudub vajalik keyword: --newuse aka -N
man emerge sisaldab päris palju kasulikku infot, võimalik et wikis on asjad veelgi paremini lahti seletatud.

Loodan et useflagid paned kirja kas make.conf'i globaalseks kasutamiseks või /etc/portage/packages.use faili/kataloogi per-pakett kasutamiseks. Käsurealt ette andmine on saadanast
Tsitaat:
!!! ERROR: dev-libs/STLport-5.1.2 failed.
Paraku on tegelik veateade mõned read üleval pool, see info ei ütle midagi kasulikku.
Tsitaat:
Ning keegi võiks lahti seletada mis põhjusel ei saa emergeda kaasaegset softi,
ma ei nõua ju viimast sofit vaid kriban lihtsalt emerge openoffice.
Kui tõesti kavatsed OOo ise kokku lasta varu minimaalselt 768M rami ning ~5GiB kõvakettaruumi /var/tmp/portage kataloogis. Alla selle see ei õnnestu. Lisaks kulub selle kokku laskmiseks su masinal oma pool päeva kindlasti Smile
Teiseks tahaks näha täielikku veateadet, ehk raalib sealt välja milles probleem.
Kolmandaks soovitan kasutada OOo binaarpaketti, openoffice-bin. Too on funktsionaalsuse poolest võrdeline käsitsi kompileerituga kuid installeerub märksa lihtsamalt.


Endal läks Gentooga alustamine isegi keerukamalt, nädal enne kui graafilise ette sain, teine enne 3d ja heli tööle saamist. Samas kui asja juba kord tööle sain siis õhku see niisama lihtsalt ei lenda. varsti peaks olema staa%u017Ei ~3.5a ning siiani ei kahetse.


nick
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 01.08.2005
Postitused: 39
Asukoht: Tartu
Distributsioon: Gentoo/FreeBSD/Xubuntu
estonia.gif
postituspostitatud: 09.04.2007, 22:13  postituse pealkiri:  (teema puudub)  

http://forums.gentoo.org/viewtopic.php?p=1060314#1060314


sips
Pingviini aktivist
Pingviini aktivist



Liitunud: 20.05.2006
Postitused: 288

Distributsioon: Arch
estonia.gif
postituspostitatud: 11.04.2007, 19:25  postituse pealkiri:  (teema puudub)  

tänud,

openoffice-bin töötab ilusti.

intsallisin üle alsa-headersi, alsa-driveri ja alsa-utilsi (viimased testing stadiumis olevad pakid) lootes, et kaob ära see jama, et alguses tuleb heli ühest kanalist, aga oh imet, isegi gnome-volume-manager hakkas tööle.

nüüd on lugu, nii et igasugu muusika ja filmide heli on olemas,
kuid puuduvad gnome desktopi helid (gnome-audio on paigaldatud ja system->preferences->audio all on kah nagu kõik paigas).
ehk on puudu mingi player, mis neid wave mängima peaks?

samuti ei saa hakkama kohaliku võrguga e. siis File Browseris minnes aadressile network:/// avaneb tühi leht.
ei kujuta ettegi, mida selleks vaja võib minna,
nii igaks juhuks emergesin nfs-utilsi ja samba, kuid nende seadistamine on ka tühi auk.
ise olen nagu rohkem php'd kriband, igasuguse võrgu seadistamise olen asjatundjatele jätnud.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group