Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 22.02.2014, 12:31  postituse pealkiri:  Täpitähtede probleem Kubuntu failinimedes.  

Kasutan Kubuntut nüüd juba järjest umbes aastajagu ning olen saanud ta enese jaoks niikaugele, et kõik on nii nagu "peab" (winilt üleminek on harjumatu paljudele). Ainus asi, mida pole suutnud lahendada on errorid täpitähtedega failinimedes. Näiteks kui üritan thunderbirdis avada manust: Tööde list.pdf siis tuleb error: could not open - failinimes on täpitähed mingid muud sümbolid. Kui salvestan faili eelnevalt arvutisse, siis laseb avada. Samuti ei õnnestu Libre Office-s salvestada täpitähtedega failinime. Muusikafailides on muutunud (algusest peale) täpitähed muudeks sümboliteks ja kui salvestan mõne õigete tähtedega muusikafaili, siis ei lase seda avata. Samas just proovisin üht nime õigeks tagasi muuta- muutus ja avas samuti. Süsteemikeel on eesti, samuti klaveri layout.
Kas on kellelgi aimu, kustpoolt viga otsida? Suht segane jutt jäi Confused
SYSTEM INFORMATION
Running Ubuntu Linux, the Ubuntu 13.10 (saucy) release.
GNOME: unknown (unknown)
Kernel version: 3.11.0-17-generic (#31-Ubuntu SMP Mon Feb 3 21:53:31 UTC 2014)
GCC: no gcc detected
Xorg: 1.14.5 (17 December 2013 10:03:52AM) (17 December 2013 10:03:52AM)


sander85
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 22.02.2014, 16:23  postituse pealkiri:  (teema puudub)  

Mis käsu locale väljund on?

_________________
Image Image Image

hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 22.02.2014, 17:18  postituse pealkiri:  (teema puudub)  

sander85 kirjutas:
Mis käsu locale väljund on?
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
Kui see on see, mida silmas pidasid


sander85
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 22.02.2014, 21:31  postituse pealkiri:  (teema puudub)  

See on see jah. Ja tulemus on selline nagu ma kartsin. ISO-8859-1 asemel oleks tahtnud näha UTF-8, paraku ei tea ma, et kuidas täpselt seda antud buntu peal muuta üldse saab, nii et tulemus poleks päris fataalne. Ehk oskavad buntu kasutajad ses osas nõu anda..

_________________
Image Image Image

muhv
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 03.03.2009
Postitused: 248
Asukoht: Pärnu
Distributsioon: Debian+
estonia.gif
postituspostitatud: 23.02.2014, 10:55  postituse pealkiri:  (teema puudub)  

Proovi
Kood:
sudo locale-gen et_EE.UTF-8
sudo dpkg-reconfigure locales
sudo LANG=et_EE.UTF-8 LANGUAGE=et_EE.UTF-8 update-locale


Allikas:
http://askubuntu.com/questions/76013/how-do-i-add-locale-to-ubuntu-server
http://blog.toxa.de/archives/535

Aga üldine soovitus oleks mitte kasutada täpitähti failinimedes. Eriti digiallkirjastamisel kus olen nii mõnelgi win-mac-linux kasutajatel probleeme näinud allkirjastatud dokumentide edastamisel (see viga on kirjeldatud ka ID kodulehel). Kes teab, mis kodeering (ANSI,UTF,ISO...) ning missugune keeletugi kuskil masinas on eriti kui on vaja teistele ka faili saata.


hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 23.02.2014, 12:53  postituse pealkiri:  (teema puudub)  

Muud polegi häda, kui vaid see et mulle tuleb palju tööalaseid meile manustega ning tihti on need täpitähtedega. Tüütu on iga kord neid salvestada, et siis korraks vaadata. Tööandjale pole ju mõtet öelda, et tee ilma täppideta nimed, ta ütleb et kasuta siis windowsi Smile
Kasutan pdf avamiseks okulari, vb peaks midagi muud proovima?

raimz@raimz-kubuntu:~$ sudo dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "et:en",
LC_ALL = (unset),
LANG = "et_EE.ISO-8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AG.UTF-8... done
en_AU.UTF-8... done
en_BW.UTF-8... done
en_CA.UTF-8... done
en_DK.UTF-8... done
en_GB.UTF-8... done
en_HK.UTF-8... hash collision (1688509771) en_HK.utf8, de_CH.utf8
failed
en_IE.UTF-8... done
en_IN.UTF-8... done
en_NG.UTF-8... done
en_NZ.UTF-8... done
en_PH.UTF-8... done
en_SG.UTF-8... done
en_US.UTF-8... done
en_ZA.UTF-8... done
en_ZM.UTF-8... done
en_ZW.UTF-8... done
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo LANG=et_EE.UTF-8 LANGUAGE=et_EE.UTF-8 update-locale
raimz@raimz-kubuntu:~$
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$


sander85
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 23.02.2014, 13:02  postituse pealkiri:  (teema puudub)  

Ma ei näe, et sa oleks esimese muhvi poolt välja toodud käsu ka sisestanud. Ehk siis sudo locale-gen et_EE.UTF-8 jäi käivitamata?

_________________
Image Image Image

hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 23.02.2014, 13:23  postituse pealkiri:  (teema puudub)  

Tegin uuesti läbi igaks juhuks:

raimz@raimz-kubuntu:~$ sudo locale-gen et_EE.UTF-8
[sudo] password for raimz:
Generating locales...
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "et:en",
LC_ALL = (unset),
LANG = "et_EE.ISO-8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AG.UTF-8... done
en_AU.UTF-8... done
en_BW.UTF-8... done
en_CA.UTF-8... done
en_DK.UTF-8... done
en_GB.UTF-8... done
en_HK.UTF-8... hash collision (1688509771) en_HK.utf8, de_CH.utf8
failed
en_IE.UTF-8... done
en_IN.UTF-8... done
en_NG.UTF-8... done
en_NZ.UTF-8... done
en_PH.UTF-8... done
en_SG.UTF-8... ^[[B^[[B^[[Bdone
en_US.UTF-8... done
en_ZA.UTF-8... done
en_ZM.UTF-8... done
en_ZW.UTF-8... done
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo LANG=et_EE.UTF-8 LANGUAGE=et_EE.UTF-8 update-locale
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 23.02.2014, 13:43  postituse pealkiri:  (teema puudub)  

Vanakooli meetod oleks /etc/locale.gen (vähemalt nii on faili nimi debianis) faili käsitsi muuta ja siis locale-gen teha. Ehk ava oma lemmik redaktoriga juurika õigustes antud fail, kommenteeeri välja ainult soovitud lokaat - et_EE.UTF-8 - kõikidele teistele trellid # ette ja siis
sudo locale-gen
ning logi välja/sisse või tee reboot... kuidas soovid.


muhv
Pingviini aktivist
Pingviini aktivist


Vanus: 47
Liitunud: 03.03.2009
Postitused: 248
Asukoht: Pärnu
Distributsioon: Debian+
estonia.gif
postituspostitatud: 23.02.2014, 19:55  postituse pealkiri:  (teema puudub)  

hjuumen kirjutas:
Tegin uuesti läbi igaks juhuks:

raimz@raimz-kubuntu:~$ sudo locale-gen et_EE.UTF-8
[sudo] password for raimz:
Generating locales...
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "et:en",
LC_ALL = (unset),
LANG = "et_EE.ISO-8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AG.UTF-8... done
en_AU.UTF-8... done
en_BW.UTF-8... done
en_CA.UTF-8... done
en_DK.UTF-8... done
en_GB.UTF-8... done
en_HK.UTF-8... hash collision (1688509771) en_HK.utf8, de_CH.utf8
failed
en_IE.UTF-8... done
en_IN.UTF-8... done
en_NG.UTF-8... done
en_NZ.UTF-8... done
en_PH.UTF-8... done
en_SG.UTF-8... ^[[B^[[B^[[Bdone
en_US.UTF-8... done
en_ZA.UTF-8... done
en_ZM.UTF-8... done
en_ZW.UTF-8... done
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo LANG=et_EE.UTF-8 LANGUAGE=et_EE.UTF-8 update-locale
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$


Tee nagu ennem näitasin aga jäta seekord "sudo dpkg-reconfigure locales" ära nii et kaks käsku ainult. Miis ta siis teeb


hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 25.02.2014, 08:12  postituse pealkiri:  (teema puudub)  

raimz@raimz-kubuntu:~$ sudo locale-gen et_EE.UTF-8
[sudo] password for raimz:
Generating locales...
et_EE.UTF-8... up-to-date
Generation complete.
raimz@raimz-kubuntu:~$ sudo LANG=et_EE.UTF-8 LANGUAGE=et_EE.UTF-8 update-locale
raimz@raimz-kubuntu:~$
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$

Ei muutunud suurt midagi.
Mida see "vanakooli meetodi" trellid ette tähendab(teeb)? Kubuntus on selline fail nagu- locale alias- kus on needsamad ee, en.... välja loetletud.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 748
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 25.02.2014, 09:30  postituse pealkiri:  (teema puudub)  

Tsitaat:
Mida see "vanakooli meetodi" trellid ette tähendab(teeb)? Kubuntus on selline fail nagu- locale alias- kus on needsamad ee, en.... välja loetletud.

Trellid rea alguses tähendab, et see on kommentaari rida, mida seda konfifaili lugev protsess ei arvesta.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 76
Liitunud: 25.03.2009
Postitused: 536
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 25.02.2014, 11:42  postituse pealkiri:  (teema puudub)  

http://crunchbanglinux.org/wiki/howto/localepurge
Installimise ajal kävitab tabeli.

Vali sealt ainult vajalikud.

_________________
Kõige parem asi on töötav asi.

mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 25.02.2014, 12:28  postituse pealkiri:  (teema puudub)  

hjuumen kirjutas:

Mida see "vanakooli meetodi" trellid ette tähendab(teeb)? Kubuntus on selline fail nagu- locale alias- kus on needsamad ee, en.... välja loetletud.


/etc/locale.alias ei ole sama!
Mida ütleb:
locale -a

Kui locale.gen pole, siis teeb Kubuntu midagi teistmoodi, kui Debian. Guugeldasin ka veidi ja leidsin, et Kubuntu kasutab update-locale tööriista, nagu siin juba mainitud ning siis avastasin, et ka debianis on olemas update-locale Razz
man update-locale
ütleb, et õige käsk võiks olla:
sudo update-locale LANG=et_EE.UTF-8
Seda ka juba siin mainitud, aga kontrolli, et /etc/default/locale failis oleks rida:
LANG=et_EE.UTF-8

Kui ei ole, siis proovi käsku:
sudo update-locale --reset LANG=et_EE.UTF-8


hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 26.02.2014, 20:27  postituse pealkiri:  (teema puudub)  

raimz@raimz-kubuntu:~$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
C.UTF-8
POSIX
de_CH.utf8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
et_EE.utf8
raimz@raimz-kubuntu:~$

selline tulemus locale -a peale, aga kui lihtsalt locale käsk, siis sama nagu enne:
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$

Proovisin vahepeal luua Libre Office Calc faili nimega -töötunnid-. Fail tekkis küll kausta, aga kui avada püüdsin, siis ütles et seda pole olemas, nii tegi ka varem.


natsa
Vana Pingviin
Vana Pingviin


Vanus: 76
Liitunud: 25.03.2009
Postitused: 536
Asukoht: Kärdla
Distributsioon: LMDE-2 Mate 64-bit
estonia.gif
postituspostitatud: 27.02.2014, 14:22  postituse pealkiri:  (teema puudub)  

KDE avamenüüst vali: Help > UNIX manual pages > (8)Sys.Administration
> locale-gen


Kasulik teave.

_________________
Kõige parem asi on töötav asi.

sander85
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 27.02.2014, 14:45  postituse pealkiri:  (teema puudub)  

hjuumen kirjutas:
raimz@raimz-kubuntu:~$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
C.UTF-8
POSIX
de_CH.utf8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
et_EE.utf8
raimz@raimz-kubuntu:~$

selline tulemus locale -a peale, aga kui lihtsalt locale käsk, siis sama nagu enne:
raimz@raimz-kubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=et_EE.ISO-8859-1
LANGUAGE=et:en
LC_CTYPE="et_EE.ISO-8859-1"
LC_NUMERIC="et_EE.ISO-8859-1"
LC_TIME="et_EE.ISO-8859-1"
LC_COLLATE="et_EE.ISO-8859-1"
LC_MONETARY="et_EE.ISO-8859-1"
LC_MESSAGES="et_EE.ISO-8859-1"
LC_PAPER="et_EE.ISO-8859-1"
LC_NAME="et_EE.ISO-8859-1"
LC_ADDRESS="et_EE.ISO-8859-1"
LC_TELEPHONE="et_EE.ISO-8859-1"
LC_MEASUREMENT="et_EE.ISO-8859-1"
LC_IDENTIFICATION="et_EE.ISO-8859-1"
LC_ALL=
raimz@raimz-kubuntu:~$

Proovisin vahepeal luua Libre Office Calc faili nimega -töötunnid-. Fail tekkis küll kausta, aga kui avada püüdsin, siis ütles et seda pole olemas, nii tegi ka varem.


Ma ei näe, et sa oleks proovinud Mihkli poolt soovitatud käskusid: https://pingviin.org/fpost78335.html#78335 - mis nende tulemused olid, kui siiski proovisid?

_________________
Image Image Image

mahfiaz
Pingviini aktivist
Pingviini aktivist



Liitunud: 19.10.2007
Postitused: 147


blank.gif
postituspostitatud: 01.03.2014, 14:18  postituse pealkiri:  (teema puudub)  

KUI lokaadivahetusega hakkama saab (mihkli viimane postitus), siis järgmine samm peaks olema failisüsteemis convmv-ga täpitähed õigesse lokaati teisendada.

Midagi sellist:
convmv -r -f ISO_8859-1 -t UTF-8 ~

Aga veelkord, seda ei maksa teha enne, kui lokaat vahetatud sai ja LANG= lõpus on UTF-8


hjuumen
Uus kasutaja
Uus kasutaja


Vanus: 42
Liitunud: 22.01.2010
Postitused: 9
Asukoht: Tapa

estonia.gif
postituspostitatud: 03.03.2014, 22:25  postituse pealkiri:  (teema puudub)  

mihkel kirjutas:
Seda ka juba siin mainitud, aga kontrolli, et /etc/default/locale failis oleks rida:
LANG=et_EE.UTF-8

Kui ei ole, siis proovi käsku:
sudo update-locale --reset LANG=et_EE.UTF-8


On selline rida olemas seal, see on ainus rida mis seal on.
Järgmise käsu- sudo update-locale LANG=et_EE.UTF-8 - peale tuli selline info:

raimz@raimz-kubuntu:~$ sudo update-locale LANG=et_EE.UTF-8
[sudo] password for raimz:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "et:en",
LC_ALL = (unset),
LANG = "et_EE.ISO-8859-1"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
raimz@raimz-kubuntu:~$


imre
Vana Pingviin
Vana Pingviin



Liitunud: 16.08.2005
Postitused: 2638
Asukoht: Saku kant
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 03.03.2014, 23:17  postituse pealkiri:  (teema puudub)  

Proovi nii:
Kood:
export LANGUAGE=et_EE.UTF-8
export LANG=et_EE.UTF-8
export LC_ALL=et_EE.UTF-8
sudo locale-gen et_EE.UTF-8
dpkg-reconfigure locales

_________________
Enne teema püstitamist kasutage OTSINGUT
Küsi targalt: Infot siit !
Kui aru ei saa, siis küsi.

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group