Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
melsu
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 21.05.2007
Postitused: 45

Distributsioon: Ubuntu lucid
estonia.gif
postituspostitatud: 15.12.2009, 17:44  postituse pealkiri:  Mobiilne internet ja UDEV  

Tere.
Sain enda valdusesse Tele2 mobiilinetipulga. Mudeliks on huawei E1752
Kuna seda hakkab edaspidi kasutama mu ema, siis tahtsin teha selle julla automaagiliseks.
Selleks kasutan skripti, mis asub usr/local/share/minuskript.sh

Kood:

#!/bin/bash
/usr/sbin/usb_modeswitch


Seejärel tegin uue UDEV rule: /etc/udev/rules.d/10-Tele2.rules


BUS=="usb", SYSFS{idProduct}=="12d1", SYSFS{idVendor}=="1446",
ACTION=="add", RUN+="/usr/local/share/minuskript.sh"
[/code]
Aga ei tööta:(
Juhendi Link
Ubuntu 9.10, gnome, 2.6.31-17-generic
udev reeglite peale enda hammas enam ei hakka.

lsusb väljund enne usb_modeswitch...
Kood:

Bus 002 Device 049: ID 12d1:1446 Huawei Technologies Co., Ltd.

... ja pärast:
Kood:

Bus 002 Device 050: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

Ehk oskab mõni targem isik aidata?
Kasutatud kirjandus:
usb modeswitch seadistamine
udev reeglid

_________________
Te ei tea, aga Te uurige Wink

obundra
Vana Pingviin
Vana Pingviin


Vanus: 46
Liitunud: 04.08.2005
Postitused: 1213
Asukoht: 127.0.0.1
Distributsioon: RHEL, Solaris, Debian, Gentoo
estonia.gif
postituspostitatud: 15.12.2009, 22:35  postituse pealkiri:  (teema puudub)  

Kas arvuti või udev teenuse restartisid ka peale udev reeglite muutmist?

_________________
IT teenused

melsu
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 21.05.2007
Postitused: 45

Distributsioon: Ubuntu lucid
estonia.gif
postituspostitatud: 15.12.2009, 22:47  postituse pealkiri:  (teema puudub)  

Jah

Kood:

sudo service udev stop
sudo service udev start

_________________
Te ei tea, aga Te uurige Wink

zeroconf
Vana Pingviin
Vana Pingviin



Liitunud: 31.03.2007
Postitused: 1047


blank.gif
postituspostitatud: 20.12.2009, 22:48  postituse pealkiri:  (teema puudub)  

Ma just sama mõtet mõlgutasin, et Tele2 käest seda vidinat soetada. Esinduses olles näitas näitsik mulle vaid Windowsi ja Mac OS-i toetust kuid Linuxi osas kehitas õlgu. Mõtlesingi just siit foorumist küsida, et kuidas see töötab ka Linuxis. Kasutusel hetkel Estobuntu 9.05 (Kubuntu 9.04) ja ka ka Ubuntu 9.10. Peaks proovima küsida Tele2 tehnilise toe käest... Näiteks ERR vastas otse.err.ee kohta küll kenasti Linuxi osas. Ei maksa arvata, et kõik organisatsioonid Linuxist midagi ei tea. Lootma peab...


zeroconf
Vana Pingviin
Vana Pingviin



Liitunud: 31.03.2007
Postitused: 1047


blank.gif
postituspostitatud: 21.12.2009, 00:04  postituse pealkiri:  (teema puudub)  

kunagi sai proovitud salutis-connect nimelist programmi Huawei E220 modemil:
https://launchpad.net/~azosim/+archive/ppa/+build/853933

See programm paistab ka siin üleval olevat.

Kas see aitab ka selle E1752 puhul?


euqen
Pingviini aktivist
Pingviini aktivist


Vanus: 41
Liitunud: 25.10.2006
Postitused: 165
Asukoht: Viimsi / Vantaa / Internet
Distributsioon: Ubuntu
estonia.gif
postituspostitatud: 21.12.2009, 00:08  postituse pealkiri:  (teema puudub)  

teatage mulle ka kui mõne internetipulga tööle saate, olen samuti samade
küsimustega EMT jutul käinud, ka nemad laiutavad käsi.


melsu
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 21.05.2007
Postitused: 45

Distributsioon: Ubuntu lucid
estonia.gif
postituspostitatud: 21.12.2009, 15:41  postituse pealkiri:  (teema puudub)  

Tele2 pulgaga on selline lugu: Kuna see julla töötab ka mälupulgana siis on vaja iga kord ümber lülitada usb_modeswitch abiga (vt. linki esimeses postituses). Ise lahendasin probleemi ajutiselt sellega, et tegin pisikese skripti (vt. esimest postitust), mida käivitan paneelile loodud nupu abil. (Võibolla ei peagi skripti kasutama ja saab otsese käsuga: gksudo usb_modeswitch) Gnome networkmanageris tegin uue ühenduse, kus kasutaja ja parooli jätsin tühjaks ning aadressiks panin data.tele2.ee. Ühenduse liik on PAP. linnuke automaatse ühendamise ette ja töötas.
Pärast käib sellises järjekorras:

1. Pulk sisse
2. kliki nuppu
3. oota, kuni ühendumiseni. See võtab natuke aega, mingi 20-30 sek.
4. Surfa Cool

Loodan, et jutt sai enam vähem selge.

_________________
Te ei tea, aga Te uurige Wink

zeroconf
Vana Pingviin
Vana Pingviin



Liitunud: 31.03.2007
Postitused: 1047


blank.gif
postituspostitatud: 25.12.2009, 01:07  postituse pealkiri:  (teema puudub)  

Üllatus-üllatus - ka Tele2 Internetitugi vastas mulle e-postiga ja näe Oliveri - pannud teine õpetuse just eile netti üles - http://olkas.blogspot.com/2009/12/huawei-e1752-ja-ubuntu-910-karmic-koala.html - huvitav oleks kuulda, kas ja kuidas see teil toimib. Endal Ubuntu 9.04 just selles masinas, mida vaja selle modemiga kasutada.... Seal põhimõte sama - ümberlülitamisega.
Tegin sellest ka koopia siia .odt faili kujul kuna .pdf läks liiga suureks...


huawei_e1752_ubuntu_9-10.odt
 Kirjeldus:
Huawei E1752 ja Ubuntu 9.10 Karmic Koala

Allalaadimised
 Failinimi:  huawei_e1752_ubuntu_9-10.odt
 Failisuurus:  143.3 kB
 Alla laaditud:  541 kord(a)


GreenGoblin2010
Uus kasutaja
Uus kasutaja



Liitunud: 21.04.2010
Postitused: 1


blank.gif
postituspostitatud: 21.04.2010, 13:40  postituse pealkiri:  (teema puudub)  

Kas keegi on seda Oliveri blogid tõesti vaatanud ja proovinud seda pulka tööle saada? Nüüd eriti Estobuntuga.

Nimelt mina küll ei seda tööle saanud nende juhistega.
Tundub et Oliver on lihtsalt kopinud selle teksti sealt Mc Canni blogist.
Skriptis on ka viga. Seal on kirjas:
TargetProdct= 0x1001

Peaks olema TargetProduct. Sellega on vist siis vedanud ja ilmselt see skript läheb tööle kui pulka on üks kord proovitud windowssis. Aga kuidas on leitud MessageContent? (Leidsin et selleks on vaja WinXP ja mingi tarkvara, aga XP'd pole).

Sain väga suurte pingutustega selle skripti nii ja naa tööle ja sain vahetatud selle pulga staatuse õigeks. Aga selleks oli vaja pulga taaskäivitust... Ja vahel vist oli kasu sellest et skripti ajal tõmbas pulga lahti. Kui skripti ajal tõmbab pulga välja, siis võibolla see vahetab staatuse 0x1001 peale...

Kõige kasulikumaks osutus Sakis3G, aga ikkagi ühenudst ei saanud. Aga kui mõllasin usb_modeswitchiga ja Sakis3Gka, siis vähemalt sai pulgale õige staatuse...

Ja 4 tunni mõllamise tulemus oli et terve masina jooksis kokku ja täna peab uuesti installima terve op-systeem...

Või kas on nii, et Estobuntu on nii erinev, et sellega seda pulka ei tööle saa?

Kui on mingi nõud siis palun väga kirjutage siia. Juhul et ma selle kuidagi tööle saan, luban postitada juhised ka. Aga praegu Estobuntu ja Huawei 1752 ei küll tööta.


zeroconf
Vana Pingviin
Vana Pingviin



Liitunud: 31.03.2007
Postitused: 1047


blank.gif
postituspostitatud: 21.04.2010, 20:06  postituse pealkiri:  (teema puudub)  

Mina sain tööle tol korral kuid jah, puhta Ubuntuga (9.04 ja 9.10). Estobuntuga ei ole proovinud...


-ordi-
Vana Pingviin
Vana Pingviin


Vanus: 29
Liitunud: 13.12.2008
Postitused: 821

Distributsioon: GNU/Linux
estonia.gif
postituspostitatud: 21.04.2010, 20:13  postituse pealkiri:  (teema puudub)  

GreenGoblin2010 kirjutas:
Kas keegi on seda Oliveri blogid tõesti vaatanud ja proovinud seda pulka tööle saada? Nüüd eriti Estobuntuga.

Nimelt mina küll ei seda tööle saanud nende juhistega.
Tundub et Oliver on lihtsalt kopinud selle teksti sealt Mc Canni blogist.
Skriptis on ka viga. Seal on kirjas:
TargetProdct= 0x1001

Peaks olema TargetProduct. Sellega on vist siis vedanud ja ilmselt see skript läheb tööle kui pulka on üks kord proovitud windowssis. Aga kuidas on leitud MessageContent? (Leidsin et selleks on vaja WinXP ja mingi tarkvara, aga XP'd pole).

Sain väga suurte pingutustega selle skripti nii ja naa tööle ja sain vahetatud selle pulga staatuse õigeks. Aga selleks oli vaja pulga taaskäivitust... Ja vahel vist oli kasu sellest et skripti ajal tõmbas pulga lahti. Kui skripti ajal tõmbab pulga välja, siis võibolla see vahetab staatuse 0x1001 peale...

Kõige kasulikumaks osutus Sakis3G, aga ikkagi ühenudst ei saanud. Aga kui mõllasin usb_modeswitchiga ja Sakis3Gka, siis vähemalt sai pulgale õige staatuse...

Ja 4 tunni mõllamise tulemus oli et terve masina jooksis kokku ja täna peab uuesti installima terve op-systeem...

Või kas on nii, et Estobuntu on nii erinev, et sellega seda pulka ei tööle saa?

Kui on mingi nõud siis palun väga kirjutage siia. Juhul et ma selle kuidagi tööle saan, luban postitada juhised ka. Aga praegu Estobuntu ja Huawei 1752 ei küll tööta.


Ma ei tea kas Mandriva päästaks sind, aga minu Huawei e220 töötab Mandriva all koheselt, ilma et peaks midagi tegema, va võrguhalduri avamine ja parooli sisestamine, proovi Mandriva liveCD'lt kas töötab kui jah, siis mina laseks ka selle peale, muresid vähem.

Mandriva pluss on veel see et võrguhaldur ei sõltu töölauast, Ubuntu all on mul nii et ka modem toimib pmst laksust aga KDE all tuleb selleks (....siia mõtle ise sobiv tekst!....) teha.
Võrguhaldurid on erinevad ja millegipärast ei ole siiani seda KDE võrguhaldurit korda tehtud.


ehhr
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 14.03.2007
Postitused: 506
Asukoht: Pärnu
Distributsioon: Ubuntu 8.10, Elementary OS(Ubuntu 12.04)
estonia.gif
postituspostitatud: 21.04.2010, 22:35  postituse pealkiri:  (teema puudub)  

Minu jookseb ka peale Oliveri õpetuse läbi tegemist nagu siidi see pulk.Kasutan ise tavalist Ubuntut 9.10.
ainus asi on, et peab selle usb-modeswitch'iga pulka tuvastama, aga mis see korra konsool avada ikka on.


--IN--
Pingviini külastaja
Pingviini külastaja


Vanus: 56
Liitunud: 05.08.2008
Postitused: 21


blank.gif
postituspostitatud: 23.04.2010, 16:02  postituse pealkiri:  (teema puudub)  

kas oskab keegi alltoodud info põhjal öelda mis mul puudu jääb,
et ma ei saa Tele2 netipulgaga internetti Linuxi all.
Sim kaardilt on PIN küsimine maha võetud ja Windoosa all toimib.
Netipulk on Huawei E1552, kuid masin tunneb ta ära E620 -na.
Kas selles võib olla asi, või on midagi seadistustes valseti?
Opsüsteem on ClearOs 5.1 (CentOs5.4 baasil)
Kogu konfimise pean tegema käsurealt, GUI-d asjal ei ole.
--
--Ilmar--


ilmar# lsusb
bus 001 Device 001: ID 0000:0000
bus 001 Device 002: ID 12d1:1001 Huawei Tecnologies Co., Ltd. E620 USB Modem
bus 002 Device 001: ID 0000:0000
bus 003 Device 001: ID 0000:0000
bus 004 Device 001: ID 0000:0000
bus 005 Device 001: ID 0000:0000


Ilmar# wvdial
--> Wvdial: Internet dialer version 1.54.0
--> Cannot get information for serial port.
--> initializing modem.
--> Sending: ATZ
OK
--> Sending ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","data.tele2.ee"
AT+CGDCONT=1,"IP","data.tele2.ee"
OK
--> Modem initialized.
--> Sending ATDT*99#
--> Waiting for carrier
ATDT*99#
CONNECT
--> Carrier detected. Waiting for prompt
[selle kohapeal on miski pooleminutine paus]
--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting pppd at Thu Apr 22 17:31:39 2010
--> pid of pppd: 32296
--> Using interface ppp0
--> Disconnecting at Thu Apr 22 17:31:47 2010
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

Ilmar# cat wvdial.conf

[Dialer Defaults]
Modem = /dev/ttyUSB0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Init3 = AT+CGDCONT=1,"IP","data.tele2.ee"
Modem Type = Analog Modem
Phone = *99#
Username = U
Password = P

EDIT: Täpsustatud Huawei mudel, mitte E1550 vaid E1552
EDIT2:
Tõstsin korraks pulga windoosa masinasse ja seal avastasin, et APN on antud "mobileinternet.tele2.ee"
Uuesti Linuxi alla ja nüüd ei saa üldse enam ühendust.
"No Carrier" saan vastuseks, kuigi seadeid muutnud ei ole Rolling Eyes


hinkus
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 07.10.2009
Postitused: 137

Distributsioon: mint 12
estonia.gif
postituspostitatud: 23.04.2010, 23:25  postituse pealkiri:  (teema puudub)  

Mul selline küsimus,et kuidas see käsk terminalis täpselt käib kui ma tahan tekstiredaktoriga seda usb_modeswitch.conf avada nii nagu Oliver soovitas ,et need lisa read sinna lõppu lisada?-usb_modeswitc on etc kataloogis. ma ise proovisin sellist sudo gedit/etc/usb_modeswitch.conf aga ütleb comand not found.Olen siin katsetand ja proovind aga ei midagi.Isegi üks kord ta minu arust tegi lahti aga lisada ei lasknud midagi ütles,et on kirjutus kaitstud

TÄNUD

_________________
www.twitter.com/ubuntu10_04lts, kes tahab see liitugu

olavsu1


Vana Pingviin
Vana Pingviin


Vanus: 45
Liitunud: 02.12.2006
Postitused: 923

Distributsioon: ubuntu, mandriva
estonia.gif
postituspostitatud: 23.04.2010, 23:54  postituse pealkiri:  (teema puudub)  

jve kirjutas:
Mul selline küsimus,et kuidas see käsk terminalis täpselt käib kui ma tahan tekstiredaktoriga seda usb_modeswitch.conf avada nii nagu Oliver soovitas ,et need lisa read sinna lõppu lisada?-usb_modeswitc on etc kataloogis. ma ise proovisin sellist sudo gedit/etc/usb_modeswitch.conf aga ütleb comand not found.Olen siin katsetand ja proovind aga ei midagi.Isegi üks kord ta minu arust tegi lahti aga lisada ei lasknud midagi ütles,et on kirjutus kaitstud

TÄNUD


mina olen seda teinud MC abil

sudo mc

norton commander peaks ikka tuttav olema. saab geditiga ka

sudo gedit

ja faili avamisdialoogiga otsid vajaliku faili üles.


andreas
Pingviini aktivist
Pingviini aktivist


Vanus: 27
Liitunud: 26.02.2008
Postitused: 112
Asukoht: Raasiku
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 24.04.2010, 00:55  postituse pealkiri:  (teema puudub)  

jve kirjutas:
sudo gedit/etc/usb_modeswitch.conf

gediti ja /etc vahel peab olema tühik.


hinkus
Pingviini aktivist
Pingviini aktivist


Vanus: 49
Liitunud: 07.10.2009
Postitused: 137

Distributsioon: mint 12
estonia.gif
postituspostitatud: 24.04.2010, 10:41  postituse pealkiri:  (teema puudub)  

Tänud veel kord! oligi jah vaja gediti ja etc vahele tühikut. kõik toimib.

_________________
www.twitter.com/ubuntu10_04lts, kes tahab see liitugu

--IN--
Pingviini külastaja
Pingviini külastaja


Vanus: 56
Liitunud: 05.08.2008
Postitused: 21


blank.gif
postituspostitatud: 24.04.2010, 13:00  postituse pealkiri:  (teema puudub)  

Kas keegi Tele2 kasutaja postitaks siia, palun, oma toimiva wvdial.conf sisu?

--
--Ilmar--


--IN--
Pingviini külastaja
Pingviini külastaja


Vanus: 56
Liitunud: 05.08.2008
Postitused: 21


blank.gif
postituspostitatud: 24.04.2010, 22:51  postituse pealkiri:  (teema puudub)  

Panin netipulga sisse EMT kaardi ja määrasin APN-iks wap.emt.ee ning ühendus olemas!

Mis siis Tele2 puhul teisiti on?
Proovitud APN-id:
wap.tele2.ee
data.tele2.ee
mobileinternet.tele2.ee

kas veel midagi??

--
--Ilmar--


sander85
Vana Pingviin
Vana Pingviin


Vanus: 35
Liitunud: 08.08.2005
Postitused: 4359
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 24.04.2010, 23:06  postituse pealkiri:  (teema puudub)  

äkki oskab nende oma klienditeenindus öelda, et mida kasutama peaks?

_________________
Image Image Image

Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group