Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
asjameez
Vana Pingviin
Vana Pingviin


Vanus: 30
Liitunud: 09.03.2007
Postitused: 428
Asukoht: Tallinn
Distributsioon: Kubuntu
estonia.gif
postituspostitatud: 06.02.2011, 22:07  postituse pealkiri:  (teema puudub)  

Testisin esteid tarkvara. Kubuntu 10.10 viimaste uuendustega ning Firefox 3.6.13. Sooritasin edukalt Swedbangas ID-kaarti kasutades ülekande.
Kahjuks minu põhibrauser, Chromium, ei tule veel ID-kaardiga toime Sad

_________________
"Dumbusers use Windows. Powerusers use Linux. Dumbusers who think they are powerusers use Mac."

julla
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 19.02.2008
Postitused: 71

Distributsioon: Ubuntu . Prooviks ka Fedora 13
blank.gif
postituspostitatud: 14.02.2011, 23:10  postituse pealkiri:  (teema puudub)  

Probleemiks digiallkirjastamine lehtedel mis kasutavad javat.
Esimesed teated tulevad kui java-aplett käivitub, et ei usalda sertifikaati ja peale seda blokeerib PKCS #11 ära.
Firefoxis, kui enda sertifikaate vaatan näen ainult logimise serti.

Id kaardi tarkvara google-code lehelt paigaldatud ja ubuntu 10.10
Ilmselt pole suur viga aga hetkel ei taipa mida teha.


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 15.02.2011, 07:44  postituse pealkiri:  (teema puudub)  

google-code'i tarkvara ei kasuta javat. Kui sul mingi java aken ette tuleb, siis järelikult on sul see vana wrapper kuskil süsteemis alles. Kustuta ära.


julla
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 19.02.2008
Postitused: 71

Distributsioon: Ubuntu . Prooviks ka Fedora 13
blank.gif
postituspostitatud: 15.02.2011, 08:11  postituse pealkiri:  (teema puudub)  

Pole küll eriline vaimuhiiglane sel teemal, aga kas see kuidas on veebileht tehtud, ei mõjuta seda asja. Pangas pole allkirjastamisega mingit probleemi.
Probleemsed on olnud elioni iseteedindus ja www.kikas.kik.ee.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 707
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 15.02.2011, 08:52  postituse pealkiri:  (teema puudub)  

Mina saan ühele ID-kaarti vajavale veebilehele ainult Seamonkeyga,
SEB-is saan ka FF-ga hakkama.


zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 31.03.2007
Postitused: 1018
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 20.02.2011, 20:14  postituse pealkiri:  (teema puudub)  

Kuidas kommenteerite uut tarkvara?
https://installer.id.ee/media/ubuntu/
https://installer.id.ee/media/opensuse/
https://installer.id.ee/media/osx/
https://installer.id.ee/media/fedora/
https://installer.id.ee/media/win/

Kas tasub paigaldada? Või tasub eelistada veel http://code.google.com/p/esteid/ peal pakutavat tarkvara??


sander85
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 08.08.2005
Postitused: 4358
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 20.02.2011, 20:49  postituse pealkiri:  (teema puudub)  

üldiselt võid ka SK oma juba proovida, sel veel mõned kühmud on, aga sellega võiks saada juba natuke ära teha ka..

_________________
Image Image Image

illukas
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 24.10.2006
Postitused: 2036


norway.gif
postituspostitatud: 20.02.2011, 21:17  postituse pealkiri:  (teema puudub)  

google oma käis minul hästa

_________________
https://www.inlink.ee

zeroconf
Vana Pingviin
Vana Pingviin


Vanus: 43
Liitunud: 31.03.2007
Postitused: 1018
Asukoht: Rapla, Tallinn
Distributsioon: Linux Mint, Ubuntu jt
estonia.gif
postituspostitatud: 20.02.2011, 21:23  postituse pealkiri:  (teema puudub)  

Mul see probleem, et vaja tekitada .cdoc ehk siis krüpteeritud fail, mida vaid konkreetsed isikud avada saaksid. Tulemus on olnud see, et nt Estobuntu 10.09 all tehtud .cdoc fail ei avanenud Windowsis sama (Google Code-ist pärit) tarkvara ei avanud - jäi ketrama ja lõpuks jooksis kinni Sad

Lisaks vaja digiallkirjastada dokument ja seejuures kindel olla, et teine pool ikka lahti saab. Kas vana tarkvara avab uue tarkvaraga allkirjastatud .ddoc faili??


anttix
Pingviini külastaja
Pingviini külastaja



Liitunud: 18.09.2010
Postitused: 18


estonia.gif
postituspostitatud: 05.03.2011, 00:00  postituse pealkiri:  (teema puudub)  

zeroconf kirjutas:
Kas vana tarkvara avab uue tarkvaraga allkirjastatud .ddoc faili??


Jah, aga .ddoc mitte .bdoc formaadis.
.ddoc on vaikimisi seega kui seda ise ei ole ära muutnud siis peaks olema OK.


sips
Pingviini aktivist
Pingviini aktivist



Liitunud: 20.05.2006
Postitused: 288

Distributsioon: Arch
estonia.gif
postituspostitatud: 09.03.2011, 21:23  postituse pealkiri:  arch, esteid-browser-plugin-svn, boost-1.46  

Arch'il (686) ei kompileeru esteid-browser-plugin-svn boost-1.46'ga
Kood:
[ 32%] Building CXX object projects/esteid-browser-plugin/NpapiPlugin/CMakeFiles/EE_NpapiPlugin.dir/NpapiPluginModule.cpp.o
[ 33%] Building CXX object projects/esteid-browser-plugin/NpapiPlugin/CMakeFiles/EE_NpapiPlugin.dir/NpapiStream.cpp.o
[ 34%] Building CXX object projects/esteid-browser-plugin/NpapiPlugin/CMakeFiles/EE_NpapiPlugin.dir/NpapiTypes.cpp.o
[ 36%] Building CXX object projects/esteid-browser-plugin/NpapiPlugin/CMakeFiles/EE_NpapiPlugin.dir/X11/NpapiPluginX11.cpp.o
Linking CXX static library libEE_NpapiPlugin.a
[ 36%] Built target EE_NpapiPlugin
Scanning dependencies of target EE_PluginCommon
[ 37%] Building CXX object projects/esteid-browser-plugin/PluginCommon/CMakeFiles/EE_PluginCommon.dir/PluginInfo.cpp.o
[ 38%] Building CXX object projects/esteid-browser-plugin/PluginCommon/CMakeFiles/EE_PluginCommon.dir/null/NullLogger.cpp.o
Linking CXX static library libEE_PluginCommon.a
[ 38%] Built target EE_PluginCommon
Scanning dependencies of target EE_PluginWindow
[ 39%] Building CXX object projects/esteid-browser-plugin/PluginWindow/CMakeFiles/EE_PluginWindow.dir/X11/PluginWindowX11.cpp.o
Linking CXX static library libEE_PluginWindow.a
[ 39%] Built target EE_PluginWindow
Scanning dependencies of target esteid
[ 40%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/Base64.cpp.o
[ 42%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/converter.cpp.o
[ 43%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/CardService.cpp.o
[ 44%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/PersonalDataAPI.cpp.o
[ 45%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/urlparser.cpp.o
[ 46%] Building CXX object projects/esteid-browser-plugin/CMakeFiles/esteid.dir/PluginSettings.cpp.o
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp: In static member function ‘static boost::filesystem3::path PluginSettings::userSettingsDir()’:
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:62:37: error: invalid conversion from ‘bool (*)(const std::string&)’ to ‘boost::enable_if_c<true, void>::type*’
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:62:37: error:   initializing argument 2 of ‘boost::filesystem3::path::path(const Source&, typename boost::enable_if<boost::filesystem3::path_traits::is_pathable<typename boost::decay<Source>::type> >::type*) [with Source = char*, typename boost::enable_if<boost::filesystem3::path_traits::is_pathable<typename boost::decay<Source>::type> >::type = void]’
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp: In member function ‘void PluginSettings::convertLegacy()’:
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:130:30: error: ‘exists’ was not declared in this scope
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:133:30: error: cannot convert ‘boost::filesystem3::path’ to ‘const char*’ for argument ‘1’ to ‘int remove(const char*)’
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp: In member function ‘void PluginSettings::save(const boost::filesystem3::path&)’:
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:167:28: error: ‘exists’ was not declared in this scope
/tmp/yaourt-tmp-rainer/aur-esteid-browser-plugin-svn/src/plugin-build/projects/esteid-browser-plugin/PluginSettings.cpp:168:37: error: ‘create_directory’ was not declared in this scope
make[2]: *** [projects/esteid-browser-plugin/CMakeFiles/esteid.dir/PluginSettings.cpp.o] Error 1
make[1]: *** [projects/esteid-browser-plugin/CMakeFiles/esteid.dir/all] Error 2
make: *** [all] Error 2
    Aborting...
==> ERROR: Makepkg was unable to build esteid-browser-plugin-svn.

_________________
PS! Vanaisale ei saa Linuxit peale lasta.

TT
Pingviini aktivist
Pingviini aktivist


Vanus: 60
Liitunud: 09.01.2007
Postitused: 141
Asukoht: Pärnu-Jaagupi
Distributsioon: Archlinux/Kubuntu
estonia.gif
postituspostitatud: 11.03.2011, 13:58  postituse pealkiri:  (teema puudub)  

Tsitaat:
Arch'il (686) ei kompileeru esteid-browser-plugin-svn boost-1.46'ga

Plugina paigaldamine õnnestus, kuid libdigidocpp-svn paigaldamine lõpeb erroriga:
Tsitaat:
[ 1%] Generating xml/XAdES.cxx
/bin/sh: line 1: 10800 Illegal instruction /usr/bin/xsdcxx cxx-tree --type-naming ucc --function-naming lcc --generate-doxygen --generate-intellisense --root-element-first --output-dir /tmp/yaourt-tmp-isa/aur-libdigidocpp-svn/src/libdigidocpp-build/src/xml --generate-serialization --namespace-map http://www.w3.org/2000/09/xmldsig#=digidoc::dsig --namespace-map http://uri.etsi.org/01903/v1.3.2#=digidoc::xades XAdES.xsd
make[2]: *** [src/xml/XAdES.cxx] Error 132
make[1]: *** [src/CMakeFiles/digidocpp.dir/all] Error 2
make: *** [all] Error 2


smuggle
Pingviini aktivist
Pingviini aktivist


Vanus: 59
Liitunud: 16.12.2010
Postitused: 112

Distributsioon: Mint 18-3 Cinnamon
estonia.gif
postituspostitatud: 11.03.2011, 14:00  postituse pealkiri:  (teema puudub)  

Tere, mul tekkis selline probleem, et kui on installitud http://code.google.com/p/esteid/ tarkvarapakett Ubuntule ja kaardilugeja on ühendatud (kas statsionaarselt või on ununenud USB pesasse) ning kasutad Firefoxi mingi aeg, siis brauseri välja lülitades jääb ta taustal käima. Uuesti Firefoxi käivitades ilmub teade: "Firefox is akready running, but is not reponding. ..."
Kui kaardilugejat pole, pole ka probleeme, kõik töötab. Kui keelasin Firefoxist Id kaardi, esines sama viga harvem. Kui uninstallisin Esteid tarkvara kadusid ka probleemid, kuigi kaardilugeja oli ühendatud. Proovitud erinevatel masinatel ja erinevate linuxitega (PinguyOs 10.10; Ubuntu 10.10; Ultimate Edition 2.8 ) . www.id.ee tarkvara ka ei ühildu. Mis teha????


mckevin
Pingviini aktivist
Pingviini aktivist


Vanus: 30
Liitunud: 02.05.2007
Postitused: 114
Asukoht: tallinn
Distributsioon: Arch Linux x86_64
estonia.gif
postituspostitatud: 13.03.2011, 14:10  postituse pealkiri:  (teema puudub)  

TT kirjutas:
Plugina paigaldamine õnnestus, kuid libdigidocpp-svn paigaldamine lõpeb erroriga:


paigalda libxsd-frontend ja xsd uuesti


TT
Pingviini aktivist
Pingviini aktivist


Vanus: 60
Liitunud: 09.01.2007
Postitused: 141
Asukoht: Pärnu-Jaagupi
Distributsioon: Archlinux/Kubuntu
estonia.gif
postituspostitatud: 17.03.2011, 11:10  postituse pealkiri:  (teema puudub)  

mckevin kirjutas:
TT kirjutas:
Plugina paigaldamine õnnestus, kuid libdigidocpp-svn paigaldamine lõpeb erroriga:


paigalda libxsd-frontend ja xsd uuesti

Mnjah, ikka jääb sama koha peale toppama Sad


mckevin
Pingviini aktivist
Pingviini aktivist


Vanus: 30
Liitunud: 02.05.2007
Postitused: 114
Asukoht: tallinn
Distributsioon: Arch Linux x86_64
estonia.gif
postituspostitatud: 17.03.2011, 18:00  postituse pealkiri:  (teema puudub)  

ei oska suurt midagi selle peale öelda makepkg.conf on ikka korras?
kui muu ei aita võid proovida staatilist versiooni
http://dl.dropbox.com/u/10871809/PKGBUILD-bin


TT
Pingviini aktivist
Pingviini aktivist


Vanus: 60
Liitunud: 09.01.2007
Postitused: 141
Asukoht: Pärnu-Jaagupi
Distributsioon: Archlinux/Kubuntu
estonia.gif
postituspostitatud: 17.03.2011, 20:06  postituse pealkiri:  (teema puudub)  

mckevin kirjutas:
ei oska suurt midagi selle peale öelda makepkg.conf on ikka korras?


Küllap vist. Ise teist näppinud pole. Aitäh, eks ma pusin aegamööda edasi.


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 707
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 30.04.2011, 20:04  postituse pealkiri:  (teema puudub)  

zeroconf kirjutas:
vaja digiallkirjastada dokument ja seejuures kindel olla, et teine pool ikka lahti saab. Kas vana tarkvara avab uue tarkvaraga allkirjastatud .ddoc faili??

Maadlesime tükk aega ühele dokumendile kolme allkirja saamisega - üks Tõraverest, üks Austraaliast, üks Tallinnast. Alustasin allkirjastamist openSUSE-11.4-s, teistel mingid MSW-d ja ei saanud .ddoc-i lahti. Kasutusel SK ID-tarkvara. Proovisin vist nelja erinevat varianti - openSUSE-11.3 oma ja 11.4 oma nii repost kui paari erinevat SVN-ist kompileeritut.

Siis allkirjastasin kolleegi Vistas, teised ei saanud ikka lahti.

Siis alustasime Tallinnas ja lisasime teised allkirjad, nii saime tehtud.
Tekkis kahtlus, mis sai ka SK-st kinnitust: probleemi tekitas õ-täht allkirjastaja infos.

SK-st teatati:
DigiDoc programmi kaudu allkirjastatud dokumendi avamisel ilmuv veateate: "error in document parsing" põhjuseks võib olla:

1) Dokumendi allkirjastaja rolli, asukoha jms nimetuses sisaldub täppidega tähti, mis pandi vaikimisi kaasa allkirjastamisel. Sellist faili ei ole kahjuks võimalik avada.

Ei pandud vaikimisi, ise kirjutasin. Ei tulnud selle pealegi, et Eestis tehtud programm ametlikuks asjaajamiseks ei saa hakkama eesti keeles olevate tähtedega.

2) Allkirjastatud dokument on Teile edastatud meili teel. Mõningad meiliserverid kahjustavad .ddoc formaadis olevaid faile, mistõttu nende hilisem avamine ei ole enam võimalik. Kahjustuste vältimiseks on soovitav fail eelnevalt kokku pakkida.


martinmartiini

Uus kasutaja
Uus kasutaja



Liitunud: 28.04.2011
Postitused: 11


blank.gif
postituspostitatud: 01.05.2011, 12:17  postituse pealkiri:  (teema puudub)  

kasutan/eelistan ID-kaardi tarkvara -- http://code.google.com/p/esteid/
opensuse repo :
http://download.opensuse.org/repositories/security:/eID/openSUSE_11.4/
sobib ID-kaardiga autentimiseks

Ubuntu 10.10 eID tarkvara töötab
Ubuntu 11.04 jaoks tarvara veel puudub

installer.id.ee hästi ei tööta


soovija
Uus kasutaja
Uus kasutaja


Vanus: 30
Liitunud: 28.02.2010
Postitused: 7


estonia.gif
postituspostitatud: 17.08.2011, 21:34  postituse pealkiri:  (teema puudub)  

Arch Linuxil on jätkuvatl see xml-security-c xalan patchi probleem. Kas keegi on selle lahendanud kavalal meetodil? Muutsin pkgbuildis nii selle lingi xml-security-c failile kui ka uuendasin id-d, aga ei saanud ikkagi tööle. Saatsin ka kaitocracy-le kirja, kes XML-security-c-ga tegeleb, aga tulu pole siiani olnud.

Ei viitsi rohkem mässata, ideid?

EDIT: Täpsustan, eelistan esteid pluginat. SK oma tundub võõras...


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group