Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
hinkus
Pingviini aktivist
Pingviini aktivist


Vanus: 48
Liitunud: 07.10.2009
Postitused: 137

Distributsioon: mint 12
estonia.gif
postituspostitatud: 27.09.2010, 11:55  postituse pealkiri:  ID-kaardi tarkvara Mac-ile ja Linuxile läbib testperioodi
Alates 27.09.2010, 12:55 kuni 28.10.2010, 13:53 (kaasa arvatud)
 

ID-kaardi tarkvara arendamisega tegelev Sertifitseerimiskeskus on valmis saanud ID-kaardi tarkvara beetaversioonid Macile ja Linuxile ning kogenud kasutajatel on võimalik uut tarkvara testida.

Hetkel on adressil http://id.eesti.ee saadaval tarkvara testversioon, mis ühildub Maci 10.6 operatisoonisüsteemiga. Hiljemalt kolmapäeval avaldab Sertifitseerimiskeskus ID-kaardi tarkvara beetaversiooni ka Maci 10.5 operatsioonisüsteemi tarvis, teatas BNS.

Tarkvara beeta- ehk testversioon tähendab, et tarkvaraarendus on lõppfaasis ning seda peaksid proovima üksnes kogenud kasutajad.

Tarkvaral võib esineda vigu, milleks võib olla näiteks kasutaja antud allkirja verifitseerimatus, allkirjastatud faili avamise tõrked, krüpteeritud faili dekrüpteerimise probleemid, selgitas Sertifitseerimiskeskuselt tarkvara tellinud Riigi Infosüsteemide Arenduskeskuse kommunikatsioonijuht Katrin Pärgmäe.

Macile ja Linuxile mõeldud ID-kaardi tarkvara peaks lõplikult valmima oktoobri lõpuks.

info:delfi majandus


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 709
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 27.09.2010, 13:14  postituse pealkiri:  (teema puudub)  

Proovisin openSUSE 11.2-l. Juhendis on see toetatud OS-ide loetelus, aga tegelikult pole, libcrypto.so.1.0.0 jääb leidmata. SUSE-11.2-l on libcrypto.so.0.9.8.

Vaatasin ka lähtekoodile otsa, aga seal pole mingitki infot, et mis keskkonnas, millised sõltuvused, mida need umbes 25 alamkataloogi tähendavad, kuidas lähtekoodist töötava koodi saab. Pole veel kohanud kasutajatele proovimiseks pakutavat unixiliste paketti, kus lähtekoodi põhikataloogis poleks vähemalt kolmerealist readme.txt-i, et mis ja milleks.


sander85
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 08.08.2005
Postitused: 4358
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 27.09.2010, 14:57  postituse pealkiri:  (teema puudub)  

akbgf kirjutas:
Proovisin openSUSE 11.2-l. Juhendis on see toetatud OS-ide loetelus, aga tegelikult pole, libcrypto.so.1.0.0 jääb leidmata. SUSE-11.2-l on libcrypto.so.0.9.8.

Vaatasin ka lähtekoodile otsa, aga seal pole mingitki infot, et mis keskkonnas, millised sõltuvused, mida need umbes 25 alamkataloogi tähendavad, kuidas lähtekoodist töötava koodi saab. Pole veel kohanud kasutajatele proovimiseks pakutavat unixiliste paketti, kus lähtekoodi põhikataloogis poleks vähemalt kolmerealist readme.txt-i, et mis ja milleks.


1.1 Toetatud operatsioonisüsteemid ja brauserid
ID-kaardi tarkvara töötab Microsoft Windowsi, Mac OS X ja Linuxi keskkonnas
(Beetas on toetatud ainult Linux (openSUSE 11.3, Fedora 13 ja Ubuntu 10.04) ja
Mac OS X 10.6). ID-kaardi tarkvara tööks minimaalselt vajalik riistvara on sama, mis
ID-kaardi tarkvara käitaval operatsioonisüsteemil.

kuigi varem oli seal lahedam sulgude vahemik Razz
(Beetas on toetatud ainult Linux (openSUSE 13, Debian 11.3 ja
Ubuntu 10.04) Laughing

_________________
Image Image Image

oldgreeneye
Pingviini aktivist
Pingviini aktivist


Vanus: 29
Liitunud: 23.01.2008
Postitused: 297
Asukoht: Tartu
Distributsioon: Arch
estonia.gif
postituspostitatud: 27.09.2010, 16:35  postituse pealkiri:  (teema puudub)  

Seegi hea uudis, et üldse miskit on Smile

Eks ilmselt annab seda sulgude vahemikku ka lahedamaks hakata venitama.


hadara
Uus kasutaja
Uus kasutaja


Vanus: 37
Liitunud: 24.03.2007
Postitused: 6

Distributsioon: FreeBSD
estonia.gif
postituspostitatud: 27.09.2010, 17:20  postituse pealkiri:  versioonikontroll?  

avaliku versioonikontrolli ligipääsu asemel mingi zip failiga lähtekoodi pakkumine on küll räme tagasiminek


mihkel
Vana Pingviin
Vana Pingviin



Liitunud: 16.04.2006
Postitused: 1284

Distributsioon: Fedora/Centos
estonia.gif
postituspostitatud: 27.09.2010, 17:36  postituse pealkiri:  (teema puudub)  

Huvitav, kas see -> https://code.google.com/p/esteid/ sisaldab sama koodi, mis see -> http://ftp.id.eesti.ee/pub/id/source.zip
Ehk siis, kas smartlink on tegelikult koodikribaja?


akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 709
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 27.09.2010, 17:50  postituse pealkiri:  (teema puudub)  

sander85 kirjutas:
(Beetas on toetatud ainult Linux (openSUSE 11.3, Fedora 13 ja Ubuntu 10.04)

Eile oli seal pikem loetelu, nende hulgas ka openSUSE 11.2.
Ma eile õhtul kurtsin neile raportis, mis leidmata jäi,
tänaseks on toetatute loetelu lühemaks jäänud.

Kuidas lähtekoodist töötava paketi saab, selle kohta juhendit pole leidnud.
Näikse cmake-ga tehtavat.


hadara
Uus kasutaja
Uus kasutaja


Vanus: 37
Liitunud: 24.03.2007
Postitused: 6

Distributsioon: FreeBSD
estonia.gif
postituspostitatud: 27.09.2010, 20:15  postituse pealkiri:  (teema puudub)  

mihkel kirjutas:
Huvitav, kas see -> https://code.google.com/p/esteid/ sisaldab sama koodi, mis see -> http://ftp.id.eesti.ee/pub/id/source.zip
Ehk siis, kas smartlink on tegelikult koodikribaja?


Ei tundu olevat sama.
Pisteliselt siit sealt diffe tehes forki eelse id.eesti.ee pealt võetud checkouti, SK praeguse code dumpi ja googlecodei esteid forgi vahel paistab erinevus id.eesti.ee viimase avaliku seisu ja esteid forgi vahel olevat oluliselt suurem kui id.eesti.ee viimase avaliku seisu ja SK code dumpi vahel.

Isegi kui ignoreerida mahtu, mis tuleb sellest juurde et esteid projektis lisanduvad kõigi failide päistesse LGPL litsentsi tingimused.

Näiteks browseri plugini diff id.eesti.ee 2010.03.23 seis vs. SK koodi dump:
Kood:

hadara@hl:~/contrib$ diff -x "\.svn" -r /contrib/id/svn/plugins/browser/trunk idkaart_sk_27.09.2010/plugins/browser/trunk | wc -l
606

ja diff id.eesti.ee ja googlecodei esteid projekti vastava kataloogi vahel:
Kood:

hadara@hl:~/contrib$ diff -x "\.svn" -r /contrib/id/svn/plugins/browser/trunk esteid-read-only/esteid-browser-plugin/trunk/ | grep -v "^> [ /]\*"  | wc -l
3171


pisi
Pingviini kasutaja
Pingviini kasutaja



Liitunud: 09.07.2007
Postitused: 65
Asukoht: Eesti
Distributsioon: Debian / Darwin
estonia.gif
postituspostitatud: 27.09.2010, 20:37  postituse pealkiri:  (teema puudub)  

sander85 kirjutas:

1.1 Toetatud operatsioonisüsteemid ja brauserid
ID-kaardi tarkvara töötab Microsoft Windowsi, Mac OS X ja Linuxi keskkonnas
(Beetas on toetatud ainult Linux (openSUSE 11.3, Fedora 13 ja Ubuntu 10.04) ja
Mac OS X 10.6). ID-kaardi tarkvara tööks minimaalselt vajalik riistvara on sama, mis
ID-kaardi tarkvara käitaval operatsioonisüsteemil.

kuigi varem oli seal lahedam sulgude vahemik :P
(Beetas on toetatud ainult Linux (openSUSE 13, Debian 11.3 ja
Ubuntu 10.04) :lol:


Samas, peenematel androididega tablettidel saab Ubuntu ehk peale panna küll. Aga USB nõue vist jääks täitmata.

_________________
pisi - muidumees ja maailmaparandaja
@MartinPaljak.net

imapi
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 01.12.2005
Postitused: 567
Asukoht: Rakvere
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 27.09.2010, 21:20  postituse pealkiri:  (teema puudub)  

akbgf kirjutas:
sander85 kirjutas:
(Beetas on toetatud ainult Linux (openSUSE 11.3, Fedora 13 ja Ubuntu 10.04)

Eile oli seal pikem loetelu, nende hulgas ka openSUSE 11.2.
Ma eile õhtul kurtsin neile raportis, mis leidmata jäi,
tänaseks on toetatute loetelu lühemaks jäänud.

... ja probleem lahendatud Smile

akbgf kirjutas:

Kuidas lähtekoodist töötava paketi saab, selle kohta juhendit pole leidnud.
Näikse cmake-ga tehtavat.

cmake suhteliselt lihtne asi Smile kui tead kuidas kasutada. Mine sortsu kataloogi ja loo uus kataloog nimega build. Mine sinna sisse ja käivita käsk ccmake ../ see peaaegu graafiline liides aitab juba ise edasi.

_________________
More than once my wife has asked why I don't do Windows, because that's where the money is. Why don't I just sell drugs or produce porn - there's money in those things, right?

imapi
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 01.12.2005
Postitused: 567
Asukoht: Rakvere
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 27.09.2010, 21:24  postituse pealkiri:  Re: versioonikontroll?  

hadara kirjutas:
avaliku versioonikontrolli ligipääsu asemel mingi zip failiga lähtekoodi pakkumine on küll räme tagasiminek


+1
ja kui viimati vaatasime Sanderiga siis puudusid ka srpm failid. Pettumus.

_________________
More than once my wife has asked why I don't do Windows, because that's where the money is. Why don't I just sell drugs or produce porn - there's money in those things, right?

akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 709
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 27.09.2010, 21:56  postituse pealkiri:  (teema puudub)  

imapi kirjutas:

cmake suhteliselt lihtne asi Smile kui tead kuidas kasutada. Mine sortsu kataloogi ja loo uus kataloog nimega build. Mine sinna sisse ja käivita käsk ccmake ../ see peaaegu graafiline liides aitab juba ise edasi.

Lähtekoodi juurkataloogis ei ole projekti CMakeLists.txt faili.
Need failid on alamkataloogide sügavustes. Kõige kõrgemad on ./*/trunk/ kataloogides - neid on tükki paarkümmend.
Missuguseist neist peaksin alustama?


imapi
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 01.12.2005
Postitused: 567
Asukoht: Rakvere
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 27.09.2010, 22:37  postituse pealkiri:  (teema puudub)  

akbgf kirjutas:
Lähtekoodi juurkataloogis ei ole projekti CMakeLists.txt faili.
Need failid on alamkataloogide sügavustes. Kõige kõrgemad on ./*/trunk/ kataloogides - neid on tükki paarkümmend.
Missuguseist neist peaksin alustama?


Jah seal trunk kataloogis peadki olema ja kõik paketid pead ükshaaval kokku laskma. Mõni pakett nõuab, et oled enne teise valmis kompileerinud.
Peale seda kui oled teinud selle ccmake ../ siis veel make ja make install kah Smile Ma ei viitsi praegu 250+M alla laadida, et täpselt järgi vaadata.

_________________
More than once my wife has asked why I don't do Windows, because that's where the money is. Why don't I just sell drugs or produce porn - there's money in those things, right?

akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 709
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 27.09.2010, 22:46  postituse pealkiri:  (teema puudub)  

imapi kirjutas:
Tundub, et oled vales kataloogis ... see peaks olema midagi <paketi nimi>/trunk/ ... vist Smile

Aga just seda ma kurdangi, et neid /trunk/ katalooge on paarkümmend tükki.

Ühes neist (libdigidoc/trunk/) sain ccmake ja make tehtud.

Ju vist katse-eksituse meetodil jõuaks kunagi ka õige kompileerimis- ja installi järjekorra leitud, et ccmake rahuldamata sõltuvuste üle ei kurdaks,
aga täna jätan järele, sest mul on homme töötavat ID-kaarti vaja autentimiseks ja see töötab vanal tarkvaral.


sander85
Vana Pingviin
Vana Pingviin


Vanus: 34
Liitunud: 08.08.2005
Postitused: 4358
Asukoht: Tallinn (vahel ka Virtsu)
Distributsioon: Mageia, Debian, CentOS
estonia.gif
postituspostitatud: 27.09.2010, 22:55  postituse pealkiri:  (teema puudub)  

akbgf kirjutas:
imapi kirjutas:
Tundub, et oled vales kataloogis ... see peaks olema midagi <paketi nimi>/trunk/ ... vist Smile

Aga just seda ma kurdangi, et neid /trunk/ katalooge on paarkümmend tükki.

Ühes neist (libdigidoc/trunk/) sain ccmake ja make tehtud.

Ju vist katse-eksituse meetodil jõuaks kunagi ka õige kompileerimis- ja installi järjekorra leitud, et ccmake rahuldamata sõltuvuste üle ei kurdaks,
aga täna jätan järele, sest mul on homme töötavat ID-kaarti vaja autentimiseks ja see töötab vanal tarkvaral.


lihtsam on edasi kasutada smartlinki tarkvara..

ftp://ftp.smartlink.ee/pub/id/nightly/opensuse/11.2/

_________________
Image Image Image

akbgf
Vana Pingviin
Vana Pingviin



Liitunud: 07.10.2009
Postitused: 709
Asukoht: Tõravere
Distributsioon: OpenSUSE, Ubuntu
estonia.gif
postituspostitatud: 27.09.2010, 23:04  postituse pealkiri:  (teema puudub)  

sander85 kirjutas:
lihtsam on edasi kasutada smartlinki tarkvara..

ftp://ftp.smartlink.ee/pub/id/nightly/opensuse/11.2/


Kunagi proovisin, digidoc3-s allkirjastamiseni ei jõudnud.
Saatsin ka veateate, aga siis vist asi sumbus.
qdigidocclient on tehtud 15.02.2010 04:55.

Hiljem pole proovinud.


imapi
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 01.12.2005
Postitused: 567
Asukoht: Rakvere
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 28.09.2010, 12:35  postituse pealkiri:  (teema puudub)  

Seal muidugi kõike ei pea kokku laskma. Näiteks pole ma OpenOffice ja FF pluginaid kunagi proovinud, ei ole lihtsalt soovi nii FF -i kui ka OOo devel pakette masinasse installida, mis nähtavasti võtaks kõva giga kettapinda ja peale selle ma neid ei kasuta ka.

_________________
More than once my wife has asked why I don't do Windows, because that's where the money is. Why don't I just sell drugs or produce porn - there's money in those things, right?

anttix
Pingviini külastaja
Pingviini külastaja



Liitunud: 18.09.2010
Postitused: 18


estonia.gif
postituspostitatud: 28.09.2010, 17:30  postituse pealkiri:  (teema puudub)  

Proovisime siis ka.

Ubuntu 10.04
-------------
Firefox:

Swedbank
Saab sisse logida, aga allkirjastada ei saa. Selle asemel suunatakse installer.id.ee lehele, kus peaks puuduva komponendi installima.

SEB
Sisse saab logida, aga allkirjastada ei saa.

Eesti.ee
Saab sisse logida, aga allkirjastada ei saa. Tuleb viga et dokument puudub sessioonis.

Utiliit
1. Alt+T avavab seadete akna, mida menüü ribal pole
2. Muuda PIN. pärast muutmist "Enter" klahvi vajutades tuleb error "Sisesta kehtiv PIN kood"

Klient
1. Juurdepääsutõendi puudumisel kui valida et laadi juurdepääsutõend avatakse sait www.sk.ee/getaccess mitte ei laadita kohe tõendit

Mac OS X 10.6
---------------
Safari 5.0.2:

Swedbank
Saab sisse logida, aga allkirjastada ei saa. Selle asemel suunatakse installer.id.ee lehele, kus peaks puuduva komponendi installima. Mac 10.6 pole seal aga toetatud, seega ei ole võimalik allkirjastada

SEB
Sisse saab logida, aga allkirjastada ei saa. Viga ohjurprogrammi paigaldamisel

Firefox 3.6.9
Samad hädad, mis Safaril

Chrome 6.0
Samad hädad, mis Safaril

Utiliit
1. Alt+T avavab seadete akna, mida menüü ribal pole (lausa 2 tegelikult)
2. Muuda PIN. pärast muutmist "Enter" klahvi vajutades tuleb error "Sisesta kehtiv PIN kood"

Klient
1. Käivitamisel error: Failed to initialize. Could not initialize XmlConf
Aknal on ka nupud "Help" ja "Close". "Help" nupule on vastus umbes, et ei oska aidata. Klient käima ei lähe, allkirjastamine võimatu.

Krüpto
1. Ümbriku Mail.app'i saatmine ei õnnestu
2. Saab avada mitu Krüpto akent korraga
3. Nupukombinatsioon Command+W ei pane Krüpto akent kinni, kuigi peaks. Sama ka menüüribalt Fail -> Sulge valides.

Järeldus:
See versioon on täielik kräpp. Igapäevaseks pruukimiseks ei kõlba absoluutselt, kuna mitte ükski brauser ei toimi korralikult mitte ühelgi lubatud platvormil.


Samuti oleks huvitav teada, kes oli see "geenius", kes arvas, et SVNi zip failiks kokku pakkimine on sobilik lähtekoodi levitusformaat?


imapi
Vana Pingviin
Vana Pingviin


Vanus: 39
Liitunud: 01.12.2005
Postitused: 567
Asukoht: Rakvere
Distributsioon: Mageia Cauldron
estonia.gif
postituspostitatud: 28.09.2010, 19:28  postituse pealkiri:  (teema puudub)  

Kas Me peaks / võiks saata Neile kirja kus väljendaks muret olukorra üle, kuna Meie oleme tõenäoliselt selle tarkvara Linuxi versiooni kõige aktiivsemad testijad / kasutajad.

_________________
More than once my wife has asked why I don't do Windows, because that's where the money is. Why don't I just sell drugs or produce porn - there's money in those things, right?

Heix
Pingviini aktivist
Pingviini aktivist


Vanus: 39
Liitunud: 23.07.2005
Postitused: 356

Distributsioon: Arch Linux
estonia.gif
postituspostitatud: 28.09.2010, 19:34  postituse pealkiri:  (teema puudub)  

Aga miks ka mitte!


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group