Portaal Portaal Pingviini veeb foorumi pealeht
  Viki  |  IRC  |  Otsing  |  Küsimused ja vastused  |  Profiil  |  Privaatsõnumite vaatamiseks logi sisse  | Logi sisse või Registreeru
<empty>
Vaata järgmist teemat
Vaata eelmist teemat

Postita uus teemaVasta teemale
Autor Sõnum
vooler3
Vana Pingviin
Vana Pingviin



Liitunud: 21.12.2015
Postitused: 446


blank.gif
postituspostitatud: 01.05.2018, 09:41  postituse pealkiri:  (teema puudub)  

Paistab, et "kõvem kolimine käib Ubuntu 18.04-le". Cool

Nüüd teatas ka Minti arendaja, et kolib samuti oma Linux Mint 19 "Tara" Ubuntu 18.04 peale.

Linux Mint 19 "Tara" Won't Collect or Send Any of Your Personal or System Data
It could arrive in May based on Ubuntu 18.04 LTS

https://news.softpedia.com/news/linux-mint-19-tara-won-t-collect-or-send-any-of-your-personal-or-system-data-520915.shtml


ertserts
Vana Pingviin
Vana Pingviin



Liitunud: 31.10.2013
Postitused: 431
Asukoht: Tallinn
Distributsioon: Ubuntu, Debian
estonia.gif
postituspostitatud: 01.05.2018, 11:42  postituse pealkiri:  (teema puudub)  

Kuna Ubuntu 18.04 LTS veel puudub ametlik SK id-kaarditarkvara tugi siis tuleb oodata.

_________________
ertserts@linuxialune:~$ echo;echo Local and Remote IP connections:;netstat -at|sort -k5|grep ESTABLISHED|cut -c20-80;echo

tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 713

Distributsioon: Debian
estonia.gif
postituspostitatud: 01.05.2018, 12:12  postituse pealkiri:  (teema puudub)  

vooler3 kirjutas:
Paistab, et "kõvem kolimine käib Ubuntu 18.04-le".


Loomulikult on kõik sunnitud seda tegema kui canonicali meeskond toetab riistvara täielikku turvaaukude lappimist ainult 18.04 peal.

_________________
ricochet:yckka6zlbxv767lz

karlsson
Pingviini aktivist
Pingviini aktivist



Liitunud: 30.09.2011
Postitused: 113

Distributsioon: Debian, Lubuntu.
estonia.gif
postituspostitatud: 01.05.2018, 13:25  postituse pealkiri:  (teema puudub)  

Sain selle rc.local faili tööle. Jätan näidise siia
Tsitaat:

Failiõigused
-rwxr-xr-x 1 root root 184 mai 1 14:00 rc.local

Faili sisu
---
#!/bin/sh -e

mount -t vboxsf -o uid=1000,gid=1000 C_DRIVE /media/c

exit 0
---

Kontroll
# systemctl status rc.local


hannes
Pingviini aktivist
Pingviini aktivist


Vanus: 34
Liitunud: 18.06.2009
Postitused: 213
Asukoht: Pärnu
Distributsioon: Debian | Ubuntu
estonia.gif
postituspostitatud: 01.05.2018, 14:28  postituse pealkiri:  (teema puudub)  

vooler3 kirjutas:
Paistab, et "kõvem kolimine käib Ubuntu 18.04-le". Cool

Nüüd teatas ka Minti arendaja, et kolib samuti oma Linux Mint 19 "Tara" Ubuntu 18.04 peale.

Kustkohast ta kolib? Mitte midagi ei "kolita". Linux Mint'i väljalasked käivad juba ammu Ubuntu LTS versioonide baasil, seega nii peabki olema ja mingit kolimist kui sellist pole.

_________________
Abielus ja kahe lapse isa. Tor'i ei kasuta. Järelikult mõttetu mees Smile

tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 713

Distributsioon: Debian
estonia.gif
postituspostitatud: 02.05.2018, 11:33  postituse pealkiri:  (teema puudub)  

hannes kirjutas:

Kustkohast ta kolib? Mitte midagi ei "kolita". Linux Mint'i väljalasked
käivad juba ammu Ubuntu LTS versioonide baasil, seega nii peabki olema
ja mingit kolimist kui sellist pole.

OK.

_________________
ricochet:yckka6zlbxv767lz

vooler3
Vana Pingviin
Vana Pingviin



Liitunud: 21.12.2015
Postitused: 446


blank.gif
postituspostitatud: 02.05.2018, 12:06  postituse pealkiri:  (teema puudub)  

tris kirjutas:
hannes kirjutas:

Kustkohast ta kolib? Mitte midagi ei "kolita". Linux Mint'i väljalasked
käivad juba ammu Ubuntu LTS versioonide baasil, seega nii peabki olema
ja mingit kolimist kui sellist pole.

OK.

Edaspidi oleks ikka mõtet seda lugeda mida Arendajad kirjutavad: Cool

Tsitaat - ja kus on üheselt ning selgelt kirjas, et "toimub kolimine Ubuntu 18.04 pardale".
Now that Canonical released the Ubuntu 18.04 LTS (Bionic Beaver) operating system, on which Linux Mint 19 "Tara" will be based, it's time for the Linux Mint team to finalize their releases. There's still no fixed release date for Linux Mint 19 "Tara," nor LMDE (Linux Mint Debian Edition) 3, but Clement Lefebvre said they will arrive soon.

Linux Mint 19 "Tara" Won't Collect or Send Any of Your Personal or System Data
It could arrive in May based on Ubuntu 18.04 LTS
https://news.softpedia.com/news/linux-mint-19-tara-won-t-collect-or-send-any-of-your-personal-or-system-data-520915.shtml

PS: Mintil on ka veel üks halb üllatus - et KDE-d rohkem enam pole. Ehk tuleb kunagi tagasi.


hannes
Pingviini aktivist
Pingviini aktivist


Vanus: 34
Liitunud: 18.06.2009
Postitused: 213
Asukoht: Pärnu
Distributsioon: Debian | Ubuntu
estonia.gif
postituspostitatud: 02.05.2018, 22:56  postituse pealkiri:  (teema puudub)  

Based on ei tähenda kuidagi kolimist. Mint 17.x, 18.x, 19,x jne ongi LTS baasil, mis kolimisest sa vooler jahud?

_________________
Abielus ja kahe lapse isa. Tor'i ei kasuta. Järelikult mõttetu mees Smile

123to
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.05.2014
Postitused: 120

Distributsioon: Xubuntu 18.04 i386, x64
estonia.gif
postituspostitatud: 03.05.2018, 21:36  postituse pealkiri:  (teema puudub)  

kas keegi seda buntulist kasutab, mis muljed on? https://thenextweb.com/dd/2018/05/02/system76-just-announced-a-major-update-to-its-developer-focused-linux-os/


vooler3
Vana Pingviin
Vana Pingviin



Liitunud: 21.12.2015
Postitused: 446


blank.gif
postituspostitatud: 04.05.2018, 12:48  postituse pealkiri:  (teema puudub)  

Paistab, et Ubuntu 18.04 on siis ka paljudele selleks "platvormiks" mille pealt 32-bitine versioon "pensionile saata".

Järgmises loos siis juttu sellest, et ka Mate tegijad jätavad alles ainult 64 bit versiooni.
PS. Mate oli muidu üsna populaarne vanemate arvutite korral.

Ubuntu MATE 18.10 Will Drop 32-Bit Support for New Installations
The OS will be released only as a 64-bit ISO image

https://news.softpedia.com/news/ubuntu-mate-18-10-will-drop-32-bit-support-for-new-installations-520980.shtml


tris

Troll - ära toida!
Troll - ära toida!



Liitunud: 23.08.2014
Postitused: 713

Distributsioon: Debian
estonia.gif
postituspostitatud: 05.05.2018, 10:36  postituse pealkiri:  (teema puudub)  

Ei ole õige, et kõik:
https://lubuntu.me/downloads/

_________________
ricochet:yckka6zlbxv767lz

vooler3
Vana Pingviin
Vana Pingviin



Liitunud: 21.12.2015
Postitused: 446


blank.gif
postituspostitatud: 08.05.2018, 21:11  postituse pealkiri:  (teema puudub)  

Paistab, et asi areneb.

Tuli välja ka "18.10 eel-eel-prooviversioon", nimega:
Ubuntu Cosmic CANIMAL (development branch)

Ning nagu on lugeda, siis ka see on veel hetkel "18.04 baasil".
-------------
PS: Vähemalt, katseks olevas Aceri läpparis see 18.10 hetkel töötab. Eks edaspidi näis mis juhtuma hakkab.


ottmaaten20
Pingviini kasutaja
Pingviini kasutaja


Vanus: 52
Liitunud: 31.10.2008
Postitused: 66

Distributsioon: Xubuntu 14.04
estonia.gif
postituspostitatud: 09.05.2018, 17:54  postituse pealkiri:  ID-kaardi kompileerimine  

Update 19:00:
Õnnestus petta qdigidoc ära kopeerides /usr/libi /usr/local/libis kompileerimisel tehtud libdigidocpp
Digidoc klient käivitub loeb kaarti - kuid allkirjastamisel tekib veateade:
ASiC_E.cpp:348 Failed to sign BDOC container.
QSigner.cpp:379 Dokumendi allkirjastamine ebaõnnestus
Terminalis kirjad:
DEBUG [SignatureXAdES_B.cpp:448] - SignatureXAdES_B::validate(POLv2)
DEBUG [SignatureXAdES_B.cpp:754] - Digest { 0E C2 AD 77 B3 DC 6F 17 59 2A F6 4C E2 47 DC 05 E9 88 92 A0 F6 BF 10 F8 3E C8 95 1C 38 37 A9 21 }:32

Küsimus 18:30
Kuidas Sul õnnestus qdigidoc kompileerida? Meil räägib ta et libdigidocpp1 on puudu, samuti dev? Kas oleme millestki mööda vaadanud.?
Opensc ja questeid töötavad


123to kirjutas:
Hakkasin ka 18.04 katsetama esialgu virtualboxis ja huvi pärast proovisin kas ID-kaarti eelmise versiooni artful soft installeerub, ei installeerunud.
Proovisin 18.04 distros olevat opensc'd, see ei lugenud ec võtmeid välja, ainult rsa.

Siis kloonisin gitist nii opensc kui ka open-eid/chrome-token-signing'u värskeimate täiendustega ja need läksid ilusti kokku ja installeerusid. Firefoxiga sain ka digidoc.ee'sse ja ka allkirjastatud.

gitist võetud opensc loeb ilusti ec võtmed välja:

$ opensc-tool --list-algorithms
Using reader with a card: SCM Microsystems Inc. SCR3340 - ExpressCard54 Smart Card Reader [CCID Interface] (00000000000000) 00 00
Algorithm: rsa
Key length: 2048
Flags: padding ( pkcs1 ) hashes ( sha1 sha256 )

Algorithm: ec
Key length: 384
Flags:

Edit:14.03.2018
õnnestus git'ist ka kaarti haldusvahend ja digidoc klient kokku lasta ja töötavad nii failide allkirjastamine kui ka krüpteerimine.
https://github.com/open-eid/qesteidutil
https://github.com/open-eid/libdigidocpp
https://github.com/open-eid/qdigidoc

Tõsi, vahepeal pidi libssl versiooni vahetama kuna libssl-dev oli konfliktis libxml-security-c-dev'ga. Ilmselt 18.04 beta viga praegult ja igapäevaselt tuleb parandusi veel.




Viimati muutis ottmaaten20 09.05.2018, 18:07; muudetud 1 kord
123to
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.05.2014
Postitused: 120

Distributsioon: Xubuntu 18.04 i386, x64
estonia.gif
postituspostitatud: 09.05.2018, 18:05  postituse pealkiri:  Re: ID-kaardi kompileerimine  

ottmaaten20 kirjutas:
Kuidas Sul õnnestus qdigidoc kompileerida? Meil räägib ta et libdigidocpp1 on puudu, samuti dev? Kas oleme millestki mööda vaadanud.?
Opensc ja questeid töötavad


enne tuleb see panna
https://github.com/open-eid/libdigidocpp

aga sellega on see jama, et tahab libssl1.0.0 ja libssl-dev läheb maha
sudo apt-get install cmake libxml-security-c-dev xsdcxx

seejärel paned libssl-dev tagasi ja siis paned

https://github.com/open-eid/qdigidoc
ja
https://github.com/open-eid/DigiDoc4-Client

just lõpetasin ühe vanema HP läpaka nc6120 peale panemise ja kõik töötab


ottmaaten20
Pingviini kasutaja
Pingviini kasutaja


Vanus: 52
Liitunud: 31.10.2008
Postitused: 66

Distributsioon: Xubuntu 14.04
estonia.gif
postituspostitatud: 09.05.2018, 18:29  postituse pealkiri:  (teema puudub)  

Kõik kompileerus - Digidoc4 avaneb - allkirjastamisel veateade:
ASiC_E.cpp:348 Failed to sign BDOC container.
QSigner.cpp:482 Dokumendi allkirjastamine ebaõnnestus

terminalis:
qdigidoc4.QSigner: Read sign cert "xxxxxxxxxx"
qdigidoc4.QSigner: Cert is empty: false
qdigidoc4.QSmartCard: Polling
qdigidoc4.MainWindow: Select card "xxxxxxxxxx"
qdigidoc4.QSmartCard: Polling


123to
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.05.2014
Postitused: 120

Distributsioon: Xubuntu 18.04 i386, x64
estonia.gif
postituspostitatud: 09.05.2018, 18:59  postituse pealkiri:  (teema puudub)  

ottmaaten20 kirjutas:
Kõik kompileerus - Digidoc4 avaneb - allkirjastamisel veateade:
ASiC_E.cpp:348 Failed to sign BDOC container.
QSigner.cpp:482 Dokumendi allkirjastamine ebaõnnestus

terminalis:
qdigidoc4.QSigner: Read sign cert "xxxxxxxxxx"
qdigidoc4.QSigner: Cert is empty: false
qdigidoc4.QSmartCard: Polling
qdigidoc4.MainWindow: Select card "xxxxxxxxxx"
qdigidoc4.QSmartCard: Polling


tundub, et sign serti ei loe välja, kas see loeb serdi välja?

pkcs15-tool -r 02

ja kas testlehel SIGN töötab?

https://hwcrypto.github.io/hwcrypto.js/sign.html

proovisin oma vboxis Xubuntu 18.04 i386 Digidoc4 ja sain allkirjastada:

Image


ottmaaten20
Pingviini kasutaja
Pingviini kasutaja


Vanus: 52
Liitunud: 31.10.2008
Postitused: 66

Distributsioon: Xubuntu 14.04
estonia.gif
postituspostitatud: 09.05.2018, 20:27  postituse pealkiri:  (teema puudub)  

pkcs15-tool -r 02
loeb serdi välja (kena pikk rida)

küll aga testlehe SIGN annab igas variandis veateate:

This is sign.html 0.0.10 running on
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

sign() clicked on Wed, 09 May 2018 18:24:42 GMT
Signing SHA-1: c33df55b8aee82b5018130f61a9199f6a9d5d385
Debug: hwcrypto.js 0.0.13 with failing backend No implementation
getCertificate() failed: Error: no_implementation

Kompileeritud sortsust on ainult OpenSC, questeid, qdigidoc, libdigidocpp, Digidoc4, arvatavasti on midagi puudu...


123to
Pingviini aktivist
Pingviini aktivist



Liitunud: 31.05.2014
Postitused: 120

Distributsioon: Xubuntu 18.04 i386, x64
estonia.gif
postituspostitatud: 09.05.2018, 23:26  postituse pealkiri:  (teema puudub)  

kes kasutab home kataloogi krüptimist, siis võiks veel ülekolimisega oodata.

https://bugs.launchpad.net/ubuntu/+source/fscrypt/+bug/1768340


vooler3
Vana Pingviin
Vana Pingviin



Liitunud: 21.12.2015
Postitused: 446


blank.gif
postituspostitatud: 12.05.2018, 09:17  postituse pealkiri:  (teema puudub)  

Paistab, et lähebki "seda teed mööda" - nagu on ka varem oletatud.

Et selle aasta sügiseks - kui tuleb välja Ubuntu 18.10, siis ei kaob ka "sõprade Distrodest" 32-Bit tugi lõplikult.

Järgmises loos on siis juttu sellest, et Lubuntu, Kubuntu & Xubuntu "jätavad samuti hüvasti 32-Bit maailmaga".

Lubuntu, Kubuntu & Xubuntu Might Also Drop Support for New 32-Bit Installations

https://news.softpedia.com/news/lubuntu-kubuntu-xubuntu-might-also-drop-support-for-new-32-bit-installations-521079.shtml


estysoft
Pingviini aktivist
Pingviini aktivist


Vanus: 35
Liitunud: 13.07.2006
Postitused: 129

Distributsioon: Debian GNU/Linux
estonia.gif
postituspostitatud: 24.05.2018, 22:07  postituse pealkiri:  (teema puudub)  

Huvitav kuidas selle stabiilusega on? Eriti kui keegi kde'd proovinud on. 17.10 jookseb see paar korda päevas kokku. Kasutan mingit plasma restardi skripti.


Näita (aja järgi):      
Postita uus teemaVasta teemale


Vaata järgmist teemat
Vaata eelmist teemat
Powered by phpBB2 Plus based on phpBB © 2001/7 phpBB Group